Login / Register 0 items | $0.00 New @ KVR
adg21
KVRer
 
1 post since 26 Jul, 2011
So is there an old version that will pass midi CC thru? I see that it was once implemented.

I mean I know it might crash some things and some others, but without pass thru CC to control basics like filter on my target VST it is pretty unusable.

Maybe implementing an option on or off for this would be ideal in future. In the mean time an old version which allows for passing of CC would be great if anyone can help.

Thanks
User avatar
DuX
KVRAF
 
3629 posts since 14 Mar, 2002, from Underworld
I'd be interested in a version that passes through the CCs, too. It's pretty essential for a MIDI plugin that goes in front of a VST synth to be able to pass through MIDI.

Although I could circumvent that in Reaper by creating a separate track for BlueARP and send MIDI from it anywhere I want. It is a waste of track [space], though, making two tracks for every sound.
It is no measure of health to be well adjusted to a profoundly sick society.
User avatar
graywolf2004
KVRist
 
457 posts since 15 Apr, 2012, from Moscow, Russia
DuX wrote:I'd be interested in a version that passes through the CCs, too. It's pretty essential for a MIDI plugin that goes in front of a VST synth to be able to pass through MIDI.

Although I could circumvent that in Reaper by creating a separate track for BlueARP and send MIDI from it anywhere I want. It is a waste of track [space], though, making two tracks for every sound.


I gonna make it configureble in hardware version, so software will get it too. Not the next one, likely v227.
User avatar
graywolf2004
KVRist
 
457 posts since 15 Apr, 2012, from Moscow, Russia
Hi all. I apologize for rare posts. Again, free time is my most scarce resource.
Although I'm working mostly on HW version, I did some for the plugin.
Since I got several complainеs about new "page system", I expanded the left panel, so now all the controls are again on the screen without page switching.
GUI became a little wider, but I think it's not a problem cause everyone got fullHD these days.

What do you think? (screenshot attached)
BlueARP_v226.png


other page - is what you change rarely
BlueARP_v226_p2.png


I can't give it out yet, needs some more testing, couple of weeks I think.
You do not have the required permissions to view the files attached to this post.
User avatar
phreaque
KVRian
 
679 posts since 16 Jul, 2007, from Baghdad-Iq
Awesome update dearest Oleg,
Thanks for your efforts indeed.

Btw, there was a glitch in page buffer, when trying to copy page content to other page within the same preset (initial preset).
Copying/pasting will give only 1 step as a result in stead of whole page..
Phreaque Modi
User avatar
DuX
KVRAF
 
3629 posts since 14 Mar, 2002, from Underworld
Neat. :tu:

You must be making some space available for additional features in the future? ;)
It is no measure of health to be well adjusted to a profoundly sick society.
Halonmusic
KVRAF
 
1517 posts since 13 Nov, 2015, from Norway
Kewl :tu:
chk071
KVRAF
 
16765 posts since 10 Apr, 2010, from Germany
998 pixels wide should also work on laptops with lower (1366x768) resolution. :)
User avatar
Niowiad
KVRist
 
190 posts since 25 Jan, 2017
It probably looked better before but this way its more functional so I prefer it in this new version any day.

I adore this plugin. I feel like it is underappreciated because of its 'freebie' status.

Sure thing I'm not the first guy to say this, but make a modern-looking GUI (more appealing and marketable) and start selling this thing. I'd take this over Cthulhu even if it was priced twice as much.
chk071
KVRAF
 
16765 posts since 10 Apr, 2010, from Germany
Niowiad wrote:It probably looked better before but this way its more functional so I prefer it in this new version any day.

TBH, i also liked it better, when the sequencer window was bigger, compared to the tool window. Looked more "focused", because the sequencer window is the window you spend most of your time in.
User avatar
graywolf2004
KVRist
 
457 posts since 15 Apr, 2012, from Moscow, Russia
DuX wrote:Neat. :tu:
You must be making some space available for additional features in the future? ;)

There's still some extra space on the current panel.
When it runs out, moving to another pages is inevitable. But still the main panel should be big ebough to keep the essentials.

phreaque wrote:Awesome update dearest Oleg,
Thanks for your efforts indeed.

Btw, there was a glitch in page buffer, when trying to copy page content to other page within the same preset (initial preset).
Copying/pasting will give only 1 step as a result in stead of whole page..

I'll check this, should be easy to fix.
cobra22
KVRer
 
1 post since 9 Apr, 2018

AUTO-ADMIN: Non-MP3, WAV, OGG, SoundCloud, YouTube, Vimeo, Twitter and Facebook links in this post have been protected automatically. Once the member reaches 5 posts the links will function as normal.

I get frequent crashes using BlueArp.

VST Host maker (Tracktion) points finger to BlueArp, they say ask vendor for VST3 or new/fixed VST2,
but I see no other reports of other hosts having issue, so wondering how to resolve.

log: https://i.imgur.com/Mta6dbk.png (https://i.imgur.com/Mta6dbk.png)
User avatar
graywolf2004
KVRist
 
457 posts since 15 Apr, 2012, from Moscow, Russia
syncopath wrote:Hi.
I have had the same problem as people above in the thread.

The program bank was blocked onto the first one and it was useless trying to make any change on it.

How could I "solve" this? Just clicking on the MENU button and choosing BANK >> Initialize. But the thing is that I had to do the same each time I was adding this VST to any track, so I saved a preset for that device into Bitwig.

But, on the other hand, I might have another bug to mention: I think that the whole "PAGE" menu isn't working at all.

MENU>>>PAGE>>>INITIALIZE/COPY TO BUFFER/PASTE FROM BUFFER.

I'm on Bitwig 2.2.3 using Blue ARP v2.2.5


Finally I made it to install Bitwig 2.2.2 and check this problem.
Yes, it messes up the preset after loading the project.
It seems always to be 1st program in chain 1.
The problem is in current chain setting. Some time ago I made a tweak so automating current chain has full range from chain1 to num_chains, the first value --- (no chain) was excluded. Bitwig seems to set all the parameters after loading the bank, including current chain. It sets the value to chain1 (lowest possible), and saved program number gets messed up.

I changed it back (no other way to fix it).
BlueARP_226_pre.zip


It's win32 dll, can you replace it in v2.5.5 and tell if it works?
You do not have the required permissions to view the files attached to this post.
User avatar
graywolf2004
KVRist
 
457 posts since 15 Apr, 2012, from Moscow, Russia
cobra22 wrote:I get frequent crashes using BlueArp.

VST Host maker (Tracktion) points finger to BlueArp, they say ask vendor for VST3 or new/fixed VST2,
but I see no other reports of other hosts having issue, so wondering how to resolve.

log: https://i.imgur.com/Mta6dbk.png

Can you also try the version from my previous post?
I installed free Tracktion T6 and tested bluearp with it, no problems so far.
User avatar
graywolf2004
KVRist
 
457 posts since 15 Apr, 2012, from Moscow, Russia
phreaque wrote:Awesome update dearest Oleg,
Thanks for your efforts indeed.

Btw, there was a glitch in page buffer, when trying to copy page content to other page within the same preset (initial preset).
Copying/pasting will give only 1 step as a result in stead of whole page..


Fixed, you can try it in version I posted before. Bit it is win32 only yet.
Hopefully next week I'll make it the 'official' release.
PreviousNext

Moderator: KVR Moderators (Main)

Return to Instruments