Login / Register  0 items | $0.00 New#KVRDeals
FathomSynth
KVRist
 
275 posts since 25 Mar, 2017, from Philadelphia, PA, USA

Postby FathomSynth; Mon Sep 11, 2017 8:48 am Re: Fathom 1.0.13 Released

RPH,

(1) Could you send me the preset "PulseFM" which is having the problem.

(2) Also, I'm not seeing any difference before and after loading the GUI with SawPulsePWMbass.
Is there a later version of that preset you could send me?

(3) Do you have any other DAW's than FL Studio, does it happen with those DAW's also?

(4) Also, is the problem only happening with Waveforms Pulse and FM?
If not, please send me a preset with the same problem without using Pulse with FM.

Using Pulse with FM is using an unbalanced waveform with FM and it will normally create
such strange and distorted results, that it's difficult to tell when there is a bug and when there isn't.

(5) If you could send me a FM preset that is more normal sounding that has the before and after GUI
loading distortion problem, then it will be easier for me to debug.

Thanks!
RPH
KVRian
 
966 posts since 20 Nov, 2005, from The Netherlands

Postby RPH; Mon Sep 11, 2017 9:55 am Re: Fathom 1.0.13 Released

1:
PulseFM(new).zip


2:
SawPulsePWMbass.zip

This should be the same version as you have.

3: I tried in Renoise, there the same thing happens with PulseFM(new).
Good thing I keep all updates of Fathom, installed version 1.0.12 (32bit) and placed my presets there.
When I then load up the preset it sounds how it should sound.

I made a video comparing the previous update with this update, only difference is 32 vs 64 bit.

Download ( rightclick > save-as ): Video comparison

Note: sorry i thought you were talking about pulseFM, also made a video of SawPulsePWMbass:
First the previous version, dist amount is correct.. nice and crunchy. Next the new update with weird dist.

Download: Video comparison 2

4: I'll go thru all my presets, I only found out after going thru my song ideas.

5: It's difficult for me to create something normal sounding :party: :wink:
Sure, i'll do some more testing and share the preset here.


Edit:
Checked all my presets, only both PulseFM presets and SawPulsePWMbass sound weird.
I'll do some more digging, probably some modulator causing this.

Edit2:

In Renoise also with the previous version of Fathom the GUI bug is there.
I'll strip the preset to see which component is the cause.
You do not have the required permissions to view the files attached to this post.
RPH
KVRian
 
966 posts since 20 Nov, 2005, from The Netherlands

Postby RPH; Mon Sep 11, 2017 10:36 am Re: Fathom 1.0.13 Released

GUI bug:
Found the problem after stripping my preset, it's NOT an audiocomponent but the polar morph filter..
When I save my project, close Renoise, then restart it and load my project...there is no sound untill I open the GUI.

To reproduce:
Start a testproject with some notes. Strip all components from SawPulsePWmbass except Analog SAW and Filter Pol.
Save the preset, close the application, reopen it, load the testproject and press play ( you'll hear nothing ). Then open the GUI to get sound back.

This also happened in the previous version of Fathom.

Cheers!

Rob.
FathomSynth
KVRist
 
275 posts since 25 Mar, 2017, from Philadelphia, PA, USA

Postby FathomSynth; Mon Sep 11, 2017 11:21 am Re: Fathom 1.0.13 Released

Great detective work!

OK, I found both problems (its actually 2 problems).

The polar filter was always broken, and the audio is silent until the GUI is loaded
because it was never saving the polar points to xml, which is why loading the GUI
which sends the view points to the processor fixes it.

The FM distortion is caused by an experiment I made in the last release,
of using modulated parameters in the FM Modulator when it is fed into the FM Carrier.

I did this because I thought people might like to modulate parameters in the FM modulator object,
but it was not realistic, because it breaks backwards compatibility with everyone's current presets,
which you discovered.

Also, FM is already complex enough if the Carrier parameters are modulated,
and using the modulated version of the object for the FM Modulator, creates
such a complex waveform it just sounds like distorted mush.

So I'll change it back to the way it was.

Tomorrow I'll give you a test release to verify both problems, and then I'll issue a global bug fix release.
RPH
KVRian
 
966 posts since 20 Nov, 2005, from The Netherlands

Postby RPH; Tue Sep 12, 2017 9:40 am Re: Fathom 1.0.13 Released

FathomSynth wrote:
So I'll change it back to the way it was.

Tomorrow I'll give you a test release to verify both problems, and then I'll issue a global bug fix release.


Ah, good that you found the issues.
Sure, send me the test release when done! :tu:
FathomSynth
KVRist
 
275 posts since 25 Mar, 2017, from Philadelphia, PA, USA

Postby FathomSynth; Tue Sep 12, 2017 8:07 pm Re: Fathom 1.0.13 Released

OK, I fixed both problems.

I sent you a beta release to make sure it works and then I'll issue a global release with the fixes.

Next release after that will include an 8 channel non-linear Phasor.
Something I've been trying to fit in for a long time.
FathomSynth
KVRist
 
275 posts since 25 Mar, 2017, from Philadelphia, PA, USA

Postby FathomSynth; Fri Sep 15, 2017 9:04 am Re: Fathom 1.0.14 Released

Version 1.0.14 Released.

www.fathomsynth.com/updates

It is highly recommended that you update to this version, as it fixes instabilities in the polar morph filter.
cron
KVRAF
 
2865 posts since 27 Dec, 2002, from North East England

Postby cron; Fri Sep 15, 2017 11:06 am Re: Fathom 1.0.14 Released

Many thanks for your hard work and dedication in making this synth the best it can be.

Just to let you know, the video linked in the first post at the very top of this thread no longer works.
User avatar
Yeager
KVRian
 
1103 posts since 28 Jun, 2005

Postby Yeager; Fri Sep 15, 2017 11:45 am Re: Fathom 1.0.13 Released

Thank you,

this is solved after resaving with the right setting :
Yeager wrote:when I recall the preset the “Play Waveform” is reset to "Sin partials" in stead of “Raw Samples”.


This is NOT :(
Yeager wrote:Also it does not display the preset name I have given it in the top bar..
FathomSynth
KVRist
 
275 posts since 25 Mar, 2017, from Philadelphia, PA, USA

Postby FathomSynth; Fri Sep 15, 2017 11:57 am Re: Fathom 1.0.14 Released

cron, thanks so much!

Yeager, did you rename the preset by typing in the top title bar
or by renaming the program name in the program browser list window?

If the later it will only change the file name not the display name.
User avatar
Yeager
KVRian
 
1103 posts since 28 Jun, 2005

Postby Yeager; Fri Sep 15, 2017 12:15 pm Re: Fathom 1.0.14 Released

FathomSynth wrote:Yeager, did you rename the preset by typing in the top title bar
or by renaming the program name in the program browser list window?

If the later it will only change the file name not the display name.


Yeh I think I know what I did (wrong), I think you have to change the name in the topbar and then save the preset, I think I got it now :D :) :tu:
If you leave it blank (the topbar) it saves the preset with the name "program 1" changing that name does indeed not generate a preset name in the topbar, so you have to change the name in the topbar press "save" and it gets the same name in both the topbar and the preset list OR overwrites a preset with the same name *without warning me.
FathomSynth
KVRist
 
275 posts since 25 Mar, 2017, from Philadelphia, PA, USA

Postby FathomSynth; Fri Sep 15, 2017 12:16 pm Re: Fathom 1.0.14 Released

Yes, someone else mentioned that also.
I'll add an overwrite warning in the next release!
User avatar
Yeager
KVRian
 
1103 posts since 28 Jun, 2005

Postby Yeager; Fri Sep 15, 2017 12:27 pm Re: Fathom 1.0.14 Released

FathomSynth wrote:Yes, someone else mentioned that also.
I'll add an overwrite warning in the next release!


:hug:
FathomSynth
KVRist
 
275 posts since 25 Mar, 2017, from Philadelphia, PA, USA

Postby FathomSynth; Fri Sep 15, 2017 10:34 pm Re: Fathom 1.0.14 Released

I just changed the harmonic distortion to use the glide frequency,
this will be included in 1.0.15.

Here's what it sounds like.

http://www.mediafire.com/file/h417hciah ... fathom.mp3
User avatar
ariston
KVRAF
 
3357 posts since 28 Jun, 2009, from Wherever I lay my hat

Postby ariston; Sat Sep 16, 2017 12:36 am Re: Fathom 1.0.14 Released

A quick dumb question, because I haven't been synthing for a while... tried to update Fathom yesterday, but I don't have a password for the zip. It wasn't in my initial purchase mail, maybe the info for that is buried somehwere in this thread. Can someone lend a helping hand?
PreviousNext

Moderator: Moderators (Main)

Return to Instruments