Login / Register 0 items | $0.00 New @ KVR
noiseboyuk
KVRAF
 
2230 posts since 25 Jan, 2007

Postby noiseboyuk; Sat Mar 10, 2018 12:44 pm Re: Spectrasonics sluggish after recent updates?

Echoes in the Attic wrote:Yeah it's weird.

It's just getting better for me. I just loaded Keyscape Grand Piano and it took about 3 minutes. Yikes.


Yikes indeed. 1m 15s for me in Keyscape standalone but - in another shock result - 57s in Omni. That's when I noticed that I had the preload settings in Keyscape higher than they needed to be, and once set as Omni and Trilian I got 54s.
http://www.guyrowland.co.uk
http://www.afterschoolvideoclub.com/
W10 Pro Creators Edition, i7 7820X, 64gb RAM, RME Babyface, 1050ti, PT 2018 Ultimate, Cubase Pro 9
MBP 2015 OSX 10.13.3 2.8ghz 16gb 1TB SSD
Echoes in the Attic
KVRAF
 
5943 posts since 12 May, 2008

Postby Echoes in the Attic; Sat Mar 10, 2018 2:01 pm Re: Spectrasonics sluggish after recent updates?

I was just testing some very basic trilian analog waveforms, loading in a blank Omnisphere patch, just hitting the next arrow. So going through for example things like Jupiter Saw, square etc. First one I timed was 7 seconds! For that super simple sound source. I'm not waiting 7 seconds to try different waveforms.
This is a block of text that can be added to posts you make. There is a 255 character limit. Once I have something clever, I will certainly fill it in.
noiseboyuk
KVRAF
 
2230 posts since 25 Jan, 2007

Postby noiseboyuk; Sat Mar 10, 2018 2:19 pm Re: Spectrasonics sluggish after recent updates?

That's about 1/2 a second on the Mac. I'll test it on Windows tomorrow.
http://www.guyrowland.co.uk
http://www.afterschoolvideoclub.com/
W10 Pro Creators Edition, i7 7820X, 64gb RAM, RME Babyface, 1050ti, PT 2018 Ultimate, Cubase Pro 9
MBP 2015 OSX 10.13.3 2.8ghz 16gb 1TB SSD
GMusic
KVRian
 
572 posts since 26 May, 2009, from California

Postby GMusic; Sat Mar 10, 2018 2:45 pm Re: Spectrasonics sluggish after recent updates?

Lesson learned. Keep all installers of Spectrasonics updates. If a new update gives you issues, expect Spectrasonics to leave you in the dark for weeks or months...
Last edited by GMusic on Sat Mar 10, 2018 10:55 pm, edited 1 time in total.
Ben H
KVRAF
 
1988 posts since 28 Jul, 2003

Postby Ben H; Sat Mar 10, 2018 3:13 pm Re: Spectrasonics sluggish after recent updates?

GMusic wrote:If a new update gives you issues, expect Spectrasonics to leave you in the dark for weeks or months...


It's been 3 weeks since the issue was reported... hardly "months" :roll:

GMusic wrote:Lesson learned. Keep all installers of Spectrasonics updates.


This is true of any software updates. Not just for Spectrasonics.
My main tools: Kontakt 5, Omnisphere 2, Iris 1 (not interested in V2), Padshop Pro, Samplemodeling SWAM and Zebra 2.
Echoes in the Attic
KVRAF
 
5943 posts since 12 May, 2008

Postby Echoes in the Attic; Sat Mar 10, 2018 9:22 pm Re: Spectrasonics sluggish after recent updates?

Actually you can get old installers by going to the legacy section at the bottom of the updates page. I’m trying to decide as the new one has some important updates. But this is painful.
This is a block of text that can be added to posts you make. There is a 255 character limit. Once I have something clever, I will certainly fill it in.
GMusic
KVRian
 
572 posts since 26 May, 2009, from California

Postby GMusic; Sat Mar 10, 2018 10:59 pm Re: Spectrasonics sluggish after recent updates?

Echoes in the Attic wrote:Actually you can get old installers by going to the legacy section at the bottom of the updates page. I’m trying to decide as the new one has some important updates. But this is painful.


Thanks, I did not see that :)

Ben H wrote:
GMusic wrote:If a new update gives you issues, expect Spectrasonics to leave you in the dark for weeks or months...


It's been 3 weeks since the issue was reported... hardly "months" :roll:


Take a look at their version history page. Bug fixes and crashes that were fixed months after the prior update.
Echoes in the Attic
KVRAF
 
5943 posts since 12 May, 2008

Postby Echoes in the Attic; Sat Mar 10, 2018 11:23 pm Re: Spectrasonics sluggish after recent updates?

Yeah they are pretty slow with bugfixes/updates, so I'm pretty worried about the current state of Omnisphere. Plus, I think it's always been not great on PC compared to mac (as the granular comparison shows which has been the case since V2 release), but it's just gotten to the point of being painfully obvious recently I think.
This is a block of text that can be added to posts you make. There is a 255 character limit. Once I have something clever, I will certainly fill it in.
GMusic
KVRian
 
572 posts since 26 May, 2009, from California

Postby GMusic; Sun Mar 11, 2018 12:25 am Re: Spectrasonics sluggish after recent updates?

Echoes in the Attic wrote:Yeah they are pretty slow with bugfixes/updates, so I'm pretty worried about the current state of Omnisphere. Plus, I think it's always been not great on PC compared to mac (as the granular comparison shows which has been the case since V2 release), but it's just gotten to the point of being painfully obvious recently I think.


Don't bother rolling back, especially if you have already applied the latest patches update. I keep getting a warning how the patches were made with a newer version of Omnisphere and may not load properly, EVERY time I select a different patch. And some patches indeed do not load properly.

So...rather than deal with deleting all my patches and starting over again, I guess I'm stuck with this sluggish new update for now. :?
Echoes in the Attic
KVRAF
 
5943 posts since 12 May, 2008

Postby Echoes in the Attic; Sun Mar 11, 2018 1:10 am Re: Spectrasonics sluggish after recent updates?

GMusic wrote:
Echoes in the Attic wrote:Yeah they are pretty slow with bugfixes/updates, so I'm pretty worried about the current state of Omnisphere. Plus, I think it's always been not great on PC compared to mac (as the granular comparison shows which has been the case since V2 release), but it's just gotten to the point of being painfully obvious recently I think.


Don't bother rolling back, especially if you have already applied the latest patches update. I keep getting a warning how the patches were made with a newer version of Omnisphere and may not load properly, EVERY time I select a different patch. And some patches indeed do not load properly.

So...rather than deal with deleting all my patches and starting over again, I guess I'm stuck with this sluggish new update for now. :?


Keep hounding support. They say they haven't received "many" support requests about this. Not sure what that means but everyone has to let them know that it sucks. i honestly don't think anyone in their building is using a windows machine.
Last edited by Echoes in the Attic on Sun Mar 11, 2018 1:12 am, edited 1 time in total.
This is a block of text that can be added to posts you make. There is a 255 character limit. Once I have something clever, I will certainly fill it in.
User avatar
DrGonzo
KVRAF
 
2011 posts since 23 Oct, 2000, from A Swede Living in Budapest

Postby DrGonzo; Sun Mar 11, 2018 1:12 am Re: Spectrasonics sluggish after recent updates?

GMusic wrote:
Echoes in the Attic wrote:I guess I'm stuck with this sluggish new update for now. :?


Not tried it myself but I've heard the support are currently testing new betas at the moment. Maybe you can contact Spectrasonics and see if you can get in to the betas.

/C
Plughugger Sound Design
80s POP for U-HE REPRO
HARDWARE SAMPLER FANATIC - Akai S1100/S950/Z8 - Casio FZ20m - Emu Emax I - Roland S750/DJ70 - Ensoniq ASR10/EPSm
Sparky77
KVRian
 
769 posts since 29 Sep, 2006

Postby Sparky77; Sun Mar 11, 2018 2:17 am Re: Spectrasonics sluggish after recent updates?

Echoes in the Attic wrote:Yeah they are pretty slow with bugfixes/updates....


I hope they improve on this.
--After silence, that which comes nearest to expressing the inexpressible is music.

-Aldous Huxley
noiseboyuk
KVRAF
 
2230 posts since 25 Jan, 2007

Postby noiseboyuk; Sun Mar 11, 2018 8:29 am Re: Spectrasonics sluggish after recent updates?

noiseboyuk wrote:That's about 1/2 a second on the Mac. I'll test it on Windows tomorrow.


Test on Windows I just did (said Yoda). It's slower than on the mac, but it's not a huge difference - feels like there's a tiny hang before it does anything. I'd still say most of those Trilain waveforms load in under a second. For whatever reason Echoes, you're suffering everything about 2-3 times worse than me, but I still agree think things aren't right in a number of ways.

Here's hoping for this beta.
http://www.guyrowland.co.uk
http://www.afterschoolvideoclub.com/
W10 Pro Creators Edition, i7 7820X, 64gb RAM, RME Babyface, 1050ti, PT 2018 Ultimate, Cubase Pro 9
MBP 2015 OSX 10.13.3 2.8ghz 16gb 1TB SSD
Echoes in the Attic
KVRAF
 
5943 posts since 12 May, 2008

Postby Echoes in the Attic; Sun Mar 11, 2018 2:12 pm Re: Spectrasonics sluggish after recent updates?

noiseboyuk wrote:
noiseboyuk wrote:That's about 1/2 a second on the Mac. I'll test it on Windows tomorrow.


Test on Windows I just did (said Yoda). It's slower than on the mac, but it's not a huge difference - feels like there's a tiny hang before it does anything. I'd still say most of those Trilain waveforms load in under a second. For whatever reason Echoes, you're suffering everything about 2-3 times worse than me, but I still agree think things aren't right in a number of ways.

Here's hoping for this beta.


In fairness 7 seconds was definitely one of the longer ones that happened. It’s unpredictable and varies randomly, but is often more like 2 seconds. I still think that’s too much for a light sound source change and trilian is always under a second. Well at least I’ll be changing to a new laptop so maybe that will improve a bit. Though I’ve already got an ssd.

Thanks for testing the trilian waveforms. Either way though the bigger sound sources are appalling. I also get quite slow load times on many of the soundscapes and things that have small soundsources.
This is a block of text that can be added to posts you make. There is a 255 character limit. Once I have something clever, I will certainly fill it in.
User avatar
Aloysius
KVRAF
 
21649 posts since 11 Aug, 2008, from a computer

Postby Aloysius; Sun Mar 11, 2018 3:07 pm Re: Spectrasonics sluggish after recent updates?

Should have gone to Specsavers, not Spectrasonics.
Impeach 64. Keep 32-bit Plug-ins alive.
PreviousNext

Moderator: Moderators (Main)

Return to Instruments