Login / Register  0 items | $0.00 New What is KVR? Submit News Advertise

Bug reports

musicdevelopments
KVRAF
 
1886 posts since 9 Jan, 2010

Postby musicdevelopments; Wed Jan 11, 2017 1:18 am Re: Bug reports

I am investigating the issues with track deletion.
How did you create the tracks? Did you import MIDI?
Will you tell me how to reproduce this step by step?

Thank you!
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions
NJ24
KVRer
 
27 posts since 8 Nov, 2016

Postby NJ24; Wed Jan 11, 2017 1:34 am Re: Bug reports

i did import a midi, but then i don't remember how i added tracks(i think i added a blank track and can't dele it), but yes track with imported midi gets deleted.
NJ24
KVRer
 
27 posts since 8 Nov, 2016

Postby NJ24; Wed Jan 11, 2017 4:34 am Re: Bug reports

sometimes i get 'undo not allowed during playback' in VST mode even if DAW is stoped.
musicdevelopments
KVRAF
 
1886 posts since 9 Jan, 2010

Postby musicdevelopments; Wed Jan 11, 2017 4:52 am Re: Bug reports

NJ24 wrote:sometimes i get 'undo not allowed during playback' in VST mode even if DAW is stoped.

Good catch, NJ24! I found and fixed this bug today.
Thanks,
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions
Nextom
KVRist
 
94 posts since 26 Sep, 2015

Postby Nextom; Sun Feb 12, 2017 9:50 am Re: Bug reports

Hi Attila,

the preview in the Chord-Suggestions-window doesn't seem to work, while I'm in the Idea-tool.
You do not have the required permissions to view the files attached to this post.
musicdevelopments
KVRAF
 
1886 posts since 9 Jan, 2010

Postby musicdevelopments; Mon Feb 13, 2017 8:23 am Re: Bug reports

Hi Nextom,
I tried this on OS X and Windows but could not reproduce it. I suppose the chord preview worked outside the Idea Tool. I find no explanation for this at the moment.
Thanks,
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions
User avatar
BlackWinny
KVRAF
 
2806 posts since 17 Jun, 2013, from very close to Paris, France

Postby BlackWinny; Sat Feb 25, 2017 12:48 pm Re: Bug reports

Hello Attila!

A few minutes ago I just installed RC (last beta) on my wife's machine (to try some dialogs between the two machines via the local network).

It was the first time RC is installed on her machine.

When running RC for the first time (to enter the key code) I observed a behavior which could be misinterpreted by a new user and which can probably be fixed very easily: after having pasted the key code it is required to press Enter by the finger BEFORE clicking the validation button. If this pressure on the key 'Enter' by the finger is not made, the little window loops on the demand without telling why. A new user will probably wonder what happens. Maybe the step of a pressure on the key 'Enter' could be avoided before clicking on the button with the mouse... or be immediately considered as the validation of the submission as well as the click with the mouse on the button.
Build your life everyday as if you would live for a thousand years. Marvel at the Life everyday as if you would die tomorrow.
musicdevelopments
KVRAF
 
1886 posts since 9 Jan, 2010

Postby musicdevelopments; Sun Feb 26, 2017 7:35 am Re: Bug reports

Thank you, BlackWinny, I'll definitely check this!
Another issue for the new user causes me headache: sometimes Windows inserts a different character for hyphen '-' when it pastes the license key which the program does not recognize. I have to fix this too.

Thanks!
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions
Previous

Moderator: musicdevelopments

Return to MusicDevelopments