Login / Register  0 items | $0.00 NewWhat is KVR? Submit News Advertise

Focusrite 2i2 and Rapidcomposer

kolderns
KVRer
 
2 posts since 11 May, 2017

Postby kolderns; Thu May 11, 2017 5:12 am Focusrite 2i2 and Rapidcomposer

I just downloaded Rapidcomposer on Windows 10. I followed the tutorial and when I try to play anything it's slow and cracks and pops. What do I need to do to get this working on Windows 10 with Focusrite 2i2?
Boone777
KVRist
 
432 posts since 8 Aug, 2011

Postby Boone777; Thu May 11, 2017 8:23 am Re: Focusrite 2i2 and Rapidcomposer

Have you checked the latency settings in RC ?
Win 7, 64Bit, 16 Gig RAM, Intel i7 Quad 3.9, Reaper, Steinberg MR816x
bvbolli
KVRer
 
7 posts since 31 Dec, 2016

Postby bvbolli; Thu May 11, 2017 8:29 am Re: Focusrite 2i2 and Rapidcomposer

Hi,

i had some problems after the Windows 10 Creators Update with my Scarlett 2i2 and i tried different driver versions for the 2i2.
The driver, i am using now is from the Focusrite Beta site and is Version V4.26.0.
The file to install the driver is named "FocusriteUSBInstaller 4.26.0.183.exe".
With this all my music software is running fine - only RapidComposer shows a strange behaviour.
Playing produces cracks an pops like the o.p. said.
But I noticed, when i open the Asio Control Panel from the Settings -> Audio in RC, Audio is 100% ok!
As soon as i close the Asio Control Panel, audio is bad again.
And another thing i noticed with the driver V4.26.0 is, that it does not like the Windows Quick start. So configure your Windows to do a normal boot.
Attila, could you imagine, why there is this strange behaviour with the Asio Control Panel and Play in RC?
If you want, i can make video of it.

Olaf
musicdevelopments
KVRAF
 
2040 posts since 9 Jan, 2010

Postby musicdevelopments; Thu May 11, 2017 9:04 am Re: Focusrite 2i2 and Rapidcomposer

I also use a Scarlett 2i2 for a long time with driver v2.5.128.1. (The drivers are one of the worst in the industry, just like the support which refused to send me the latest driver when I asked. :x )
I am using Windows10 and luckily so far I had no issues with RapidComposer and Scarlett 2i2.
I think you should try to change the latency settings, as Boone777 suggested.
A good idea is to start RapidComposer with the Alt key held down as described on
http://www.musicdevelopments.com/wiki/doku.php?id=en:troubleshooting:troubleshooting
RC will start without audio, and you can set up audio under Settings / Audio.
This way RC will use the default values for buffer size and sampling rate.

It is very strange that the audio is good when the control panel is open. At the moment I can't find an explanation for that. I'll investigate.

Thanks,
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions
bvbolli
KVRer
 
7 posts since 31 Dec, 2016

Postby bvbolli; Thu May 11, 2017 12:15 pm Re: Focusrite 2i2 and Rapidcomposer

Hi Attila,

i just downloaded the new beta of RapidComposer and a new driver for the Scarlet 2i2.
Same strange behaviour with the Asio Control Panel.

In case you want to investigate it further, this is the Website, where i got the driver:
http://beta.focusrite.com/

The driver, i am using now, is the first one the site:
Focusrite USB2 Drivers 4.36.0

Olaf
kolderns
KVRer
 
2 posts since 11 May, 2017

Postby kolderns; Thu May 11, 2017 1:23 pm Re: Focusrite 2i2 and Rapidcomposer

musicdevelopments wrote:It is very strange that the audio is good when the control panel is open. At the moment I can't find an explanation for that. I'll investigate.

Thanks,
Attila

I just tested mine to see if it behaved like bvbolli's did. I opened RC and the phrase editor and played one of the phrases on repeat. Cracks, pops and missing notes. I then opened the control panel. The cracks went away and all the notes played. I then closed control panel and it went back to cracks and missing notes.

The audio is fine in Reaper or other apps.
musicdevelopments
KVRAF
 
2040 posts since 9 Jan, 2010

Postby musicdevelopments; Fri May 12, 2017 5:48 am Re: Focusrite 2i2 and Rapidcomposer

I experienced the same with driver 4.36.0.415!
Somehow this driver behaves differently than previous drivers.
I never had any issues with v2.5.128.1.
I am investigating this.
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions
musicdevelopments
KVRAF
 
2040 posts since 9 Jan, 2010

Postby musicdevelopments; Fri May 12, 2017 6:57 am Re: Focusrite 2i2 and Rapidcomposer

I see, this Focusrite USB driver v4.36.0.415 is a piece of crap as I expected. I'll get back to v2.5.128.1 ASAP.
The problem is that the time between rendering 2 buffers varies greatly, it is sometimes 0.1 msec when I set the buffer period to 10 msec! This is very unfortunate when using double buffering as in RapidComposer because the program is not able to provide the requested samples so quickly, so an underflow occurs.
Rendering a small audio buffer takes 1.2-1.4 msec in RapidComposer. This is a lot, I know it should be optimized, but RC is more complex than a DAW where a track is a series of MIDI events.
I'll see if I can improve audio with such buggy drivers.
Thanks,
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions
bvbolli
KVRer
 
7 posts since 31 Dec, 2016

Postby bvbolli; Fri May 12, 2017 8:40 am Re: Focusrite 2i2 and Rapidcomposer

Hi Attila,

thanks for looking into it!

I was using driver V2.5.1 also for a long time but after the Windows 10 Creators Update i had difficulties with it in many audio apps!
So i was testing all the drivers from the Focusrite Beta site and this driver works with all other audio apps except RapidComposer.
I even have done a clean install of Windows 10 with the Microsoft Media Creator.
It would be nice of you with your background Knowledge, to tell Focusrite what crap the driver is. ;-)

Olaf
bvbolli
KVRer
 
7 posts since 31 Dec, 2016

Postby bvbolli; Fri May 12, 2017 8:50 pm Re: Focusrite 2i2 and Rapidcomposer

Hi Attila,

what i forgot to ask,
As the audio is ok, when the Asio Control Panel is open, is the driver then changing its bad timing behaviour? As the driver is a beta driver, one should really tell Focusrite about it.

Olaf
musicdevelopments
KVRAF
 
2040 posts since 9 Jan, 2010

Postby musicdevelopments; Sat May 13, 2017 2:44 am Re: Focusrite 2i2 and Rapidcomposer

I am not certain why the sound becomes perfect when the ASIO control panel is open, probably because of a thread priority change.

However I have good news: I made improvements in audio rendering (much faster wake-up of the rendering thread and faster rendering =0.4 msec), so RapidComposer seems to work well now with the new driver, even with 2.6 msec buffers (256 samples @ 96kHz). If you don't mind using a beta version, I'll upload a new update tomorrow. [EDIT: v3.3b8 is available now with the fix]

Thanks for reporting this problem. I'll still go back to the old driver because during listening to music with Groove Music I can hear clicks sometimes.

Thanks,
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions
bvbolli
KVRer
 
7 posts since 31 Dec, 2016

Postby bvbolli; Sat May 13, 2017 10:25 pm Re: Focusrite 2i2 and Rapidcomposer

Hi Attila,

thanks so much!
With the new beta Version the play and audio is now perfect!!!

Olaf
musicdevelopments
KVRAF
 
2040 posts since 9 Jan, 2010

Postby musicdevelopments; Sun May 14, 2017 5:26 am Re: Focusrite 2i2 and Rapidcomposer

Happy to hear that!
Thanks for the feedback.
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

Moderator: musicdevelopments

Return to MusicDevelopments