Login / Register  0 items | $0.00 NewWhat is KVR? Submit News Advertise

Using ENV to pan problem

tedoo
KVRer
 
10 posts since 25 Oct, 2016

Postby tedoo; Mon May 15, 2017 9:28 am Using ENV to pan problem

I want to create a doppler effect for a single sample lay'd over a few octaves.

Firstly I want to be able to create a dynamic pan modulation, Ive chosen to use ENV1 as source, PAN as destination. Ive made sure amounts are set to +1.00 and -1.00, and its enabled. Im probly not understanding something but I assumed you could set a tangential ENV shape to mimic something moving from one side to the other, basically just a diagonal ENV, but its kind of working but it wont completely leave the RH or LH speaker, whereas when I move the pan position dial, it does. I want it to completely move from R to L during the course of the sample.

Extra confused because if I use an LFO or SEQ it does completely pan, but I want to use the ENV because I need the higher keys to pan faster than the lower keys, i.e. no matter what pitch I play the sample the middle of the wave is always at the middle pan position, i assumed i could use KEY to do this once I'd sorted the ENV pan how I want it.

I guess the simple question is, can I completely pan left or right using an ENV as source?

Sorry if a bit long, thanks for reading.
elcallio
KVRian
 
1245 posts since 27 May, 2005, from Stockholm

Postby elcallio; Wed May 17, 2017 1:04 am Re: Using ENV to pan problem

Ha. Thanks for spotting this. Seems the MOD ENV got a very nasty bug in an earlier fix, causing negative env points to become truncated as zero -> difficult to pan stuff indeed.
I've fixed this, plus did a slight modification to the timing function to make it sound a bit better. I will update the beta build shortly.
TX16Wx Software Sampler:
http://www.tx16wx.com/
elcallio
KVRian
 
1245 posts since 27 May, 2005, from Stockholm

Postby elcallio; Wed May 17, 2017 3:07 am Re: Using ENV to pan problem

2.4.2e beta build updated.
TX16Wx Software Sampler:
http://www.tx16wx.com/
tedoo
KVRer
 
10 posts since 25 Oct, 2016

Postby tedoo; Wed May 17, 2017 4:10 am Re: Using ENV to pan problem

Brilliant, thanks escallio. Not sure where I can download the beta build from though?

I bought the pro version btw and your prompt customer service was a factor in me purchasing it. Would be cool to have a video tutorial somewhere as well.
DarkStar
KVRAF
 
7898 posts since 2 Sep, 2003, from Surrey, UK

Postby DarkStar; Wed May 17, 2017 4:12 am Re: Using ENV to pan problem

<< link removed - 404 error >>
Last edited by DarkStar on Wed May 17, 2017 5:48 am, edited 1 time in total.
DarkStar
Interesting, if true ...
tedoo
KVRer
 
10 posts since 25 Oct, 2016

Postby tedoo; Wed May 17, 2017 4:42 am Re: Using ENV to pan problem

Sorted-I found the link-it now pans completely, thanks very much : )

Moderator: elcallio

Return to CWITEC