Login / Register 0 items | $0.00 New @ KVR
User avatar
Vortifex
KVRian
 
729 posts since 1 Sep, 2016

Postby Vortifex; Sat Apr 14, 2018 9:59 am KClip 3 demo, several issues in FL Studio 12

Just trying the 64 bit demo in FL Studio 12, Windows 10. I've identified several issues.

When I activate multiband mode it introduces some nasty noise, and not of the clipping kind. Doesn't matter what setting I use on any of the dials, whether or not bands are soloed or bypassed, the crackling is still there. Selecting the various saturation types on any band will cause CPU load within FL's CPU meter to rise almost to maximum, causing more crackling and audio dropouts. These issues are not present in single band mode.

When I first loaded the plugin, changing the quality setting to 5 caused some extreme smearing/distortion but for some reason this went away after 5 minutes or so and I've not been able to replicate it.

Finally, just from a usability point of view, it takes far too much mouse travel to turn the dials. If I put the plugin at the top of my screen (1920x1080) and drag the Mix dial down it only goes to 40% before I have to click it again and continue dragging. Similar issue with the smaller dials in multiband mode.
yaw69
KVRer
 
3 posts since 9 May, 2014

Postby yaw69; Sat Apr 14, 2018 10:54 am Re: KClip 3 demo, several issues in FL Studio 12

Same problem in Logic 10 pro . Multiband sounds like a bitcrusher is used
User avatar
Kazrog
KVRian
 
755 posts since 24 Oct, 2009

Postby Kazrog; Sat Apr 14, 2018 10:59 am Re: KClip 3 demo, several issues in FL Studio 12

Looking into FL Studio issues - I believe it's due to the buffering system in that DAW. I've been trying for a while to get a test copy of FL from Image Line, as it's very frustrating working with the demo as a testing platform. If they don't get back to me soon, I may be forced to start a user petition.

PS - I develop and test in 1920x1080 resolution, and it's fine here. However, mouse travel changes have been a top request, and I'm working on it. In the mean time, use the scroll wheel if you need fast adjustments. 8)
Shane McFee
CEO/CTO - Kazrog LLC
User avatar
EvilDragon
KVRAF
 
16294 posts since 6 Jan, 2009, from Croatia

Postby EvilDragon; Sat Apr 14, 2018 11:37 am Re: KClip 3 demo, several issues in FL Studio 12

Yeah try the fixed buffers option in FL's plugin wrapper.

Kazrog wrote:PS - I develop and test in 1920x1080 resolution, and it's fine here. However, mouse travel changes have been a top request, and I'm working on it. In the mean time, use the scroll wheel if you need fast adjustments. 8)


It's interesting that knobs in Thermionik don't have this issue. Methinks you might have mouse accelleration set a bit too fast on that gaming mouse you use, or something, which then makes it work great on your machine, but not many others. It's always a good idea to have a bog-standard mouse around and test with it, too ;)


That said, I never had issues with THIS slow mouse response with any other plugin... Logitech MX Master mouse here, default DPI setting, default mouse speed in Windows control panel, 1920x1200.
User avatar
Vortifex
KVRian
 
729 posts since 1 Sep, 2016

Postby Vortifex; Sat Apr 14, 2018 12:01 pm Re: KClip 3 demo, several issues in FL Studio 12

EvilDragon wrote:Yeah try the fixed buffers option in FL's plugin wrapper.


Thank you, this fixed the issue.
User avatar
Kazrog
KVRian
 
755 posts since 24 Oct, 2009

Postby Kazrog; Sat Apr 14, 2018 12:07 pm Re: KClip 3 demo, several issues in FL Studio 12

EvilDragon wrote:Yeah try the fixed buffers option in FL's plugin wrapper.

Kazrog wrote:PS - I develop and test in 1920x1080 resolution, and it's fine here. However, mouse travel changes have been a top request, and I'm working on it. In the mean time, use the scroll wheel if you need fast adjustments. 8)


It's interesting that knobs in Thermionik don't have this issue. Methinks you might have mouse accelleration set a bit too fast on that gaming mouse you use, or something, which then makes it work great on your machine, but not many others. It's always a good idea to have a bog-standard mouse around and test with it, too ;)


That said, I never had issues with THIS slow mouse response with any other plugin... Logitech MX Master mouse here, default DPI setting, default mouse speed in Windows control panel, 1920x1200.


I don't use any acceleration. Also, the knobs are working fine on my Mac Mini with stock mouse/settings. But I'll defer to the wisdom of the crowd for the next update.
Shane McFee
CEO/CTO - Kazrog LLC
User avatar
EvilDragon
KVRAF
 
16294 posts since 6 Jan, 2009, from Croatia

Postby EvilDragon; Sat Apr 14, 2018 12:41 pm Re: KClip 3 demo, several issues in FL Studio 12

Kazrog wrote:I don't use any acceleration. Also, the knobs are working fine on my Mac Mini with stock mouse/settings.


Interesting...
User avatar
Gamma-UT
KVRAF
 
4156 posts since 8 Jun, 2009, from UK

Postby Gamma-UT; Sat Apr 14, 2018 11:41 pm Re: KClip 3 demo, several issues in FL Studio 12

The knobs feel slow on this Mac Pro (10.12.6). I'm also getting the bitcrusher noise in multiband mode - no matter the threshold setting.
User avatar
Kazrog
KVRian
 
755 posts since 24 Oct, 2009

Postby Kazrog; Sun Apr 15, 2018 12:23 am Re: KClip 3 demo, several issues in FL Studio 12

Gamma-UT wrote:The knobs feel slow on this Mac Pro (10.12.6). I'm also getting the bitcrusher noise in multiband mode - no matter the threshold setting.


Host?
Shane McFee
CEO/CTO - Kazrog LLC
User avatar
Gamma-UT
KVRAF
 
4156 posts since 8 Jun, 2009, from UK

Postby Gamma-UT; Sun Apr 15, 2018 12:26 am Re: KClip 3 demo, several issues in FL Studio 12

Kazrog wrote:
Gamma-UT wrote:The knobs feel slow on this Mac Pro (10.12.6). I'm also getting the bitcrusher noise in multiband mode - no matter the threshold setting.


Host?


Live 10, Logic X latest - it makes no difference.
User avatar
Kazrog
KVRian
 
755 posts since 24 Oct, 2009

Postby Kazrog; Sun Apr 15, 2018 12:29 am Re: KClip 3 demo, several issues in FL Studio 12

Weird. I'm getting more reports like this, but all is fine in those hosts on my Mac Mini (i5) in High Sierra. Will continue to try to recreate.
Shane McFee
CEO/CTO - Kazrog LLC
User avatar
Kazrog
KVRian
 
755 posts since 24 Oct, 2009

Postby Kazrog; Sun Apr 15, 2018 10:26 am Re: KClip 3 demo, several issues in FL Studio 12

Back to FL Studio - seems like KClip 3 is not alone in needing special setup to work correctly:

https://www.reveal-sound.com/knowledge.php?27-30

I can say unequivocally that any host that dynamically adjusts the buffer will wreak havoc with just about any plugin I'd be likely to make. That is the most idiotic default setting of all time - I can see where it would be cool as an OPTION, but not a default.
Shane McFee
CEO/CTO - Kazrog LLC
User avatar
Vortifex
KVRian
 
729 posts since 1 Sep, 2016

Postby Vortifex; Sun Apr 15, 2018 2:24 pm Re: KClip 3 demo, several issues in FL Studio 12

Even with the fixed buffer option selected in FL my CPU is maxed out when I change the saturation modes. This is only within FL's CPU meter, which doesn't reflect actual CPU usage. In Task Manager CPU only went up by about 2%.

When people bring these issues regarding CPU to the attention of the FL devs they become quite defensive about it. For example, certain patches on VST synths will make FL crap out, whereas in other DAWs the CPU hit is small. It's a longstanding issue with FL and I don't think it'll ever be resolved.
User avatar
Kazrog
KVRian
 
755 posts since 24 Oct, 2009

Postby Kazrog; Sun Apr 15, 2018 7:27 pm Re: KClip 3 demo, several issues in FL Studio 12

I really try to be sparing in my criticism of DAWs. A lot of work goes into them. However, this sort of behavior is maddening for devs like me.
Shane McFee
CEO/CTO - Kazrog LLC
User avatar
Kazrog
KVRian
 
755 posts since 24 Oct, 2009

Postby Kazrog; Mon Apr 16, 2018 10:03 am Re: KClip 3 demo, several issues in FL Studio 12

Good news! Image Line got back to me. I'll be testing all future releases in FL Studio. Big thanks to the Image Line team!

Critiques aside, I'm looking forward to learning more about their platform. It is really interesting.
Shane McFee
CEO/CTO - Kazrog LLC

Moderators: Moderators (Main), Kazrog Mods

Return to Kazrog