Login / Register  0 items | $0.00 NewWhat is KVR? Submit News Advertise
User avatar
moss
KVRian
 
1081 posts since 12 May, 2004

Postby moss; Mon Jun 05, 2017 1:15 pm Re: Arturia Beatstep and Beatstep Pro support is here

turbo_kev wrote:Moss help what is going on here

https://youtu.be/mc9P5oy94yw

cheers
Kev


OK, I could reproduce both:

1) This is a Bitwig bug, which I reported to them. It happens with every midi device, might be only happening on Windows.

2) Sequencer channels were interpreted like the controller channel, which caused some chaos. Will be fixed in the next version.

Thanks for reporting!
turbo_kev
KVRist
 
373 posts since 18 Dec, 2014

Postby turbo_kev; Tue Jun 06, 2017 11:43 pm Re: Arturia Beatstep and Beatstep Pro support is here

Here is the screen shot you wanted
You do not have the required permissions to view the files attached to this post.
BitWig , Spark LE , V Collection 4, BeatStep, BeatStep PRO
Keylab 25 , Axiom pro 49, Focusrite Scarlett 8i6, Launchpad Pro
KRK Rokit 10/3 ref speakers,win 10 pro 64 bit, i7 5820k 4ghz , 16 gig ddr 4 , 500gig ssd, msi x99a sli + , Nvidia GF Gt 710,
User avatar
moss
KVRian
 
1081 posts since 12 May, 2004

Postby moss; Sun Jun 25, 2017 8:55 am Re: Arturia Beatstep and Beatstep Pro support is here

Update day!

Get it from: http://mossgrabers.de/Software/Bitwig/Bitwig.html

# 4.01
  • New: The hardware sequencer is now split up into a separate channel, so you can use it with Bitwig as well. To make this work reinstall the Template coming with the Extension. Note that the button colors are still overwritten when you use the sequencer.
  • Fixed: Wrong name for Midi input (displayed Launchpad)
  • Fixed: (Beatstep Pro) The name of the "Control" channel of the Pro was wrong (was "Beatstep Pro").
  • Fixed: (Beatstep Pro) Sequencers channels were interpreted as controller channel, which caused some chaos
  • Fixed: (Beatstep Pro) The step buttons did not work (they do what the Shift menu does on the Beatstep)
sawtdk
KVRer
 
2 posts since 22 Mar, 2008

Postby sawtdk; Wed Jul 05, 2017 2:07 am Re: Arturia Beatstep and Beatstep Pro support is here

Hello moss,
Thank you for the update..

After I installed the update (and update the template on the beatstep) the shift button is sending a midi note signal to Bitwig when I press it. It's a bit unconvenient. Have you noticed this behaviour?
User avatar
moss
KVRian
 
1081 posts since 12 May, 2004

Postby moss; Sat Jul 08, 2017 2:28 am Re: Arturia Beatstep and Beatstep Pro support is here

sawtdk wrote:After I installed the update (and update the template on the beatstep) the shift button is sending a midi note signal to Bitwig when I press it. It's a bit unconvenient. Have you noticed this behaviour?


Sorry, but I cannot replicate that.
E.D.L.
KVRer
 
5 posts since 11 Sep, 2014

Postby E.D.L.; Fri Sep 08, 2017 7:08 am Re: Arturia Beatstep and Beatstep Pro support is here

Tried the new extension but I noticed that the up/down function in drum sequencer mode doesn't work properly.

I'm using Bitwig's Drum machine and in drum play mode, the pads are always playing from C1 to Eb2 independently from the up/down settings. Is this a normal behaviour?

Also if I add new single drums sounds to the drum machine, the pads will be lit incorrect: a completely different pad is lit where no sound entered and the pad of the added sound isn't lit.

Im using the latest Bitwig 2.x and of course I'm using the latest Beatstep midi template.

BTW: I'm missing an on-screen notification for the (drum) part in dum sequencer mode ... but that's maybe a feature request.
User avatar
moss
KVRian
 
1081 posts since 12 May, 2004

Postby moss; Sat Sep 09, 2017 3:08 am Re: Arturia Beatstep and Beatstep Pro support is here

E.D.L. wrote:I'm using Bitwig's Drum machine and in drum play mode, the pads are always playing from C1 to Eb2 independently from the up/down settings. Is this a normal behaviour?


Hmm, just tried that but it works fine here.
E.D.L.
KVRer
 
5 posts since 11 Sep, 2014

Postby E.D.L.; Tue Sep 12, 2017 1:49 am Re: Arturia Beatstep and Beatstep Pro support is here

... because I wasn't sure about the technical condition of my old Beatstep, I ordered a brand new for testing, but it's the same. Shifting the notes with the Beatstep knob doesn't change anything to the pads ... the shifted note group is visible in Bitwig's devices, but I still play C1 to Eb2 from the pads. Any idea - maybe i configured something bad?! I would really appreciate some thoughts about my problems, moss (or anybody else).

Maybe I have to say, that I'm using a Hackintosh ... but everything works flawless imho (usb, audio, midi etc.)
You do not have the required permissions to view the files attached to this post.
Previous

Moderator: Bitwig Mods

Return to Controller Scripting

Who is online

Users browsing this forum: CCBot (commoncrawl)