Login / Register  0 items | $0.00 NewWhat is KVR? Submit News Advertise

Unable to mute reverb @ Ubuntu

kompik2
KVRer
 
2 posts since 21 Apr, 2012

Postby kompik2; Tue Jan 03, 2017 5:23 am Unable to mute reverb @ Ubuntu

Dear Mark,

I'm trying to use NRPN to control the system effects, have added echo as a first and reverb as a second. Sending these:

B0 63 04 // Select the system effects
B0 62 01 // Select the second effect
B0 06 00 // Select the effect parameter 00
B0 26 7F // Change the parameter of effect to the value 7F (127)

and it changes ok. However I expect if I send B0 26 00 as last line - this will mute reverb. But not the case - it still works at some minimum level. Same with echo. So the question, is this the normal functionality? Is it possible to turn off effect somehow via midi?

Best,
Ihor.
fundamental
KVRist
 
430 posts since 21 Oct, 2008, from USA

Postby fundamental; Tue Jan 03, 2017 9:44 am Re: Unable to mute reverb @ Ubuntu

This appears to be an issue that affects multiple effect types.

For a system-effect reverb instance the volume is calculated at:
https://github.com/zynaddsubfx/zynaddsu ... b.cpp#L218

This puts the output multiplier logarithmically between 1e-8 and 1.0 with different volume settings.

Until this bug is corrected the best way to mute a system effect reverb would be to change it's volume in the system effect routing interface. This can be done through MIDI using the MIDI learn interface, but not through the normal NRPN interface.
One of the developers on the ZynAddSubFX open source synth
The author of the Zyn-Fusion UI for ZynAddSubFX

Moderator: paulnasca

Return to ZynAddSubFX

Who is online

Users browsing this forum: CCBot (commoncrawl)