Login / Register  0 items | $0.00 New
paulnasca
KVRist
 
218 posts since 23 May, 2004

Postby paulnasca; Mon Nov 01, 2004 2:07 pm "ZynAddSubFX VST doesn't work in X or Y" PostHere

I have seen that many topics sounds like this: "ZynAddSubFX VST doesn't work in X".

Please post theese questions or issues report here.
A quick answer. If ZynAddSubFX vst doesn't work in X or Y, please try to use the standalone version.
I will solve theese kind of problems when I can. Now I cannot because 1) the price of Windows, of most vst hosts,etc. are prohibitive for a Romanian programmer. 2) So, I don't use Windows at home: I have only Linux, installed.Anyway, even if I would have windows, I would use only for VST developing&testing, for other stuff, Linux & free/open source software is ok for me. 3) I don't have too much time. I am investing the little free time to write docs and other zynaddsubfx stuff.

Thanks.
Paul
My portfolio:
http://www.paulnasca.com
FaX
KVRAF
 
2072 posts since 23 Sep, 2004, from Canada

Postby FaX; Wed Nov 03, 2004 3:52 pm

Paul it won't work in Live 4.0 and you can downlaod the Host demo for Live 4.0 which will host VSTi's as is without any cash outlay.
If you try it you'll find it crashes Live 4.0 in a Major way I'm afraid - and there's a noticeable midi lag / delay problem via USB controller in stand alone mode with XP pro also.
Links to other media sites and contact details are available at the bottom of my artists website.

http://venndiagram.ca
Matti
KVRer
 
21 posts since 26 Oct, 2004

Postby Matti; Sat Nov 13, 2004 4:51 am

Hello,

which version is ZynAddSubFX?

Is it possible to use ZynAddSubFX with programms that supports VST 2.0 ? I think yes. But what can be the problem that it didn't work.

I'm using MusikMaker (www.magix.com)

How can I help to fix the problem?
----
Regards,
Matti
VariKusBrainZ
KVRAF
 
6708 posts since 16 Dec, 2002

Postby VariKusBrainZ; Sat Nov 13, 2004 6:12 am

FaX wrote:Paul it won't work in Live 4.0 and you can downlaod the Host demo for Live 4.0 which will host VSTi's as is without any cash outlay.
If you try it you'll find it crashes Live 4.0 in a Major way I'm afraid - and there's a noticeable midi lag / delay problem via USB controller in stand alone mode with XP pro also.


Hi,

it worked with a previous verion of Live4 so Im beginning to think the bug is with the latest build of Live4. Fruityloops aslo used to work fine as a VSTi but no longer doe in Live4 :(
Matti
KVRer
 
21 posts since 26 Oct, 2004

Postby Matti; Tue Nov 16, 2004 11:01 am

Hello,

unfortunately it could be a problem by myself.

I played today with the driver options in MusicMaker and got some crashes. After a view crashes and restarts ZynAddSubFX was loaded as VSTi and it works well.

JUCHHHHHHHHHHUUUUUUUUUUUU!!! I'm sooooooo happy !!!!!!!
----
Regards,
Matti
tERMoBLUe
KVRian
 
1300 posts since 26 May, 2003, from im müscha...

Postby tERMoBLUe; Wed Nov 17, 2004 7:09 am

really nice ;) ...cool works in fruity - and no problems...i search more presets...I have already made some myself, how must load these on the new one again and again...the plug not find the song-patches :cry: ...but i'm very about this one sounded enthusiastic...thx...cya

tro
egbert
KVRAF
 
3907 posts since 20 Oct, 2001, from my bolthole in the south pacific

Postby egbert; Wed Nov 17, 2004 7:27 am

ZynAddSubFX crashes SX3 during sequencer startup. If I remove it from the VstPlugins directory (Logic/Vstplugins) the problem goes away.

Eg
Matti
KVRer
 
21 posts since 26 Oct, 2004

Postby Matti; Sun Nov 28, 2004 8:47 am

Hello,

I will chanbe my sequenzer software to Tracktion.
Only ZynAddSubFX didn't work. :-(

Is here anybody who works with Tracktion and can use ZynAddSubFX?
----
Regards,
Matti
Armadillo
KVRAF
 
1922 posts since 30 Dec, 2002, from London, UK

Postby Armadillo; Sun Nov 28, 2004 9:16 am

egbert wrote:ZynAddSubFX crashes SX3 during sequencer startup. If I remove it from the VstPlugins directory (Logic/Vstplugins) the problem goes away.

Eg


The same happens with Cubase SE, which is not that surprising I suppose.
Image
beanie
KVRist
 
109 posts since 13 Jul, 2004

Postby beanie; Sun Nov 28, 2004 11:48 pm

Hi Nasca,

I took a look at the sourcecode. Zynaddsubfx's setchunk and getchunk are missing a parameter. So you defined two new functions by "overloading" them instead of "overriding" them.

Defined in Vstsdk 2.3 audioeffect.h:

virtual long getChunk (void** data, bool isPreset = false) { return 0; }
virtual long setChunk (void* data, long byteSize, bool isPreset = false) { return 0; }

Defined in zynaddsubfx's main.C:

long VSTSynth::getChunk(void** data)
{
int size=0;
size=vmaster->getalldata((char **)data);
return(size);
};

void VSTSynth::setChunk(void *data,long size)
{
vmaster->putalldata((char*)data,size);
};

Both are missing the "bool isPreset" parameter. Also, both return "size" which is type "long". Fix them and parameter saving should work.
Matti
KVRer
 
21 posts since 26 Oct, 2004

Postby Matti; Sat Dec 04, 2004 2:16 am

ZynAddSubFX didn't save the settings, where the banks are and so on:
http://www.kvr-vst.com/forum/viewtopic.php?t=65711

What do I wrong?
----
Regards,
Matti
snooky
Banned

Postby snooky; Sat Dec 04, 2004 4:02 am

beanie wrote:Hi Nasca,

I took a look at the sourcecode. Zynaddsubfx's setchunk and getchunk are missing a parameter. So you defined two new functions by "overloading" them instead of "overriding" them.

Defined in Vstsdk 2.3 audioeffect.h:

virtual long getChunk (void** data, bool isPreset = false) { return 0; }
virtual long setChunk (void* data, long byteSize, bool isPreset = false) { return 0; }

Defined in zynaddsubfx's main.C:

long VSTSynth::getChunk(void** data)
{
int size=0;
size=vmaster->getalldata((char **)data);
return(size);
};

void VSTSynth::setChunk(void *data,long size)
{
vmaster->putalldata((char*)data,size);
};

Both are missing the "bool isPreset" parameter. Also, both return "size" which is type "long". Fix them and parameter saving should work.


So, did Paul ever get those lines fixed? Have you tried e-mailin' him?

Btw, ZynaddsubFX is my fav synth!
Got some mates around and they were blown away by it!
paulnasca
KVRist
 
218 posts since 23 May, 2004

Postby paulnasca; Sun Dec 05, 2004 2:39 am

Thanks for telling me.
I will fix this.
Paul
My portfolio:
http://www.paulnasca.com
nolus
KVRer
 
1 post since 12 Dec, 2004

Postby nolus; Sun Dec 12, 2004 9:52 am

If you have a copy of Energy XT you can use it to get around most "synth X does not work in Host Y" problems.

Energy XT is a plugin that can host other plugins (and a lot of other things).

Instead of opening the synth directly in your host open the Energy XT plugin instead. Then open the problem plugin within Energy XT.

I successfully got ZynAddSubFx working with Live 4 using this method.
amgo
KVRer
 
1 post since 8 Mar, 2005

Postby amgo; Tue Mar 08, 2005 1:29 pm

cubase sx2.0 - NOT WORKING. :///
(crashes during plugin init)

buzz - working.
psycle - working ok.
Next

Moderator: paulnasca

Return to ZynAddSubFX