Login / Register  0 items | $0.00 NewWhat is KVR? Submit News Advertise

LiveSlice 1.48 beta thread

DarkStar
KVRAF
 
7924 posts since 2 Sep, 2003, from Surrey, UK

Postby DarkStar; Thu Apr 16, 2009 7:23 am

GilJ wrote:
ohm wrote:Todays update is out :-)

- fixed crash when dragging multiple files to loops list
- browser: fixed little scrolling bug when using arrow keys and page down
- browser: fixed plus and minus keys not working correctly after previewing a file
- browser: fixed bug with plus key on the last item in the browser causing a crash
- the "default samples directory" text fields and browse buttons didn't work - fixed
- fixed "locate slice" button got stuck sometimes


Hi,

Mouse wheel is broken again :(

Cheers,
GilJ.


... it's Ok here in EXT1 and Reaper2. I've got the Steal and Read keyboard options set. How it is broken for you?
DarkStar
Interesting, if true ...
GilJ
KVRist
 
233 posts since 16 Mar, 2005

Postby GilJ; Thu Apr 16, 2009 7:59 am

DarkStar wrote:... it's Ok here in EXT1 and Reaper2. I've got the Steal and Read keyboard options set. How it is broken for you?


Thanks, you're right DarkStar!
When "Steal keyboard focus from host" is enabled, mouse wheel works again :)

So as to be forgiven for my mistake, here is a couple of B.R :wink: :

[LiveSlice v1.5rc3]
BR1/ Event display not being updated correctly
1- Let's say we have a loop loaded in the slicer with two slices [A|B]
2- Lock to loop
3- In the slicer, delete the marker between A and B
:?: The event's display doesn't get updated

BR2/ The number box of the number of events doesn't get updated when increasing/decreasing value with mouse wheel


Cheers,
GilJ.
DarkStar
KVRAF
 
7924 posts since 2 Sep, 2003, from Surrey, UK

Postby DarkStar; Thu Apr 16, 2009 8:28 am

Both confirmed here.
They look like display-refresh issues to me.
DarkStar
Interesting, if true ...
ohm
KVRAF
 
1520 posts since 2 Jul, 2004

Postby ohm; Thu Apr 16, 2009 11:41 am

GilJ wrote:Hi,

Mouse wheel is broken again :(

Cheers,
GilJ.


doh... thanks. yes I uncommented that line when I was debugging another issue... all fixed now.
http://www.livelab.dk - slice up your life
ohm
KVRAF
 
1520 posts since 2 Jul, 2004

Postby ohm; Wed Apr 22, 2009 1:07 am

GilJ wrote:
DarkStar wrote:... it's Ok here in EXT1 and Reaper2. I've got the Steal and Read keyboard options set. How it is broken for you?


Thanks, you're right DarkStar!
When "Steal keyboard focus from host" is enabled, mouse wheel works again :)

So as to be forgiven for my mistake, here is a couple of B.R :wink: :

[LiveSlice v1.5rc3]
BR1/ Event display not being updated correctly
1- Let's say we have a loop loaded in the slicer with two slices [A|B]
2- Lock to loop
3- In the slicer, delete the marker between A and B
:?: The event's display doesn't get updated

BR2/ The number box of the number of events doesn't get updated when increasing/decreasing value with mouse wheel


Cheers,
GilJ.


In RC4, Mouse wheel works without "Steal focus from host" enabled, as it should.

BR2 was an easy fix, but BR1... I can't reproduce it at all, in energy xt or Reaper - I've tried deleting the slice using middle mouse and CTRL+RMB - updates fine every time, tried both XP and Vista too... what if you just move the slice marker - does it update the event then?

thanks.
http://www.livelab.dk - slice up your life
ohm
KVRAF
 
1520 posts since 2 Jul, 2004

Postby ohm; Thu Apr 23, 2009 4:36 am

bump for the BR1 - still can't reproduce it here.
http://www.livelab.dk - slice up your life
GilJ
KVRist
 
233 posts since 16 Mar, 2005

Postby GilJ; Thu Apr 23, 2009 7:35 am

ohm wrote:bump for the BR1 - still can't reproduce it here.


I can still reproduce BR1 with LiveSlice v1.5rc4 :(
I'll try to reformulate this one:

[LiveSlice v1.5rc4]

BR1/ Event display not being updated correctly
1- Load a one shot sample in the slicer
2- Slice the sample in 2 slices
3- Drag to track the first slice as the first event of the track
4- In the slicer, delete the marker
:?: The event's display on the track doesn't get updated (unless I change arrangements)
ohm
KVRAF
 
1520 posts since 2 Jul, 2004

Postby ohm; Thu Apr 23, 2009 11:09 am

GilJ wrote:
ohm wrote:bump for the BR1 - still can't reproduce it here.


I can still reproduce BR1 with LiveSlice v1.5rc4 :(
I'll try to reformulate this one:

[LiveSlice v1.5rc4]

BR1/ Event display not being updated correctly
1- Load a one shot sample in the slicer
2- Slice the sample in 2 slices
3- Drag to track the first slice as the first event of the track
4- In the slicer, delete the marker
:?: The event's display on the track doesn't get updated (unless I change arrangements)

thanks - that one I could reproduce and fix.
http://www.livelab.dk - slice up your life
Optomadic
KVRAF
 
6166 posts since 17 Oct, 2007

Postby Optomadic; Thu May 14, 2009 3:37 pm

Hi just wondering how eveything is coming along.

thnx ohm
Image
stay juicy!
Optomadic
KVRAF
 
6166 posts since 17 Oct, 2007

Postby Optomadic; Tue Nov 10, 2009 5:06 pm

Just thought I'd bump this.

No more posts at KVR?? Anyone know what happened??
Image
stay juicy!
Previous

Moderator: ohm

Return to Livelab.dk