Login / Register 0 items | $0.00 New @ KVR
ianfoxfire
KVRer
 
28 posts since 8 Oct, 2006

Postby ianfoxfire; Thu Sep 27, 2007 10:16 am

MaliceX wrote:Bugs/comments:

-Unison and pitch bend = one of the notes bend, but not the unison notes.
-Really needs some serious optimization in terms of load times, and its behaviour of wavetable selection.
-Wave drawing: Any possibility of some key shortcuts like holding CTRL and dragging to 'smooth out' the drawn stuff, and a line tool of sorts? (See Oatmeal, for an example.)
-Wave morphing: Any possibility for easy 'duplication' from the previous 'frame'?
-Pitch bending needs optimization, as already indicated. Whether or not it does 'anything', the fact the message is being "sent" works up the CPU more than necessary.

All in all, this thing has GREAT potential, it just has some optimization issues that really need to be addressed.


- Both the unison + pitch bending problems should have been fixed in 1.2, ill test again this evening.

- I will look into optimizing patch save/load times. There are lots of params that need to be saved and loaded, i guess thats a drawback of having a matrix for most knobs.

- I agree, the wavetable interface could be better. Unfortunatly, i did not design this module, nor do I have the money to convince the designer to put the effort in myself. Maybe if people message and/or donate to Attila Fustos http://www.vstline.com, he will add or update the wavedraw.
ianfoxfire
KVRer
 
28 posts since 8 Oct, 2006

Postby ianfoxfire; Thu Sep 27, 2007 4:55 pm

GilJ wrote:
ianfoxfire wrote:
xolax wrote:Aww, still does not work in Live 6 :(. I was looking forward to trying it out. Hope you can solve the problem one day.


can you offer the exact version of Live? I'm using 6.0.7, which is fine.


Hi,
I haven't been able to try the synth with Live 6.0.9 or 6.0.10 :(


I have just downloaded ableton live 6.0.10, and it works fine.... im not sure what to do for you....
Please make sure you have the latest 1.2 version.
User avatar
lotus2035
KVRAF
 
4077 posts since 5 May, 2005, from Stockholm, Sweden

Postby lotus2035; Thu Sep 27, 2007 4:58 pm

IFF is my clear favourite at this point and I don't think thats going to change anytime soon.. :wink:
ianfoxfire
KVRer
 
28 posts since 8 Oct, 2006

Postby ianfoxfire; Thu Sep 27, 2007 5:00 pm

MaliceX wrote:Bugs/comments:

-Unison and pitch bend = one of the notes bend, but not the unison notes.
-Really needs some serious optimization in terms of load times, and its behaviour of wavetable selection.
-Wave drawing: Any possibility of some key shortcuts like holding CTRL and dragging to 'smooth out' the drawn stuff, and a line tool of sorts? (See Oatmeal, for an example.)
-Wave morphing: Any possibility for easy 'duplication' from the previous 'frame'?
-Pitch bending needs optimization, as already indicated. Whether or not it does 'anything', the fact the message is being "sent" works up the CPU more than necessary.

All in all, this thing has GREAT potential, it just has some optimization issues that really need to be addressed.


So ive finally got a chance to test, im using cubase SX3, ableton 6.0.7 & 6.0.10,
and I do NOT experience these problems in version 1.2,
but they sound like problems that did exist in previous versions.
maybe try deleting all reference files/dirs to the old plugin, and reinstall the latest via http://www.ianfoxfire.com/iff/Synth/lib/IFF_Synth_v1.2.exe

as for the loading of patches, it litereally only takes a fraction of a second....

BUT - Reverb and Delay need to be optimized!! im workin on it!!
xolax
KVRian
 
640 posts since 16 Dec, 2006, from Caught Somewhere In Time

Postby xolax; Thu Sep 27, 2007 6:55 pm

ianfoxfire wrote:
GilJ wrote:
ianfoxfire wrote:
xolax wrote:Aww, still does not work in Live 6 :(. I was looking forward to trying it out. Hope you can solve the problem one day.


can you offer the exact version of Live? I'm using 6.0.7, which is fine.


Hi,
I haven't been able to try the synth with Live 6.0.9 or 6.0.10 :(


I have just downloaded ableton live 6.0.10, and it works fine.... im not sure what to do for you....
Please make sure you have the latest 1.2 version.

I did try v1.2 and it still crased. I would update Live, but I dont want to, because im afraid of stability issues with some of my vsts (some of which are ancient by todays standards). I will just wait until the next release and hope it works.
Image
ianfoxfire
KVRer
 
28 posts since 8 Oct, 2006

Postby ianfoxfire; Thu Sep 27, 2007 9:18 pm

lotus2035 wrote:IFF is my clear favourite at this point and I don't think thats going to change anytime soon.. :wink:

Thanks!!
Once I finish updating IFF synth to 1.3, with better matrix value mouse response/reset response + optimizing reverb & delay CPU
Ill start on its sister synth.... wich will be similar, but im replacing the AF Wave Draw with 4 Super high quality oscillators you can draw, and are saved with presets.
All 4 osc's morph between each other via XY pad, + there is FM & AM modulation routing options between each....
MaliceX
KVRAF
 
2892 posts since 26 Jul, 2005, from dun unda

Postby MaliceX; Fri Sep 28, 2007 9:25 pm

That's weird, cause 1.2 was the first version I ever used. :S
Anyway, I've only tested this under Cantabile. I'll wait for the next version and re-test it.
ianfoxfire
KVRer
 
28 posts since 8 Oct, 2006

Postby ianfoxfire; Sat Sep 29, 2007 10:30 pm

MaliceX wrote:That's weird, cause 1.2 was the first version I ever used. :S
Anyway, I've only tested this under Cantabile. I'll wait for the next version and re-test it.


You had me worried, because i really like Cantabile...
But when I test both versions of IFF Synth 1.2 and my latest 1.3 (in progress), they seem to work just fine.

what exactly happens when you try to run it?
ianfoxfire
KVRer
 
28 posts since 8 Oct, 2006

Postby ianfoxfire; Sat Sep 29, 2007 10:38 pm

MaliceX wrote:That's weird, cause 1.2 was the first version I ever used. :S
Anyway, I've only tested this under Cantabile. I'll wait for the next version and re-test it.

One thing i did notice with Cantabile, is that when I restarted it, and loaded my synth, there was no sound.
This was because there was no Audio Driver defined... not sure what im doing wrong, but every time I close and restart cantabile, i have to reset the audio driver....
MaliceX
KVRAF
 
2892 posts since 26 Jul, 2005, from dun unda

Postby MaliceX; Sun Sep 30, 2007 7:43 am

Again, I'll wait for the new build to make life easier for the both of us. :D
ianfoxfire
KVRer
 
28 posts since 8 Oct, 2006

Postby ianfoxfire; Mon Oct 01, 2007 7:13 am

Over the weekend i made the following updates to what will be IFF Synth 1.3:

- Changed the behavior of each knobs matrix value field.
Before, it would reset to zero when ever you clicked it,
Now it will sustain its value allowing you to fine tune it.
Double clicking will reset to zero.

- Optimized reverb
It now has what I feel is a better sound, and actually uses less CPU.
I went from a generic 4 delay per channel design, to an optimized 8 delays per channel.
I have replaced the simple "width" knob with left & Right 8 bar graphs allowing you to add unique and slight variation to each individual delay time, and damping.
Playing with these settings is FUN and allows you control over the reverb overall shape and sound.


NEXT:
Because of these changes, I will now have to manually go in and recreate each Preset that was in 1.2.... and probably add some new ones.
In the meantime, If anyone wants to beta test 1.3 to help me find bugs these changes could have caused, I would greatly appreciate it! If interested email me directly ianfoxfire at gmail dot com.
MaliceX
KVRAF
 
2892 posts since 26 Jul, 2005, from dun unda

Postby MaliceX; Tue Oct 02, 2007 5:40 am

Problem: Your email doesn't work. (got a return message saying no such user)

PM me.
ianfoxfire
KVRer
 
28 posts since 8 Oct, 2006

Postby ianfoxfire; Tue Oct 02, 2007 11:50 am

MaliceX wrote:Problem: Your email doesn't work. (got a return message saying no such user)

PM me.


Try ianfoxfire@gmail.com

or do it from the contact link from http://www.ianfoxfire.com
kx77free
KVRian
 
612 posts since 19 Jul, 2005, from Paris

Postby kx77free; Tue Oct 02, 2007 11:40 pm

Hi,

Good work!

I just tested your synthesizer.
I didn't found preset banks ...

It is like SM oscillators, it's very difficult to determine the harmonic content when you draw a waveform with a mouse.

Your synthesizer is too clean, it should have presets.

Xavier
ianfoxfire
KVRer
 
28 posts since 8 Oct, 2006

Postby ianfoxfire; Wed Oct 03, 2007 9:21 am

kx77free wrote:Hi,

Good work!

I just tested your synthesizer.
I didn't found preset banks ...

It is like SM oscillators, it's very difficult to determine the harmonic content when you draw a waveform with a mouse.

Your synthesizer is too clean, it should have presets.

Xavier


Thanks for the note!,
Version 1.2 has presets, you can download it here: http://www.ianfoxfire.com/iff/Synth/lib/IFF_Synth_v1.2.exe
The .exe installer ensures the wavetable banks get installed in the proper location.
PreviousNext

Moderator: Moderators (Main)

Return to KVR Developer Challenge 2018