What is KVR Audio? | Submit News | Advertise | Developer Account

Options (Affects News & Product results only):

OS:
Format:
Include:
Quick Search KVR

"Quick Search" KVR Audio's Product Database, News Items, Developer Listings, Forum Topics and videos here. For advanced Product Database searching please use the full product search. For the forum you can use the phpBB forum search.

To utilize the power of Google you can use the integrated Google Site Search.

Products 0

Developers 0

News 0

Forum 0

Videos 0

Search  

Osc Pitch bug

Official support for: kv331audio.com

Moderators: Teoman, kv331

bm1000
KVRist
 
37 posts since 11 Jun, 2012

Postby bm1000; Wed Nov 14, 2012 5:44 am Osc Pitch bug

Hello, I have been using Synthmaster a lot lately, and one thing has kept annoying me.

When you try to tune one of the oscillators an octave down or up using the Pitch knob, it is often really hard to hit exactly one octave up or down, often the text might say "+76,5" and when i move the mouse even the tiniest bit, it jumps over exactly "+76" and goes to "75,5" and the same thing happens the other way. It does not "lock" to exactly one octave, in fact, the Pitch knob seems to avoid exactly one octave.

Also, the text next to the pitch number "+63, -1 semitone" (which is correct) is very often not correct, for example, at this very moment an instance of Synthmaster on my other screen reads "+76, 11 semitones", which is not correct, +76 is one octave or 12 semitones up. I just pressed a key on my controller, and tried to tune the same oscillator one octave down, and after a bit of fiddling trying to hit the octave interval by hearing alone, now it reads "+52, -1 octave -1 semitones", which is also not correct, since +52 is exactly one octave down.

And last, often when I tune the oscillator just by the text, for example I turn the knob to exactly +72 and let go of the mouse button, it would seem that the oscillator is now tuned to +72, but when I move my cursor off the knob, and back to it again, inexplicably, the text now reads +72,5. This does not happen always.

Anyways, I hope you can find an easier way to tune the oscillators, perhaps clicking the second mouse button and getting a menu that would have at least +7 semitones and +one octave(and of course the minus octave too). Or maybe a keyboard modifier that locks on to semitones, not half semitones. Or even have the default action to lock to just exact semitones, and have shift as a modifier to get half semitones.

I am using 32bit Reaper in Windows 7 if it matters.

Thanks for an awesome soft synth!
kv331
KVRAF
 
4945 posts since 14 Nov, 2006, from Ankara, Turkey

Postby kv331; Wed Nov 14, 2012 6:56 am

when you use the mousewheel, it increments/decrements exactly by 1 semitone.

Also, for finer resolution, use shift key + mouse. that'd increase the resolution.
bm1000
KVRist
 
37 posts since 11 Jun, 2012

Postby bm1000; Wed Nov 14, 2012 3:15 pm

Tried the mousewheel, and since I have never before used the mousewheel in Synthmaster, I only now noticed that it doesn't work for some reason. I tried changing the mousewheel options in Reaper, but it just won't do anything to the knobs in SM. It works in a couple of other plugins, like SonEQ and Battery 3 for example.
kv331
KVRAF
 
4945 posts since 14 Nov, 2006, from Ankara, Turkey

Postby kv331; Thu Nov 15, 2012 11:52 am

Try clicking on the plugin window first, so it gets the focus. Then mousewheel should work, at least in Reaper (windows) it works for me.
bm1000
KVRist
 
37 posts since 11 Jun, 2012

Postby bm1000; Thu Nov 15, 2012 3:15 pm

Nope, still does not work, after making sure the window was in focus, clicking both the SM window and the button it self. And mousewheel works perfectly at least with Battery, SonEQ, Zebralette and Reaper's own plugins. No idea why.

But, for me at least, it wouldn't even be a problem if there was another way to use the pitch knob in one semitone increments.

And I really appreciate the quick answering!

EDIT. Oh and by the way, if it matters, I'm using 32bit Reaper in 64bit Win7. Can't think of any other variables, I even tried another mouse.
Gino Cortesi
KVRist
 
181 posts since 28 Jun, 2010

Postby Gino Cortesi; Sun Nov 18, 2012 6:14 am

On a related topic, I don't understand why you can't set exact values for modulation.

To reproduce this.

1) Assign an LFO to the pitch of OSC1
2) Attempt to set the modulation amount to 12.0 (or any whole number actually)

Although I love the sound of this synth, to me it's weird that you can't do that.

Best regards,

Gino

Moderators: Teoman, kv331

Return to KV331 Audio