What is KVR Audio? | Submit News | Advertise | Developer Account

Options (Affects News & Product results only):

OS:
Format:
Include:
Quick Search KVR

"Quick Search" KVR Audio's Product Database, News Items, Developer Listings, Forum Topics and videos here. For advanced Product Database searching please use the full product search. For the forum you can use the phpBB forum search.

To utilize the power of Google you can use the integrated Google Site Search.

Products 0

Developers 0

News 0

Forum 0

Videos 0

Search  

Setting up audio and ASIO

Official support for: mutools.com

Moderators: muzycian, mutools

Lazman
KVRer
 
5 posts since 23 Jan, 2013

Postby Lazman; Wed Jan 23, 2013 5:33 am Setting up audio and ASIO

Dear MuLab users, forgive me for being very basic but this is how I am at the moment! I have just installed MuLab and have also installed ASIO through asio4all, understanding that this is preferable to MME (I run Windows XP). However, in the Audio set up secreen I don't get an option for a USB connected sound source, which I do when I use, for example Audacity (it appears as USB Audio CODEC); although I can hear the demos so the output is correctly set up. How can I get MuLab to speak with my USB mixer? Many thanks
mutools
KVRAF
 
5749 posts since 24 Jun, 2008, from Europe

Postby mutools; Wed Jan 23, 2013 9:20 am

If it isn't listed as an ASIO device then there is no such ASIO driver, also not in Audacity. I assume what you see in Audacity is another type of driver (MME, WDM, DirectX). Are you sure you installed the ASIO driver for your sound device? If it hasn't such ASIO driver maybe you have to select it in the Asio4All control panel.
Lazman
KVRer
 
5 posts since 23 Jan, 2013

Postby Lazman; Wed Jan 23, 2013 11:14 am

mutools wrote:If it isn't listed as an ASIO device then there is no such ASIO driver, also not in Audacity. I assume what you see in Audacity is another type of driver (MME, WDM, DirectX). Are you sure you installed the ASIO driver for your sound device? If it hasn't such ASIO driver maybe you have to select it in the Asio4All control panel.


Thank you so much for your quick reponse. I did what you suggested and checked the ASIO control panel and selected the driver. Now I see the USB codec in the audio setup secreen in both the input and output sections; however I've lost the output now! Presumably I sould be able to hear the playback through my USB mixer but for whatever reason I can't. What I record apprears in the composer secreen, just no sound. Any ideas?
Nickl
KVRist
 
34 posts since 7 Jun, 2012, from Welsh Marches, England

Postby Nickl; Wed Jan 23, 2013 11:42 am

ASIO appears to support only one app at a time - so it could be that you have another app open which has grabbed it.
Lazman
KVRer
 
5 posts since 23 Jan, 2013

Postby Lazman; Wed Jan 23, 2013 12:19 pm

Nickl wrote:ASIO appears to support only one app at a time - so it could be that you have another app open which has grabbed it.


Hi Nickl, thanks for that. I don't have any other audio software open while I'm running MuLab but your suggestion made me think again about the setup and I went back to the setup window and ticked only what appears on my computer as USB audio CODEC 2 in both the input and the output, when previouisly I had both 1 and 2 ticked (you're probably thinking I'm really stupid now!) and it actually did the trick. So it seems I have sound both going in and coming out for now. I'll carry on expreimenting. Many thanks.
User avatar
dakkra
KVRian
 
549 posts since 4 Oct, 2012, from Utah

Postby dakkra; Wed Jan 23, 2013 12:34 pm

Lazman wrote:(you're probably thinking I'm really stupid now!)

Nah. Many of us (including myself) have run into a similar situation as you. We all learn though. :tu:
Lazman
KVRer
 
5 posts since 23 Jan, 2013

Postby Lazman; Wed Jan 23, 2013 12:40 pm

Me again, sorry! I have a problem with the ASIO4all settings. In the control panel I am given a choice of 'Realtek high definition audio' and 'USB audio codec' in the WDM device list. It is the USB audio codec that I need but I don't seem to be able to permanently change the setting in the control panel and make this my default. Even when it is highlighted with green, under Legend the Realtek is said to be running and highlighted in green while the USB just remains 'available'. Any ideas?
Lazman
KVRer
 
5 posts since 23 Jan, 2013

Postby Lazman; Wed Jan 23, 2013 12:47 pm

dakkra wrote:
Lazman wrote:(you're probably thinking I'm really stupid now!)

Nah. Many of us (including myself) have run into a similar situation as you. We all learn though. :tu:


Thanks for the encouragement. It's really trying though!

Moderators: muzycian, mutools

Return to MUTOOLS