What is KVR Audio? | Submit News | Advertise | Developer Account

Options (Affects News & Product results only):

OS:
Format:
Include:
Quick Search KVR

"Quick Search" KVR Audio's Product Database, News Items, Developer Listings, Forum Topics and videos here. For advanced Product Database searching please use the full product search. For the forum you can use the phpBB forum search.

To utilize the power of Google you can use the integrated Google Site Search.

Products 0

Developers 0

News 0

Forum 0

Videos 0

Search  
KVRist
 
69 posts since 2 Feb, 2009

Postby UltraSniffy; Mon Jan 14, 2013 3:22 am Filter glitches in Predator FX

Hi,

I seem to be experiencing strange distortion/clicks/glitches when using the main filter in Predator FX. This seems to present in most in not all filter models, but is especially noticeable in the new (2) 24db set. This also appears to be dynamics dependent—when I use smooth pads as a source, I don't get any glitches, but as soon as I switch to something more energetic, such as a beat or even a didgeridoo, I get very audible clicks (similar to filter stepping, only worse).

If you need more information, or some audio samples, don't hesitate.

Thank you for taking the time to look into this.
KVRAF
 
3493 posts since 6 Feb, 2003, from UK
 

Postby Concretefx; Mon Jan 14, 2013 1:46 pm

I haven't noticed that, my first idea would be to turn off the filter smooth so it's 'edgy' and see if that helps, but I'll need to give it a check out.

Cheers

Jon
KVRist
 
69 posts since 2 Feb, 2009

Postby UltraSniffy; Thu Jan 24, 2013 4:17 pm

Hi,

Sorry I didn't follow this up sooner. I just installed the latest versions of all plugins, and I'm experiencing this issue. Running Live 8.4(b9) in 64bit (OS X 10.8.2).

I recorded a dry, then wet example of what I'm talking about and up uploaded it to my Dropbox: https://www.dropbox.com/s/r345i8u62w2h9 ... tch%29.aif

Let me know if this is normal, or if there's anything else you need.

Cheers,
US
KVRAF
 
3493 posts since 6 Feb, 2003, from UK
 

Postby Concretefx; Thu Jan 24, 2013 11:46 pm

Hi there

I'll need to look into that and see what is happening.

Cheers

Jon
KVRist
 
69 posts since 2 Feb, 2009

Postby UltraSniffy; Fri Feb 01, 2013 9:36 am

Hi,

Just downloaded and tested the latest version of Predator and the glitch is still there (dry, then wet with a modulated 12LP2 filter:

https://www.dropbox.com/s/o9izbw2ue05y8 ... 202%29.aif
KVRAF
 
3493 posts since 6 Feb, 2003, from UK
 

Postby Concretefx; Sat Feb 02, 2013 3:57 am

Hmm, is it only that filter or all of them ?

Cheers

Jon
KVRist
 
69 posts since 2 Feb, 2009

Postby UltraSniffy; Sat Feb 02, 2013 4:12 am

On all except for 6LP/HP (high res setting trigger it, and the 6LP/HP don't have high res settings). I was surprised to see that the comb filters also have it.
KVRAF
 
3493 posts since 6 Feb, 2003, from UK
 

Postby Concretefx; Sat Feb 02, 2013 8:21 am

Just to be sure I'm checking the right thing, could you send me a preset showing this problem ?

Cheers

Jon
KVRist
 
69 posts since 2 Feb, 2009

Postby UltraSniffy; Thu Feb 07, 2013 4:40 am

You know... I'd love to, but I just tried it again, and I can't for the life of me reproduce it. This is very odd, as until last week, I couldn't find a way around these artefacts, and now bam!—nothing. Sorry for wasting your time I guess, and I'll let you know if they come back...

Cheers,
US
KVRAF
 
3493 posts since 6 Feb, 2003, from UK
 

Postby Concretefx; Fri Feb 08, 2013 12:54 am

Ok, cool. Let me know if anything re-occurs.

Cheers

Jon
KVRist
 
69 posts since 2 Feb, 2009

Postby UltraSniffy; Sat Feb 16, 2013 4:04 am

Hi,

It reoccurred again. Here's a zip with both a sample of the effect and the preset that was causing it:

https://www.dropbox.com/s/v7g6a5vgblnt0 ... Glitch.zip

Cheers,
US
KVRAF
 
3493 posts since 6 Feb, 2003, from UK
 

Postby Concretefx; Sat Feb 16, 2013 4:07 am

Thanks, I'll give that check out and let you know what I find.

Cheers

Jon
KVRAF
 
3493 posts since 6 Feb, 2003, from UK
 

Postby Concretefx; Sat Feb 16, 2013 1:28 pm

Hi there

I think I've fixed this

here is the bad one

https://dl.dropbox.com/u/48505672/Bad_PredatorFX.wav

and here is the fixed one

https://dl.dropbox.com/u/48505672/Fixed_PredatorFX.wav

and it seems to remove this click (it was all down to the filter reasonance). I'll put this fix in the next version of Predator which should be out next week, which you can then check out.

Thanks for mentioning this, anything else weird just let us know.

Cheers

Jon
KVRist
 
69 posts since 2 Feb, 2009

Postby UltraSniffy; Tue Feb 19, 2013 2:14 pm

"high res setting trigger it"
- me ;)

Cheers for fixing this, looking forward to trying out the update tomorrow!
KVRAF
 
3493 posts since 6 Feb, 2003, from UK
 

Postby Concretefx; Tue Feb 19, 2013 2:51 pm

The new version is out now, so if you download & install it, it should be ok now, but let us know if anything odd happens.

Cheers

Jon
Next

Moderators: Meffy, Concretefx, Rob Papen

Return to Rob Papen