What is KVR Audio? | Submit News | Advertise | Developer Account

Options (Affects News & Product results only):

OS:
Format:
Include:
Quick Search KVR

"Quick Search" KVR Audio's Product Database, News Items, Developer Listings, Forum Topics and videos here. For advanced Product Database searching please use the full product search. For the forum you can use the phpBB forum search.

To utilize the power of Google you can use the integrated Google Site Search.

Products 0

Developers 0

News 0

Forum 0

Videos 0

Search  

SF2 error on project load (Reaper)

Official support for: tx16wx.com

Moderator: elcallio

A Little Man and a House
KVRer
 
19 posts since 16 Dec, 2013

Postby A Little Man and a House; Sat Jan 11, 2014 2:26 pm SF2 error on project load (Reaper)

I'm using Reaper to load a particular SF2 bank in Reaper. It plays fine, but when I save and load the project file it fails to load and sometimes crashes Reaper. It might just be a buggy sf2, since its only happens with this bank (SFZ player loads it fine though)
It's given either of these messages when loading the project:
Could not read XML data 10:61; '61' violates maxInclusive constraint of '50'. The attribute '{http://www.tx16wx.com/2.0/program}fine' with value '61' failed to parse.

Could not read XML data 10:61; Unspecified error: Wave reference out of range: 288

The SF2 is on this page: http://www.williamkage.com/snes_soundfonts (it's the Earthbound one)
elcallio
KVRian
 
959 posts since 27 May, 2005, from Stockholm

Postby elcallio; Sun Jan 12, 2014 6:33 am Re: SF2 error on project load (Reaper)

The SF2 is not buggy, except for maybe the fact that it has several samples using the same name, which is in general bad for exporting. The issue you've encountered however is because pitch information for waves were not normalized on import, resulting in invalid tuning values (tx16wx only allows [-50,50] range).

I've hotfixed the issue, there is a 2.3.1a available in the download section.
Cheers
/C
TX16Wx Software Sampler:
http://www.tx16wx.com/
A Little Man and a House
KVRer
 
19 posts since 16 Dec, 2013

Postby A Little Man and a House; Sun Jan 12, 2014 2:16 pm Re: SF2 error on project load (Reaper)

That was fast, I am super impressed. Downloaded and everything is running smoothly now. Thanks.
A Little Man and a House
KVRer
 
19 posts since 16 Dec, 2013

Postby A Little Man and a House; Tue Mar 04, 2014 9:01 pm Re: SF2 error on project load (Reaper)

I'm bumping my topic because the problem is related.
I loaded an sf2 from above website (the yoshi's island one), had set up several channel slots and outs. Reaper crashed (not responding). On loading project, it displays this message:

could not read xml data 10:82; unspecified error: stoi argument out of range

The SF2 bank is gone, as are channel slots, groups, splits and so on.

I don't think it is directly caused by crash, because pre-crash backups have same the problem.
A Little Man and a House
KVRer
 
19 posts since 16 Dec, 2013

Postby A Little Man and a House; Tue Mar 04, 2014 9:35 pm Re: SF2 error on project load (Reaper)

also, tx16wx becomes unstable and usually crashes when I load the GeneralUser GS soundfont, available at schristiancollins.com/generaluser.php

I'm still using 2.3.1a and cannot easily update right now, so sorry if these things are already patched.
elcallio
KVRian
 
959 posts since 27 May, 2005, from Stockholm

Postby elcallio; Wed Mar 05, 2014 12:22 am Re: SF2 error on project load (Reaper)

A Little Man and a House wrote:I'm bumping my topic because the problem is related.
I loaded an sf2 from above website (the yoshi's island one), had set up several channel slots and outs. Reaper crashed (not responding). On loading project, it displays this message:

could not read xml data 10:82; unspecified error: stoi argument out of range

The SF2 bank is gone, as are channel slots, groups, splits and so on.

I don't think it is directly caused by crash, because pre-crash backups have same the problem.


As usual, send me the project + all related files and I will look at it.
TX16Wx Software Sampler:
http://www.tx16wx.com/
Llamatron
KVRer
 
16 posts since 31 Mar, 2013

Postby Llamatron; Wed Mar 26, 2014 5:04 am Re: SF2 error on project load (Reaper)

Bumping too because I have the exact same problem than in the OP, except it happens when having imported the soundfont as SFZ from the Program import, instead of SF2 from the Bank one.

Also, how come Program supports SFZ import but not SF2, and the other way around for Banks?
elcallio
KVRian
 
959 posts since 27 May, 2005, from Stockholm

Postby elcallio; Wed Mar 26, 2014 8:58 am Re: SF2 error on project load (Reaper)

Thanks for the SFZ, exactly same issue indeed. A one liner fix as well (did not handle illegal pitch offsets when root key override was added).

I've updated the current 2.3.2 beta with the fix.

To answer your question: SF2 is a monolithic format containing any number of "programs", thus it can not be loaded as a single program, since "which is the one you want?".
You can however browse inside SF2 files in the file browser and load individual SF-programs instead of the whole file.
TX16Wx Software Sampler:
http://www.tx16wx.com/
Llamatron
KVRer
 
16 posts since 31 Mar, 2013

Postby Llamatron; Wed Mar 26, 2014 9:46 am Re: SF2 error on project load (Reaper)

Thanks for your reactivity and your explaination!
A Little Man and a House
KVRer
 
19 posts since 16 Dec, 2013

Postby A Little Man and a House; Thu Jun 19, 2014 6:36 pm Re: SF2 error on project load (Reaper)

This bug lives on. Where do I send the project files? It won't allow me to attach them here. Also, do you know if there is a simple way to save a self-contained Reaper project when the sf2s/wavs are all over my hard drive? Or do I just have to manually correct the file paths?

Here is what went down this time.
What I did: had 1 instance open with a couple sf2s loaded and a few raw wavs. Had several channels, had been editing loop points without difficulty, 8 outputs.
What happened: Saved project. On re-open, got this somewhat familiar message:
Could not read XML data 10:75; Unspecified error : Wave reference out of range: 18

tx16 was now an empty patch..
I have two project files. The most recent save, which contains the empty tx16. There is also the last working backup, from a while back.
elcallio
KVRian
 
959 posts since 27 May, 2005, from Stockholm

Postby elcallio; Fri Jun 20, 2014 12:51 am Re: SF2 error on project load (Reaper)

A Little Man and a House wrote:This bug lives on. Where do I send the project files? It won't allow me to attach them here. Also, do you know if there is a simple way to save a self-contained Reaper project when the sf2s/wavs are all over my hard drive? Or do I just have to manually correct the file paths?

Here is what went down this time.
What I did: had 1 instance open with a couple sf2s loaded and a few raw wavs. Had several channels, had been editing loop points without difficulty, 8 outputs.
What happened: Saved project. On re-open, got this somewhat familiar message:
Could not read XML data 10:75; Unspecified error : Wave reference out of range: 18

tx16 was now an empty patch..
I have two project files. The most recent save, which contains the empty tx16. There is also the last working backup, from a while back.
 

This is actually a completely different bug, though I guess it might look similar to you. Just as a guess I'd say that one referenced sound font was changed/replaced, and the imported waves now differ so that once programs are loaded, these waves are off and thus cannot be resolved. It might be _very_ related to the fact that the original sound font you sent me uses the same name for many samples, which can definitely confuse the DAW loader. 
If you can, send me the projects + SF2:s so I can verify this.
TX16Wx Software Sampler:
http://www.tx16wx.com/
elcallio
KVRian
 
959 posts since 27 May, 2005, from Stockholm

Postby elcallio; Sat Jun 21, 2014 11:12 am Re: SF2 error on project load (Reaper)

So, the problem you ran into was more or less what I guessed, you had SF2:s referenced but with one of the imported waveforms duplicated, which confused the DAW bank loader (no issues if using TX disk programs). Basically, it more or less shows that the way a referenced SF2 was loaded up until now, by referencing samples by name is not really working. I've modified the mechanism to
1.) Reference samples by SF2 index instead
2.) Allow multiple instances of same referenced wave to be loaded

The downside of this is that IF you were to modify a referenced SF2, inserting or removing samples, the import will break. I am not sure it is truly worth it trying to build a mechanism that semi-handles this, since it would always break in _some_ way.

In any case, I have made a fix and updated the current RC build.
TX16Wx Software Sampler:
http://www.tx16wx.com/
A Little Man and a House
KVRer
 
19 posts since 16 Dec, 2013

Postby A Little Man and a House; Sat Jun 21, 2014 10:49 pm Re: SF2 error on project load (Reaper)

Thanks, I'll give it a test drive. : )

which confused the DAW bank loader (no issues if using TX disk programs)


Does this mean that if I had re-saved SF2s into the native txbank format I wouldn't have encountered the problem?
elcallio
KVRian
 
959 posts since 27 May, 2005, from Stockholm

Postby elcallio; Sat Jun 21, 2014 11:49 pm Re: SF2 error on project load (Reaper)

Well, yes, but on the other hand you would have saved the samples as WAV:s so maybe that would not have been what you are looking for. I was just pointing out that the bug is only related to using SF2:s within a DAW project.
TX16Wx Software Sampler:
http://www.tx16wx.com/

Moderator: elcallio

Return to CWITEC