What is KVR Audio? | Submit News | Advertise | Developer Account

Options (Affects News & Product results only):

OS:
Format:
Include:
Quick Search KVR

"Quick Search" KVR Audio's Product Database, News Items, Developer Listings, Forum Topics and videos here. For advanced Product Database searching please use the full product search. For the forum you can use the phpBB forum search.

To utilize the power of Google you can use the integrated Google Site Search.

Products 0

Developers 0

News 0

Forum 0

Videos 0

Search  

Finally: Venom VB-303 v1.00

VST, AU, etc. plug-in Virtual Instruments discussion

Moderator: Moderators (Main)

User avatar
KVRAF
 
2156 posts since 4 Sep, 2006, from 127.0.0.1
 

Postby antto; Tue Jan 14, 2014 8:54 am Re: Finally: Venom VB-303 v1.00

try flipping to the rear panel and back to the front

i couldn't figure out this bug, it's somehow related to how the Host behaves with gui/dsp threads and stuff, and i can't reproduce it in my hosts
It doesn't matter how it sounds..
..as long as it has BASS and it's LOUD!
KVRer
 
15 posts since 5 May, 2005, from Serbia
  

Postby HYPNAGOGIA; Tue Jan 14, 2014 9:09 am Re: Finally: Venom VB-303 v1.00

No joy flipping to rear panel, knobs still don't show.
User avatar
KVRAF
 
2256 posts since 5 Jun, 2012

Postby fluffy_little_something; Tue Jan 14, 2014 9:20 am Re:

DCO18 wrote:Everytime I start Venom in FL Studio, the display shows the following message:

NONSEQ
Please Wait, Booting
C:\Programs\VstPlugins

And it is booting all the time and I can't start working :(
Meanwhile, the LED belonging to the C-Key ist always blinking at a very high frequency.
Can anyone help me?
:help:



It's probably got nothing to do with it, but I have read repeatedly that in Windows one should not install VST's under Programs.
User avatar
KVRist
 
221 posts since 17 Feb, 2005, from Serbia

Postby lesha; Tue Jan 14, 2014 9:24 am Re: Finally: Venom VB-303 v1.00

Tried it many times with no luck. Also, when I click pattern or memory "load" or "save" nothing happens.
I previously had a problem with displaced knobs until I used your suggestion and gave the dll file read/write access.
Ingonator described the same problem here
It's easy if you know how
User avatar
KVRAF
 
2156 posts since 4 Sep, 2006, from 127.0.0.1
 

Postby antto; Tue Jan 14, 2014 6:31 pm Re: Finally: Venom VB-303 v1.00

another thing you could try.. in some hosts, you can close a plugin's GUI window, and then reopen it
and/or restart the whole plugin (including DSP threads and all)
if that doesn't help either - i'm out of ideas
It doesn't matter how it sounds..
..as long as it has BASS and it's LOUD!
User avatar
KVRist
 
221 posts since 17 Feb, 2005, from Serbia

Postby lesha; Wed Jan 15, 2014 1:18 am Re: Finally: Venom VB-303 v1.00

antto wrote:another thing you could try.. in some hosts, you can close a plugin's GUI window, and then reopen it
and/or restart the whole plugin (including DSP threads and all)
if that doesn't help either - i'm out of ideas

When I insert it on a new track everything is fine. The knobs are gone when I load the project the next time. Also, if I delete it from the channel and bring it back again, the knobs are there, but still I can't use load or save functions no matter if the GUI is OK or not. Fortunately, I can load the preset via fxp I previously saved in Ableton, but that is not a great solution.

I think this needs to be fixed, Ableton Live is one of the most popular and used DAWs around. I am sure I'm not the only one with the problem, Ingonator hasn't fixed it yet, just contacted him through pm.

Thanks for your effort. :tu:
It's easy if you know how
User avatar
KVRAF
 
7407 posts since 21 Mar, 2008, from Hannover, Germany
  

Postby Ingonator; Wed Jan 15, 2014 1:24 am Re: Finally: Venom VB-303 v1.00

lesha wrote:
antto wrote:another thing you could try.. in some hosts, you can close a plugin's GUI window, and then reopen it
and/or restart the whole plugin (including DSP threads and all)
if that doesn't help either - i'm out of ideas

When I insert it on a new track everything is fine. The knobs are gone when I load the project the next time. Also, if I delete it from the channel and bring it back again, the knobs are there, but still I can't use load or save functions no matter if the GUI is OK or not. Fortunately, I can load the preset via fxp I previously saved in Ableton, but that is not a great solution.

I think this needs to be fixed, Ableton Live is one of the most popular and used DAWs around. I am sure I'm not the only one with the problem, Ingonator hasn't fixed it yet, just contacted him through pm.

Thanks for your effort. :tu:


I could confirm that when i loaded an old Live project the controls for Cutoff etc. are dispapeared. This seems to affect the graphics while the knobs still seem to work when you know where they should be.
Concerning the request of lesha (by PM): As there did not seem to be an update since i reported this in April last year i did not really expect this to be fixed yet.

Like he already mentioned (and like i mentioned in my post in April 2013) only removing and re-inserting the plugin from a MIDI track solves the problem. Closing and re-opening the GUi does not help.

One solution (which i forgot in my PM to Lesha) could be assigning the corresponding controls to MIDI and/or Automation. This adds sliders for the corresponding controls to the Live GUI for the plugin (and you could assign those to a hardware controller).
I have done that with my Korg NanoKONTROL.


Ingo
"Atmospheric Transients" for PPG Wave 3.V
"Analog vs Digital" for Blofeld
Win 7 64-bit / Live Suite 9.1.1 / Reaper 4.61
Motif ES 7 / Wavestation EX / Blofeld desktop / Pulse 2
User avatar
KVRAF
 
2156 posts since 4 Sep, 2006, from 127.0.0.1
 

Postby antto; Wed Jan 15, 2014 3:51 am Re: Finally: Venom VB-303 v1.00

i went to see if there's a demo of Ableton so i can test
it's freakin' 700MB
i'm not gonna promise anything
It doesn't matter how it sounds..
..as long as it has BASS and it's LOUD!
User avatar
KVRist
 
221 posts since 17 Feb, 2005, from Serbia

Postby lesha; Wed Jan 15, 2014 3:56 am Re: Finally: Venom VB-303 v1.00

Thank you Anton, hope to hear good news from you soon :)
It's easy if you know how
User avatar
KVRAF
 
2156 posts since 4 Sep, 2006, from 127.0.0.1
 

Postby antto; Wed Jan 15, 2014 4:52 am Re: Finally: Venom VB-303 v1.00

i just tested it
when first loaded - it works fine
when the project is saved and reopened - the plugin is loaded somehow differently
the sequencer fails to get the pattern root dir (evidence, press Pattern LOAD - it should always open up the /patterns/ dir)
but the DSP side of the sequencer manages to get the vst dir
so this must be the GUI side failing to initialize in the expected order

is there a way to reset/restart a plugin in ableton?

EDIT: found a solution

right-click, "CUT" and then re-PASTE it back
this seems to initialize the plugin with the same vst memory and params, but in the "right" way
It doesn't matter how it sounds..
..as long as it has BASS and it's LOUD!
User avatar
KVRist
 
221 posts since 17 Feb, 2005, from Serbia

Postby lesha; Wed Jan 15, 2014 5:15 am Re: Finally: Venom VB-303 v1.00

antto wrote:is there a way to reset/restart a plugin in ableton?

EDIT: found a solution

right-click, "CUT" and then re-PASTE it back
this seems to initialize the plugin with the same vst memory and params, but in the "right" way

Thanks. Regarding your solution, I already put a delay and reverb effects to the right of the Venom, and when I cut it Ableton does not allow pasting right to the effects, only drag and drop to the left. So I have to make another MIDI track and paste it there, and then drag it back to the original track.
And unlock MidiPlay again, of course. Pattern & memory load or save still do not work.
It's easy if you know how
User avatar
KVRist
 
221 posts since 17 Feb, 2005, from Serbia

Postby lesha; Wed Jan 15, 2014 5:21 am Re: Finally: Venom VB-303 v1.00

I tried it again, and it doesn't work with cut/paste anymore. :neutral:
It pastes the same GUI without 'tuning', 'cutoff', 'resonance' and other 3 knobs...
It's easy if you know how
User avatar
KVRAF
 
2156 posts since 4 Sep, 2006, from 127.0.0.1
 

Postby antto; Wed Jan 15, 2014 6:19 am Re: Finally: Venom VB-303 v1.00

i'm not familiar with the "workflow" in ableton, i just loaded an instance of vb303 into an empty project, and cut/paste did the job... no idea if that's actually useful in a complex project

as for pattern/memory load/save - these are only available in Pattern-Write mode, and also be careful when you press them in SETTINGS mode, since they have another purpose there (see the manual)
* EDITed, typo
Last edited by antto on Wed Jan 15, 2014 6:37 am, edited 1 time in total.
It doesn't matter how it sounds..
..as long as it has BASS and it's LOUD!
User avatar
KVRist
 
221 posts since 17 Feb, 2005, from Serbia

Postby lesha; Wed Jan 15, 2014 6:31 am Re: Finally: Venom VB-303 v1.00

antto wrote:as for pattern/memory load/save - these are only available in Pattern-Play mode, and also be careful when you press them in SETTINGS mode, since they have another purpose there (see the manual)

Load/save buttons don't work in pattern-play mode, just in pattern-write mode. Is that OK?
It's easy if you know how
User avatar
KVRAF
 
2156 posts since 4 Sep, 2006, from 127.0.0.1
 

Postby antto; Wed Jan 15, 2014 6:38 am Re: Finally: Venom VB-303 v1.00

yes, pattern-write mode, typo
It doesn't matter how it sounds..
..as long as it has BASS and it's LOUD!
PreviousNext

Moderator: Moderators (Main)

Return to Instruments