What is KVR Audio? | Submit News | Advertise | Developer Account

Options (Affects News & Product results only):

OS:
Format:
Include:
Quick Search KVR

"Quick Search" KVR Audio's Product Database, News Items, Developer Listings, Forum Topics and videos here. For advanced Product Database searching please use the full product search. For the forum you can use the phpBB forum search.

To utilize the power of Google you can use the integrated Google Site Search.

Products 0

Developers 0

News 0

Forum 0

Videos 0

Search  

Cubase 7.5 + Yamaha S90 XS + Win8.1

Plug-in hosts and other software applications discussion

Moderator: Moderators (Main)

KVRian
 
961 posts since 13 Sep, 2006, from Germany

Postby FrankT; Sat Jun 21, 2014 6:04 am Cubase 7.5 + Yamaha S90 XS + Win8.1

Guys, I have sent this to the Steinberg support folks, but perhaps someone here has an idea about this problem ?!

Prob: my Yamaha S90XS does not show up as Midi Keyboard in Cubase 7.5.20 nor can I use the S90XS VST3 instrument. I have installed all current Yamaha drivers: Yamaha Midi driver v3.1.3 for Win64bit and S90XS Edit/VST v.1.6.3 for Windows. The midi driver must be ok as I can use my controller CC121 properly. But the S90XS does not show up as Midi Input or in the Midi connectivity settings. (My other midi keyboards do show up!) Moreover, when I load the S90XS VST3 I get an error message from the VST that the ports have not been set properly (the VST has a menu for this). However, when I try to set the ports within the VST the S90XS is not listed as a divice (unlike controller CC121 and midi keyboard Impact LX49).

This is very frustrating, especially since the latest S90XS Editor/VST is supposed to support my configuration:

V1.6.0 -> V1.6.3

- Now supports Cubase 7.5.
- Now supports Windows 8.1.
- Now Cubase5 series are NONcompliant.
- Now Windows XP and Windows Vista are NONcompliant.
- Fixed some minor problems.

Registered Date : 4/2/2014
Language : English
Size : 52.13 MB

Any input/idea much appreciated!

Thanks
Frank
KVRAF
 
10973 posts since 18 Oct, 2003, from Berlin, Germany
 

Postby Compyfox; Sat Jun 21, 2014 9:00 am Re: Cubase 7.5 + Yamaha S90 XS + Win8.1

Two instant things pop up:

a) VST3
b) Windows 8.1


The only hints I can give you, are:

a) try to use a VST2 version, if available - VST3 is darn buggy in ALL STEINBERG PRODUCTS (I addressed this to the support as well)
b) use Windows 7, even if Steinberg (or anyone else) might say different. Win8.1 is still fairly new, and not everything audio related is working there yet


If this all worked before, roll back at some point. Worst that can happen is that the support requests to reinstall your rig.


Steinberg support seems to be overrun with Wavelab and Nuendo inquiries currently. I still wait for an answer to my last ticket. Then again, I'm sure that the usual suspects will show up in here and try to post something out of the Knowledge Base.
KVRian
 
961 posts since 13 Sep, 2006, from Germany

Postby FrankT; Sat Jun 21, 2014 8:49 pm Re: Cubase 7.5 + Yamaha S90 XS + Win8.1

You might be right that this is OS related as the whole stuff worked with Win7 and Cubase 6. But I cant go back to Win7 as building my new DAW took a hell of a lot of time. I am actually not so concerned about using the S90XS as VST instrument. Sure, I expect this to work since it is coming from the Yam/Steini combo. But I have Halion Sonic and a ton of other virtual instruments and If needed I can record the S90XS straight through my RME. But what really, really bugs me is that the S90XS isn't even recognised as my master midi keyboard. Apart from the obvious use for piano VSTs I need the weighted keys for orchestral sample instruments that are layed out across the whole 88 keys range...
KVRAF
 
10973 posts since 18 Oct, 2003, from Berlin, Germany
 

Postby Compyfox; Sun Jun 22, 2014 2:34 am Re: Cubase 7.5 + Yamaha S90 XS + Win8.1

I can totally understand the frustration, Frank.
But Steinberg/Yamaha is not a combination that is guaranteed to work. Even if they "work together" (which doesn't seem to be the case, else a lot of bugs would have been sorted).


I can only give the recommendations to maybe try a different USB port, maybe delete all USB ports and relaunch the PC and see if things reinitialize how they should. Maybe try another host just to rule out if it's Cubase's fault or not (you can never know, maybe try a former Cubase on Win8).

And as long as the VST3 standard is not really implemented and interpreted properly in either CubEndo or Wavelab (especially Wavelab!!!), I recommend you to stay the hell away from it for the time being.



Then again... who knows, maybe the most recent drivers are still funked up and even if they say that they should work, they don't. You don't know what's up - each rig setup is unique and the argument that "Macs don't cause that much trouble" doesn't count on that behalf.

This is all I can give you on the way. Else your last result is connecting your keyboard to the RME MIDI ports.
KVRian
 
961 posts since 13 Sep, 2006, from Germany

Postby FrankT; Sun Jun 22, 2014 3:40 am Re: Cubase 7.5 + Yamaha S90 XS + Win8.1

Yep, I know why I never threw away those good old 5 pin midi cables ;-)

Nonetheless, I'd expect the combo Yamaha and Steinberg to work...
I'll see what support comes back with. If this isn't solved I will have to sell the Yamaha and go for a 88 keys master midi keyboard that works with Win 8.1.
KVRAF
 
10973 posts since 18 Oct, 2003, from Berlin, Germany
 

Postby Compyfox; Sun Jun 22, 2014 4:48 am Re: Cubase 7.5 + Yamaha S90 XS + Win8.1

Again... I only trust Win8.1 as far as I can throw it. And since I don't have a copy... you know. :shrug:

Maybe it is an Win8.1 issue - it's still a fairly new OS. And I still remember issues with both VISTA and Win7 until everything worked. And that was around the time the new OS was available for a couple of months.


Good luck with the support.
KVRAF
 
5798 posts since 30 Dec, 2004, from London uk
 

Postby UltraJv; Sun Jun 22, 2014 8:07 am Re: Cubase 7.5 + Yamaha S90 XS + Win8.1

Edited : I think its a driver clash between other midi drivers you have installed. Uninstall them all then try the Yamaha one.
KVRian
 
961 posts since 13 Sep, 2006, from Germany

Postby FrankT; Sun Jun 22, 2014 11:47 pm Re: Cubase 7.5 + Yamaha S90 XS + Win8.1

I again uninstalled the drivers, and this time had CCleaner sort the registry entries. Then I reinstalled first the Yamaha midi driver and then the Yamaha Editor/VST app. The Yamaha midi driver installer stopped the install and asked for the Yamaha device to be turned on. Something that didn't pop up when I installed the drivers for the first time.
Now all is working fine, Midi as well as VST/Editor! I have informed Steinberg/Yamaha support.
Thanks for the ideas, guys!

Moderator: Moderators (Main)

Return to Hosts & Applications (Sequencers, DAWs, Audio Editors, etc.)