What is KVR Audio? | Submit News | Advertise | Developer Account

Options (Affects News & Product results only):

OS:
Format:
Include:
Quick Search KVR

"Quick Search" KVR Audio's Product Database, News Items, Developer Listings, Forum Topics and videos here. For advanced Product Database searching please use the full product search. For the forum you can use the phpBB forum search.

To utilize the power of Google you can use the integrated Google Site Search.

Products 0

Developers 0

News 0

Forum 0

Videos 0

Search  

BlueARP - VST Arpeggiator development - let's discuss! (OSX beta is out)

VST, AU, etc. plug-in Virtual Instruments discussion

Moderator: Moderators (Main)

graywolf2004
KVRist
 
265 posts since 15 Apr, 2012, from Moscow, Russia

Postby graywolf2004; Sun Jun 08, 2014 10:21 am Re: BlueARP - VST Arpeggiator development - let's discuss! (OSX beta is out)

phreaque wrote:Privet Oleg,

Molodetz for this great job.. Just wanted to ask you: FL Studio internal presets for BlueARP I made, I can't use them with the new version. I tried to rename the plugin into (BlueARP.dll) and I got many error messages (c++ runtime error) ...

Hi. You're right, currently it's not compatible with older versions, but it will be compatible. I'll write the conversion routine, it's the next item on my todo list.

sizemore0409 wrote:...Can BlueArp be used in conjunction with LMMS; and if so, would someone be willing to provide simple step-by-step instructions telling me what I need to do to be able to enjoy Oleg's BlueArp, like so many other people do?
thanks!
Andy

Hi. Probably it's something about LMMS, if they didn't fix it yet. Check this thread
http://sourceforge.net/apps/phpbb/lmms/ ... ?f=7&t=809
It says someone had the same problem with Kirnu. To check if it's BlueARP or LMMS bug, please try any other arp - Kirnu, Cthulhu, etc.


Those who had the noise problem in Cubase (last report by chk071, please check if it's still there in version 2.01)
User avatar
AusDisciple
KVRist
 
221 posts since 6 Oct, 2013, from South Australia

Postby AusDisciple; Sun Jun 08, 2014 12:06 pm Re: BlueARP - VST Arpeggiator development - let's discuss! (OSX beta is out)

I made extensive use of V2 BlueARP on my newest track Graywolf and it worked without hiccup (multiple instances in REAPER on Win8 all sync'd to my Roland System 700 sequencer). I'll be posting the new track and a description shortly.
My music - AusDisciplesBand.com. New site - Synthesizers.Audio
User avatar
AusDisciple
KVRist
 
221 posts since 6 Oct, 2013, from South Australia

Postby AusDisciple; Tue Jun 10, 2014 10:50 am Re: BlueARP - VST Arpeggiator development - let's discuss! (OSX beta is out)

Here's the link to the new track with a full description of how everything was patched and what was used.... viewtopic.php?f=14&t=413329
Loving BlueARP. Keep up the great work Graywolf. :tu:
My music - AusDisciplesBand.com. New site - Synthesizers.Audio
vanhaze
KVRist
 
70 posts since 23 Oct, 2004

Postby vanhaze; Sat Jun 21, 2014 9:15 am Re: BlueARP - VST Arpeggiator development - let's discuss! (OSX beta is out)

Many thx for this great plug, but when can we see a 64 bit Win version of it ?
I use only 64 bit plugins, that's why i am asking.
I hate bridging 32bit plugs.
Rob van Hees
vanhaze
KVRist
 
70 posts since 23 Oct, 2004

Postby vanhaze; Sat Jun 21, 2014 9:17 am Re: BlueARP - VST Arpeggiator development - let's discuss! (OSX beta is out)

Forget my post, i just overlooked and see that there is a 64bit version.
Apologizes.
Rob van Hees
graywolf2004
KVRist
 
265 posts since 15 Apr, 2012, from Moscow, Russia

Postby graywolf2004; Sat Jun 21, 2014 12:41 pm Re: BlueARP - VST Arpeggiator development - let's discuss! (OSX beta is out)

AusDisciple wrote:I made extensive use of V2 BlueARP on my newest track Graywolf and it worked without hiccup (multiple instances in REAPER on Win8 all sync'd to my Roland System 700 sequencer). I'll be posting the new track and a description shortly.

These are great news, thanks!

All
I'm still finishing the remaining stuff with PC & MAC versions. Already implemented patch compatibility, now working on skins management.
vanhaze
KVRist
 
70 posts since 23 Oct, 2004

Postby vanhaze; Sat Jun 21, 2014 12:44 pm Re: BlueARP - VST Arpeggiator development - let's discuss! (OSX beta is out)

Awesome ! Can't wait !
Rob van Hees
graywolf2004
KVRist
 
265 posts since 15 Apr, 2012, from Moscow, Russia

Postby graywolf2004; Sat Jun 28, 2014 6:41 am Re: BlueARP - VST Arpeggiator development - let's discuss! (OSX beta is out)

Hi all. Here's another update: BlueARP v2.02

Windows version (yet 32-bit only)
http://www.graywolf2004.net/files/2/Blu ... _v2.02.zip
OSX version (universal 32/64 bit bunary)
http://www.graywolf2004.net/files/2/Blu ... _v2.02.zip

Things I did since 2.01 (for both PC & Mac versions)
1. Patch (bank\program) compatibility with versions 1.1x - so you can use this one with presets/banks saved in ver 1.15x
2. GUI Settings - fine velocity and semitone range
3. Skins as separate files
4. Storing selected skin and GUI settings in BlueARP. ini
5. Minor bugfixes

So ver 2.02 should has all the functionality of the latest stable Delphi version - 1.15b3. Now I finished re-creating BlueARP with WDL-OL. Some more testing, and I'll continue adding features (gate per step is the next thing I want to add).

There is a known bug in Mac version - GUI sometimes opens with some controls disappeared, just select any skin - it will redraw the whole window.
Didn't yet figure out how to compile 64-bit version for Windows, it's either cause I have Visual Studio Express or Win64 home basic (need Pro version probably).

Please give me feedback - how it works, especially on Mac's, cause I can't test it for OSX as carefully as I do for Windows/FL Studio.
vanhaze
KVRist
 
70 posts since 23 Oct, 2004

Postby vanhaze; Sat Jun 28, 2014 9:02 am Re: BlueARP - VST Arpeggiator development - let's discuss! (OSX beta is out)

Many,many thanx and awesome it is available for OSX !
I can test the mac version in Reaper and Live (both 64bit)
Rob van Hees
sinkmusic
KVRAF
 
5583 posts since 28 Apr, 2004, from france

Postby sinkmusic; Sat Jun 28, 2014 9:33 am Re: BlueARP - VST Arpeggiator development - let's discuss! (OSX beta is out)

Thank you !
Image
vanhaze
KVRist
 
70 posts since 23 Oct, 2004

Postby vanhaze; Sun Jun 29, 2014 1:14 am Re: BlueARP - VST Arpeggiator development - let's discuss! (OSX beta is out)

Did some fast tests in Live and Reaper (osx 10.9.3 -64 bit).
Bluearp opens just fine in both and does the job well.
No strange things occured yet.

But can't wait for 64 bit pc version !!
Rob van Hees
ZXOxo67
KVRist
 
49 posts since 15 Jan, 2013, from Bremen, Germany

Postby ZXOxo67; Sun Jun 29, 2014 4:01 am Re: BlueARP - VST Arpeggiator development - let's discuss! (OSX beta is out)

Great job.
i tested it in fl 11.1 and all works like the 1.5b3. (had not much time yesterday evening)
but only the arp-latch function seems to have a bug. it stops playing after some repeats.
maybe bluarp lost his memory ?
The good old 80s never come back
a old FLStudio nerd
User avatar
chk071
KVRAF
 
3061 posts since 10 Apr, 2010, from Germany

Postby chk071; Sun Jun 29, 2014 4:20 am Re: BlueARP - VST Arpeggiator development - let's discuss! (OSX beta is out)

Are the factory presets included now again in the 2.02 version? I kind of missed those in the last version. :) Edit: Yes they are. :) Thanks for the update.
thebutler
KVRist
 
42 posts since 9 Oct, 2013, from uk

Postby thebutler; Mon Jun 30, 2014 1:25 pm Re: BlueARP - VST Arpeggiator development - let's discuss!

chk071 wrote:Btw, there's some issue i'm having when loading BlueArp in the VST instruments rack in Cubase Elements 6 32-bit on Windows 8.1 64-bit ... when i load it in the rack, i get a permanent, saw wave like, ... noise.

I'm just starting to experiment with the latest v2.02 edition of BlueARP and this issue is happening to me too. I get it 100% every time I load it in Cubase 7.5.20 (Full edition) Instrument Rack and run it - I then cannot turn it (the noise) off. It is emanating from the plugin somehow. I can run an ARP ok to a synth and it will play it fine - but the noise is still constantly there in the background.

I did have the last (v1.15b3) edition of BlueARP running fine in this project. I copied over the new *.dll for v2.02 and bingo - now this problem.

Need more info..? Let me know. See sig for system detail.
In the meantime, I will try in a fresh (clean) project

Cheers,
Bob
Win7 32bit; Q6600 2.4Ghz; 4Gb RAM; NVIDIA GeForce 8400 GS; 2x LG 21" LCD displays; MidiSport 2x2; Delta 1010LT; Yamaha HS80 and Equator Audio Research D5 studio monitors; Cubase 7.5.20; Komplete 9; Stylus RMX
thebutler
KVRist
 
42 posts since 9 Oct, 2013, from uk

Postby thebutler; Mon Jun 30, 2014 11:48 pm Re: BlueARP - VST Arpeggiator development - let's discuss! (OSX beta is out)

ok - maybe needn't be overly concerned on this; all is running/sounding fine in a brand new, fresh project with exact same synth/sounds and BlueArp v2.02 all loaded from scratch. No 'extraneous' noises, no issues.

Happy..! :)

Brilliant stuff greywolf2004 and many thanks for this lovely little piece of (free..!) genius. :) :)

Bob
Win7 32bit; Q6600 2.4Ghz; 4Gb RAM; NVIDIA GeForce 8400 GS; 2x LG 21" LCD displays; MidiSport 2x2; Delta 1010LT; Yamaha HS80 and Equator Audio Research D5 studio monitors; Cubase 7.5.20; Komplete 9; Stylus RMX
PreviousNext

Moderator: Moderators (Main)

Return to Instruments