What is KVR Audio? | Submit News | Advertise | Developer Account

Options (Affects News & Product results only):

OS:
Format:
Include:
Quick Search KVR

"Quick Search" KVR Audio's Product Database, News Items, Developer Listings, Forum Topics and videos here. For advanced Product Database searching please use the full product search. For the forum you can use the phpBB forum search.

To utilize the power of Google you can use the integrated Google Site Search.

Products 0

Developers 0

News 0

Forum 0

Videos 0

Search  

LMMS project @ GitHub (Prev. Sourceforge)

Plug-in hosts and other software applications discussion

Moderator: Moderators (Main)

glokraw
KVRAF
 
5127 posts since 6 Oct, 2004

Postby glokraw; Sun Jun 01, 2014 1:02 pm Re: LMMS project @ GitHub (Prev. Sourceforge)

tresf wrote:
briandc wrote:... where should I post this bug?


https://github.com/LMMS/lmms/issues/new

Is there any chance that when wine has something activated at system startup,
that it conflicts with lmms over vst turf? I turned that wine preloader
off a while back, just for luck, after seeing it running in htop.

I don't know if vestige relies on wine at all, but if it does,
perhaps the winecfg setting to control drawing the windows
can be reversed by users for some plugins, to aid sorting the
multitude of potential issues among gui apps out there
Cheers
tresf
KVRist
 
74 posts since 20 Jan, 2014

Postby tresf; Sun Jun 15, 2014 11:10 am Re: LMMS project @ GitHub (Prev. Sourceforge)

We plan to release 1.1.0 at the end of June.

Are there any interested beta testers that can help test and report bugs? If so, what OS would you need it for? (I can currently build for OSX and Windows 32/64 if someone would like to try it).

Image
tresf
KVRist
 
74 posts since 20 Jan, 2014

Postby tresf; Sun Jun 15, 2014 11:15 am Re: LMMS project @ GitHub (Prev. Sourceforge)

glokraw wrote:
tresf wrote:
briandc wrote:I don't know if vestige relies on wine at all


@glokraw, Sorry, missed this question. Yes, vestige relies on wine in both Linux and OSX (OSX cannot compile the vestige plugin at this time so it is not available)

When vestige is running under Windows, then it loads the plugins natively. (So as long as the 32-bit LMMS loads a 32-bit VST. The 64-bit LMMS build can run a 32-bit VST wrapper, something many DAWs cannot do out of the box! :) )

-Tres
drunken jesus
KVRist
 
81 posts since 9 Feb, 2009

Postby drunken jesus; Mon Jul 07, 2014 4:21 pm Re: LMMS project @ GitHub (Prev. Sourceforge)

I know this is a little late but I'd be happy to help beta-test if you guys are still looking for people

This project has came along way, last time I tried to use it their were a lot of bugs and glitches now it works pretty flawlessly

Is the GitHub site the main area for discussion, feature requests, & what not?
http://drunk3nj3sus.blogspot.com/ < My blog
Free samples, presets, etc.
tresf
KVRist
 
74 posts since 20 Jan, 2014

Postby tresf; Tue Jul 08, 2014 5:28 am Re: LMMS project @ GitHub (Prev. Sourceforge)

drunken jesus wrote:I know this is a little late but I'd be happy to help beta-test if you guys are still looking for people

This project has came along way, last time I tried to use it their were a lot of bugs and glitches now it works pretty flawlessly

Is the GitHub site the main area for discussion, feature requests, & what not?


Here's the latest betas created July 2nd: (windows)



If you need a build for another platform (i.e. Ubuntu) I'd recommend asking on the mailing list. We plan to offer a .deb package soon but no one has taken that role yet. (We also provide instructions for compiling from source on our GitHub wiki)

General discussion usually happens here:
https://lists.sourceforge.net/lists/listinfo/lmms-devel

Bug discussion happens here:
https://github.com/LMMS/lmms/issues?state=open
drunken jesus
KVRist
 
81 posts since 9 Feb, 2009

Postby drunken jesus; Tue Jul 08, 2014 3:25 pm Re: LMMS project @ GitHub (Prev. Sourceforge)

Thanks for the links and info, I'm gonna play around on it a bit tonight and see what kinda bugs I run into, I came across 2 in the old version
http://drunk3nj3sus.blogspot.com/ < My blog
Free samples, presets, etc.
tresf
KVRist
 
74 posts since 20 Jan, 2014

Postby tresf; Tue Jul 08, 2014 4:11 pm Re: LMMS project @ GitHub (Prev. Sourceforge)

FYI, it appears we have some VST issues in this build. I have an email out to find out why.
grymmjack
KVRAF
 
9041 posts since 6 Apr, 2003

Postby grymmjack; Tue Jul 08, 2014 4:28 pm Re: LMMS project @ GitHub (Prev. Sourceforge)

Great to see LMMS still growing. I will give it a shot. What do we use to compile the latest version on Windows 8? Will VS2012 work?

Cheers!

edit nm: https://github.com/LMMS/lmms/wiki/Compiling-lmms
tresf
KVRist
 
74 posts since 20 Jan, 2014

Postby tresf; Tue Jul 08, 2014 4:42 pm Re: LMMS project @ GitHub (Prev. Sourceforge)

The build scripts have mostly been configured for Linux and OSX, so if you need a Windows build, you'll likely have to set up the mingw dependencies inside a Linux environment. This process has been outlined for Ubuntu 12.04 here and will work in a VM if you don't have a native install. If you use another OS, you'll get furthest if it's Debian-based and we're happy to add changes to our cmake script.

https://github.com/LMMS/lmms/wiki/Compiling-lmms-(Windows)

-Tres
grymmjack
KVRAF
 
9041 posts since 6 Apr, 2003

Postby grymmjack; Tue Jul 08, 2014 6:35 pm Re: LMMS project @ GitHub (Prev. Sourceforge)

So I installed 32 bit (presuming I could use 32 bit VST) but I miss something. I cannot get any MIDI devices to show up. Did I need to do something special for this to show my MIDI controller?
tresf
KVRist
 
74 posts since 20 Jan, 2014

Postby tresf; Wed Jul 09, 2014 5:45 am Re: LMMS project @ GitHub (Prev. Sourceforge)

The very latest build has some issues and I'm not sure if this would affect MIDI or not. I assume MIDI is working fine in the previous build? MIDI in LMMS isn't the most intuitive thing to get working, so if you just need help setting it up please let me know.

-Tres
drunken jesus
KVRist
 
81 posts since 9 Feb, 2009

Postby drunken jesus; Wed Jul 09, 2014 9:57 pm Re: LMMS project @ GitHub (Prev. Sourceforge)

tresf wrote:FYI, it appears we have some VST issues in this build. I have an email out to find out why.


Yeah bridging to 32 bit in the 64 bit didn't work at all & some 64 bit plugins don't work

Didn't really have many issues with the 32 bit version & vsts, plugs that use a good bit of CPU tend to click and pop but I think thats mainly an audio driver issue, adding asio4all support into LMMS would be a really good idea if possible
http://drunk3nj3sus.blogspot.com/ < My blog
Free samples, presets, etc.
tresf
KVRist
 
74 posts since 20 Jan, 2014

Postby tresf; Thu Jul 10, 2014 6:52 am Re: LMMS project @ GitHub (Prev. Sourceforge)

We fixed the 32bit/64bit VST issue last night so I'll have a new download available in about an hour.

The popping and clicking is a known issue (but seldom discussed). I created a work-around here, but it is not elegant (vbscript file hosted on SkyDrive):

http://tresdev.blogspot.com/2013/03/fix ... 7-x64.html

Note: Chrome doesn't allow the download of VBS files, so you'll need to use another web browser.
tresf
KVRist
 
74 posts since 20 Jan, 2014

Postby tresf; Thu Jul 10, 2014 7:33 am Re: LMMS project @ GitHub (Prev. Sourceforge)

Ok, I've filed a new bug report for the VST pops/clicks here:
https://github.com/LMMS/lmms/issues/967

Any insight is appreciated.

Here are today's updated installers.


Latest 1.1 RC:





Latest 1.0 Stable:


drunken jesus
KVRist
 
81 posts since 9 Feb, 2009

Postby drunken jesus; Fri Jul 11, 2014 3:20 am Re: LMMS project @ GitHub (Prev. Sourceforge)

I don't have any programming expertise but imo the priority thing may help some but it's not the cause of the issue, all the other audio programs I use run at normal as well none change the setting to a higher priority

In FL studio if I have the audio output set to DirectSound(like LMMS) I get the same issue with clicks and pops with CPU hungry VSTs or if I have alot of VSTs in a project, & even adjusting the latency settings and sample rate don't make a difference(same as LMMS)

But if I set the output to ASIO4ALL I rarely run into problems and don't even really have to adjust the latency even when I'm only using 1 core, I dunno why it makes such a difference but for whatever reason it does, one thing I do know that it does is it takes exclusive control of the soundcard, but in XP ASIO doesn't and it still doesn't have problems with clicks and pops
http://drunk3nj3sus.blogspot.com/ < My blog
Free samples, presets, etc.
PreviousNext

Moderator: Moderators (Main)

Return to Hosts & Applications (Sequencers, DAWs, Audio Editors, etc.)