Login / Register  0 items | $0.00 NewWhat is KVR? Submit News Advertise
User avatar
Frostline
KVRist
 
139 posts since 12 Aug, 2016

Postby Frostline; Fri Jun 09, 2017 8:39 am Re: Lord of the Springs v2- The New Powers

Taron wrote:
Could you try to load up LotS and then change your BPM in Reaper before you hit a note!? That might be helpful for me!


Just tried, same behavior. Can post video if needed, but video looks exactly the same as previous except the BPM change.

Taron wrote:OH, and, yes, the decay chain is intended: Spring A is MASTER, Spring B is ...eh...employee? :lol: (no slaves here!)

I will accept that lol. Was stuck on it for awhile trying to get some duration out of the noise.
Taron wrote:The Body coming later for low notes than for high notes is its natural behavior, because the Body is essentially a frame with all the springs mounted on top. Playing a low frequency vibrates slower and stimulates the array of springs more gradually. Since all springs are tunes, resonance behavior is also depending on what stimulates the frame.

I thought that might be how it works. What I was hoping for was a control to set the frame distance or something. Something tied to keytracking. As is one pitch will sync perfectly with BPM and have the body start on the 1/8th note after. But it goes out of time when changing notes which messes up the cool synced body response.
Taron wrote:I know, all of this is not exactly what people expect from a "synth", but that's mostly because LotS isn't really a synth.

Still a very cool instrument. :tu:
And probably cursing myself here, but V2 has not crashed (yet). :hyper:
Win10 x64, Reaper 5.XX x64, i5-3330, 8gb ram, GTX-970, UC-33, Panorama P4, Wharfedale Diamond 8.2 and JVC HA-RX700
User avatar
Taron
KVRAF
 
1773 posts since 17 Apr, 2010, from Croatia

Postby Taron; Fri Jun 09, 2017 9:05 am Re: Lord of the Springs v2- The New Powers

YAY! :hyper:

Great! Thanks for doing the test! It's actually good to know that it isn't that, I guess. Now it will be more challenging to figure out what that bad voodoo might be. It's always nearly impossible, as long as I can't replicate the issue, you know. Blind guessing. But I did that for you already, AND- me so happy- You've noticed!!! :hug: ...I figured, I'll check, if values remain the same on a parameter before updating it... ...hmmmmmmmmmmmmm.... ...that makes me think! :lol:
I wonder, if the funky Reaper problem is actually the root of the new problem with your Reaper. I'm saying "your" Reaper, because I don't have this issue here in my Reaper, you know. Jeeez. Before I know that for sure, I'll try to manage my time more wisely, I think.
I still need to clean up all the preset stuff. There are still some weird things, if you don't strictly follow my concept, but you really shouldn't have to. So... some more preset GUI things to attend to. :wheee:
User avatar
Taron
KVRAF
 
1773 posts since 17 Apr, 2010, from Croatia

Postby Taron; Fri Jun 09, 2017 2:36 pm Re: Lord of the Springs v2- The New Powers

I've just posted another little hotfix. I went through the preset GUI slowly and carefully, trying to make sure it has a decent behavior.

NOW:
Creating a <New Bank will create an initialized bank. It will drop an "Init" preset in the first slot, but I may later take that off as well. It's just for orientation. Once created, you can either start making <New Presets or load presets by switching to "..." instead of bank so you can pick a preset, then switch back to your new bank and drop them in there via <New Preset. At any time you can load and save presets via the TOP BAR, of course.
Currently, anything you do to a preset that is inside the active bank, it will be modified by what you do to it. If you want to keep the original preset, just make a new preset with it by hitting <New Preset. Then modify it or switch out of the bank to "...", which should work fine, too, without modifying the bank itself.

This is such tricky stuff. There is no ideal solution, but this one feels fairly natural to me.

Other than that, I made some new sounds I put into the presets, including BASS and LEAD sounds. Try the LEAD picolino! If you play it right, you get a perfect halftone pipe. Play it almost like a SOLO instrument with only brief overlaps between the notes...something like C2 - C3 - G3 - C4 - E4 - G4 - A#4 - C5 - D5 and back down and around and so on... best with a nice echo...so mesmerizing! :violin:
User avatar
Taron
KVRAF
 
1773 posts since 17 Apr, 2010, from Croatia

Postby Taron; Sat Jun 10, 2017 4:51 pm Re: Lord of the Springs v2- The New Powers

Frostline, download again and see if that solves the startup issue, please! 8)
User avatar
Frostline
KVRist
 
139 posts since 12 Aug, 2016

Postby Frostline; Sat Jun 10, 2017 7:39 pm Re: Lord of the Springs v2- The New Powers

Taron wrote:Frostline, download again and see if that solves the startup issue, please! 8)

Startup volume of Init is good now. :tu:

Will substitute in project and let you know if anything new pops up.
It is about at the point of implosion if I don't start freezing some tracks I think though. :help:
Win10 x64, Reaper 5.XX x64, i5-3330, 8gb ram, GTX-970, UC-33, Panorama P4, Wharfedale Diamond 8.2 and JVC HA-RX700
User avatar
Taron
KVRAF
 
1773 posts since 17 Apr, 2010, from Croatia

Postby Taron; Sun Jun 11, 2017 12:11 am Re: Lord of the Springs v2- The New Powers

Ugh, how many instances are you running by now?
(and: Yehaw! Startup healed! :party: )
Armagibbon
KVRist
 
339 posts since 20 Apr, 2017

Postby Armagibbon; Sun Jun 11, 2017 5:56 am Re: Lord of the Springs v2- The New Powers

Just gotta say this synth is a fun time man. Got like 20 loaded up and my cpu isn't even budging. You done damn good.
User avatar
Taron
KVRAF
 
1773 posts since 17 Apr, 2010, from Croatia

Postby Taron; Sun Jun 11, 2017 6:07 am Re: Lord of the Springs v2- The New Powers

:o ........ :hyper: :party: :hyper:
No, wait, hold on, I should react completely different:
8)

THANK YOU for letting me know! :hug:
User avatar
Taron
KVRAF
 
1773 posts since 17 Apr, 2010, from Croatia

Postby Taron; Wed Jun 14, 2017 1:42 pm Re: Lord of the Springs v2- The New Powers

Armagibbon
KVRist
 
339 posts since 20 Apr, 2017

Postby Armagibbon; Wed Jun 28, 2017 7:34 am Re: Lord of the Springs v2- The New Powers

Aw man wish cubase had that kinda modularity. Woulda made my life a ton easier.

Still had a fun time with your synth man. Kickass work.
User avatar
Taron
KVRAF
 
1773 posts since 17 Apr, 2010, from Croatia

Postby Taron; Tue Jul 11, 2017 6:08 am Re: Lord of the Springs v2- The New Powers

Ah, Thanks Armagibbon! :hug:
...I just posted the following in the OSC thread, but it's much more at home right here:

Uuuuh, the freaking awesomeness! No idea what divine inspiration came over me, but suddenly I thought about "FOCUS" matters again. In LotS I tried to do at least some sort of autofocus in order to make it easier to send keyboard shortcuts back to the host, but it only created very distracting focus jumps. Suddenly I was wondering: Can't I just SEND messages to windows, rather than just receiving them!?
I took quick look and immediately found it, hooked it into my windows message dealings and VOILA! The new version will allow you to play/stop with space on hosts, even while LotS is in focus! :hyper: 8)
This shouldn't sound like anything special, but check with countless free synths and even some of the commercial ones, and you may find that this is not necessarily the norm! ;)
:phew:

Next update will get good! :wheee:
RichardSemper
KVRist
 
382 posts since 30 Oct, 2013, from Stoke On Trent

Postby RichardSemper; Mon Jul 17, 2017 2:08 am Re: Lord of the Springs v2- The New Powers

Taron wrote:@RichardSemper:
OH NO, this is GREAT feedback! I'll check into all of this, except the theremin thing:
- grab the NEEDLE (for spring A) and hold on to it, while you move it "over the keys" or anywhere, actually. I just move over the keys for orientation, but am actually holding on the tuning needle!

That's how that works. I didn't realize that this could be confusing, probably because I'm just too used to it already and I did consider it a gimmick. Yet, it's really super powerful. I love using it!


Grabbing and moving the needle is exactly what I did, tried it for spring A and spring B, tried to replicate the settings you had in the vid, but for some reason it does not create the same smooth transitions for me. Its as though the level peaks whenever a chromatic note is reached. The same thing happens when automating the high and low freq knobs on spring 2 - something I did in my submission, and which creates nice little trills. Take a look at my mulab project file:
https://www.dropbox.com/s/8yq1bchn2vl48 ... s.zip?dl=0
and see the automation on the pad track.
I can try again later to see what is really going on - but might be a couple of days...
http://www.richardsemper.com/
When was the Last Time you did something for the First Time.
User avatar
Taron
KVRAF
 
1773 posts since 17 Apr, 2010, from Croatia

Postby Taron; Mon Jul 17, 2017 2:28 am Re: Lord of the Springs v2- The New Powers

OOOOoooooohhhhh, you actually used curve automation to move the tuning?
Yeah, that won't work.
However, the noise frequency and resonance settings are fixed in the upcoming update! (Not there, yet!)
I likely won't be able to do that for the tuning, though, I could offer a mode for it.
If you record it live, just like I did, you shouldn't have such troubles, though!
User avatar
Taron
KVRAF
 
1773 posts since 17 Apr, 2010, from Croatia

Postby Taron; Mon Jul 17, 2017 3:00 am Re: Lord of the Springs v2- The New Powers

Try this for the noise fix. The Pad just modulates the noise frequency, which I have fixed already:
www.taron.de/Storage/vst/LotS_prerelease.rar

Here's a MuProject Theremin Demo:
www.taron.de/Storage/vst/ThereminDemo.rar
RichardSemper
KVRist
 
382 posts since 30 Oct, 2013, from Stoke On Trent

Postby RichardSemper; Tue Jul 18, 2017 7:14 am Re: Lord of the Springs v2- The New Powers

Yes I did use automation to move the tuning, I recorded it in live, then modified the curve after to get the effect i liked. That's fine for what it is and came out as intended.
I only showed you that as a quick demonstration of the effect i'm getting when moving the sliders cause its somewhat similar, and I really had no time the other day.

Thanks for posting your theremin demo, this enables me to show you what I am getting: I loaded your project and did a mixdown - FLAC version is here:
https://www.dropbox.com/s/jm8whuud5g2qw ... t.zip?dl=0

You will hear from this that what I get is not the same as you do on your setup. And this also happens just the same when moving the sliders live with the mouse. I'm really scratching my head about this because it may mean there's something fundamentally wrong somewhere in my audio setup or something, and I wonder what else that may be affecting, for eg with other synths or fx :?
I am going to try a few things, like moving location of the plugin, changing ASIO settings etc. Will let you know if anything works.
http://www.richardsemper.com/
When was the Last Time you did something for the First Time.
PreviousNext

Moderator: Moderators (Main)

Return to Instruments