What is KVR Audio? | Submit News | Advertise | Developer Account

Options (Affects News & Product results only):

OS:
Format:
Include:
Quick Search KVR

"Quick Search" KVR Audio's Product Database, News Items, Developer Listings, Forum Topics and videos here. For advanced Product Database searching please use the full product search. For the forum you can use the phpBB forum search.

To utilize the power of Google you can use the integrated Google Site Search.

Products 0

Developers 0

News 0

Forum 0

Videos 0

Search  
User avatar
KVRian
 
1266 posts since 12 Jun, 2003, from Denmark
 

Postby metal; Thu Dec 18, 2008 12:19 am

This thread is for bug reports only please. Please request features, and ask questions on another thread.

If you do encounter a bug, we would like to sincerely apologize for the inconvenience this causes you. We'd also like to reassure you that we will work hard to ensure that all bugs are dealt with rapidly - as a company, our main priority is to iron out all these problems as soon as possible there are currently two developers devoting there time working on solving these issues, and we also have several people testing and working on solutions. Unlike most companies, we are keeping our bug list publicly viewable, as we believe its the most efficient way to communicate with our users - and also there's nothing like having it public to motivate us to resolve these issues rapdily!

We would appreciate both your patience and assistance in helping us to recreate the issue you have.

How To Report A Bug

Before reporting a bug, it would be helpful if you could check the FAQs on the support page, and also check this thread to see if it has already been reported - only add an additional report if you feel you can add some useful information for locating the problem.

Please copy and paste the following, and fill in at least the REPRODUCE, EXPECTED BEHAVIOUR and OBSERVED BEHAVIOUR fields:

Code: Select all

STATUS:
ASSIGNED TO:

VERSION:
HOW TO REPRODUCE:
EXPECTED BEHAVIOUR:
OBSERVED BEHAVIOUR:


If Alchemy is failing to start up properly, please paste the contents of the AlchemyLog.txt file afterwards.

Mac users who experience a crash should email the crash log to support(at)camelaudio.com with the title 'Mac Crash Log'. You can obtain the crash log by going to your username Library/Logs/CrashReporter folder and finding your sequencer log, or when it crashes you can click on Report and copy the text into an email.

ASSIGNED TO: If the status is Cannot Repeat, then this should be the name of the support person who is following up with the user. If the status is Confirmed then it should be the name of a developer. If its related to the GUI it should be 'Rob', if its a problem with a particular preset or sample (eg. tuning issue) it should be assigned to 'Tim' and otherwise should be 'John'.
STATUS: What's the current status with the bug - must be one of: Investigating / Cannot Repeat / Confirmed / Not a Bug / Fixed In Update
VERSION: Please give the Alchemy version number, operating system and host in which the problem occurs.
HOW TO REPRODUCE: Complete steps to reproduce the bug. We can only fix the problem if we can recreate it, so please ensure that following these steps reliable reproduces the problem.
EXPECTED BEHAVIOUR: Expected behavior
OBSERVED BEHAVIOUR: Observed (buggy) behavior. If an error message is displayed, please type the contents in here. Please do not include screenshots - we will request them if we really need them.

Moderation Rules

The following is information is intended for moderators of this forum. Keeping this thread up to date and tidy is a top priority as it allows the developers to most efficiently solve the problems. Please moderate this thread thoroughly and frequently to ensure it complies with the rules below:
- Move bugs reported elsewhere to this thread and remove the other reports
- Reformat any bugs which do not comply exactly with the form above. If the user has reported multiple bugs in each post, each bug report must be as specified as above.
- Move feature requests to the suggestions thread.
- Remove any posts from this thread which are not bug reports.
- Remove any duplicate bug reports and merge any additional information contained in the extra bug report into the original report.
- Any bugs which have a status of 'Investigating' should be investigated by you, if you have access to the given operating system and host. If you can repeat it then please set the status to 'Confirmed' and set the ASSIGNED TO field. If you have the same setup but can't repeat it, then set the status to 'Cannot Repeat' and set the ASSIGNED TO field to your KvR name. Then email or PM the user and request further information. Correspond with the user until you are able to repeat the problem. If the user does not respond to repeated requests for information within a period of two weeks from the time the bug is reported then delete the report.

When a new update is released:
- Remove any bugs with status 'Fixed In Update', also remove bugs with status 'Not a Bug'.

(This thread was rewritten by Ben [Camel Audio]).

Tim: NOTE: beta testers are currently testing new versions, so if you see a different revision number in the reports then the one you have, do not worry. We will notify all users when an update is ready for download on the support site.
Last edited by metal on Mon Dec 22, 2008 9:30 am, edited 2 times in total.
music // vibrants // soundcloud
soundsets for synths // twolegstoneworks
KVRist
 
111 posts since 6 Jul, 2004

Postby fhunktion; Thu Dec 18, 2008 3:23 pm

STATUS: Cannot Repeat
ASSIGNED TO: Tim

VERSION: 1.04, Mac OSX 10.5.5, Ableton Live LE 7
HOW TO REPRODUCE: Loading a sample into the granular engine
EXPECTED BEHAVIOUR:
OBSERVED BEHAVIOUR: Crashes Ableton Live LE. Didn't get the spinning beachball or anything. Live just crashed.

Col: Cannot repeat
Ben: Get the file causing the problem and see if you can repeat. Could be related to not loading certain AIF files, which is fixed in 1.06.

Col: follow up PM sent 30/01/2008
KVRer
 
14 posts since 18 Dec, 2008

Postby UmFuFu; Thu Dec 18, 2008 5:06 pm

STATUS: Cannot Repeat
ASSIGNED TO: Tim

Note: we need someone to test this in Nuendo specifically.

VERSION: 1.04, Mac OSX 10.5.6, Steinberg Nuendo
HOW TO REPRODUCE: The random button causes Nuendo to crash. Everytime. Also, the "Save As" button just cause the same crash.
EXPECTED BEHAVIOUR:
OBSERVED BEHAVIOUR: Crashes Nuendo

Tim: I do not have Nuendo to test. Save As and Random works fine on other hosts.
KVRAF
 
2462 posts since 7 Jul, 2002, from Limerick, Ireland
 

Postby mckenic; Thu Dec 18, 2008 7:40 pm

STATUS: Cannot Repeat
ASSIGNED TO: Tim

VERSION: 1.04, Mac OSX 10.5.5, Logic Pro 8.0.2, 2.4Ghz Core 2 Duo

HOW TO REPRODUCE: Load Alchemy - pick a sound create a midi part to play that sound. As your inputting notes you can hear the patch. Press play and the sound goes away - open the Alchemy plugin GUI and switch presets then switch back and the sound is available again - UNTIL you stop playback then the sound is gone again when you restart playback.

EXPECTED BEHAVIOUR:
OBSERVED BEHAVIOUR: Its not playing nice AT ALL with Logic 8.0.2.

Tim: Could not reproduce Logic8

ZenPunkHippy: I've not noticed this behaviour at all in Logic 8.0.2 / OS X 10.5.6

Col: Cannot reproduce
KVRAF
 
9013 posts since 6 Apr, 2003

Postby grymmjack; Thu Dec 18, 2008 10:08 pm

The following reported bugs are related to the problem with Clear from the Arp menu.

=========================================
STATUS: Not a bug
ASSIGNED TO: ZenPunkHippy

VERSION: 1.04 / All

HOW TO REPRODUCE:
1. file | import all -> midi clip into the arp
2. play something - perfect, just as imported
3. file | clear - expected EVERYTHING to clear
4. play something - NOTES still there from import

EXPECTED BEHAVIOUR: Arp is cleared completely
OBSERVED BEHAVIOUR: Only the currently selected Arp page is cleared

Tim: Could not reproduce. Win. Selecting clear from the arp menu clears the notes in the arp.

ADDITIONAL INFO:

ZenPunkHippy: See the following bug report for more details.

http://www.kvraudio.com/forum/viewtopic ... 09#3386809

Ben: Assuming that point 3 relates to the file menu in the arp seq area, then this is not a bug. That menu clears the current arpseq only - it is not designed to clear all patterns.

==========================================
STATUS: Not a bug
ASSIGNED TO: ZenPunkHippy

VERSION: 1.04, Win VST / OS X AU, Logic Studio, Live 7 (Windows), OS X 10.5.6, XP SP 2
Reported by ZenPunkHippy

REPRODUCE: Create 2 or more ARP's and set the number of steps to more or less than the default e.g. 32 - observe that all ARP's are set to the same length.

EXPECTED BEHAVIOUR: After using the Clear ARP menu function, all ARP's should return to 16 steps
OBSERVED BEHAVIOUR: Only the currently selected ARP is cleared, the others remain at the previously set length.

ADDITIONAL INFO: After the bug is triggered, if you set the length of one of the ARP's manually, all ARP's are returned to the same length value.

Ben: Assuming that point 3 relates to the file menu in the arp seq area, then this is not a bug. That menu clears the current arpseq only - it is not designed to clear all patterns.
KVRist
 
389 posts since 18 Oct, 2003, from UK in t'north canny good like

Postby simesf; Fri Dec 19, 2008 1:46 am

STATUS: Cannot Repeat
ASSIGNED TO: Tim

VERSION: 1.04, Win Win XP SP3, Sonar Producer 8, dual core pc
HOW TO REPRODUCE: I installed to a programfiles/vstplugins/misc/alchemy folder. The only other synth in there is Massive.
EXPECTED BEHAVIOUR:
OBSERVED BEHAVIOUR: It was recognised and played fine in Acid Pro 6 and EnergyXT version1 but when I navigated to the folder in Sonar 8 Producer I only saw the Massive vst in the folder.

Tim: Could not reproduce. Works Ok in Sonar7 on my System.
ZenPunkHippy: Cannot reproduce in Sonar 7 Producer Edition (Trial version). Probably related to VST cache issues, as most similar issues in various hosts have been fixed by forcing the host to re-scan for VST's.
www.drippycat.com - switchaball for iPhone, switchballHD for iPad
KVRAF
 
17906 posts since 1 Oct, 2001, from England

Postby Kriminal; Fri Dec 19, 2008 3:58 am

STATUS: Cannot Repeat
ASSIGNED TO: ZenPunkHippy

VERSION: 1.04, Live 7 and Tracktion 3
HOW TO REPRODUCE:
EXPECTED BEHAVIOUR:
OBSERVED BEHAVIOUR: Same problem as reported by Kriminal.
NorthSouth: Don't despair, I'm having the same problems as you, install /uninstall/install/uninstall etc, Tim already knows. Install goes well and all, but it just won't show.

Live 7, no show, rescan no show, Tracktion 3 same and puts it in the "nono list" .
Kore2 crashes the second it sees the DLL at start-up when scanning for plugs

[EDIT ZenPunkHippy] The updated DLL was sent to NorthSouth but Alchemy is still not running. This note was left on 26/12/08:

Received it a couple of days ago from John, still not working.
Tons of stuff running but this just won't show, as in "ignore listed"

NOTE: PM sent to user 22-Jan. Reply from user states a motherboard failure / replacement means the problem cannot be verified or pursued further. The user is willing to close this bug as Cannot Repeat.
User avatar
KVRian
 
509 posts since 13 Mar, 2008, from Finland
 

Postby muLperi; Fri Dec 19, 2008 4:49 am

The following reported bugs are related to the missing first note doesn't trigger correctly.

These issues may be related to the following bug report (includes steps to reproduce in Logic):

http://www.kvraudio.com/forum/viewtopic ... 91#3431091

==============================================
STATUS: Not Fixed 1.06
ASSIGNED TO: John

VERSION: 1.04 / FL Studio 7 / All Hosts with piano roll
Reported by muLperi
HOW TO REPRODUCE: Starting playback, pattern/song

EXPECTED BEHAVIOUR:
OBSERVED BEHAVIOUR: First note doesn't make a sound at all if placed right in the starting position. This error can be avoided starting the song (or not in the pianoroll) for example from the second bar. But annoying since no other plugins do that and I don't want to use any strange methods. When simple mode, plugin windows bottom half shows green blank

Tim: Somewhat confirmed. Used a percussive tone for patch, and it appears that the initial attack is not sounding, but it does play the note. Moving the note over a little does make the attack come in. However if note is at the start of the pattern, the initial attack does not sound.

Also simple/advanced mode bug confirmed. This may be a wrapper issue.

ZenPunkHippy: I have noticed this behaviour in all hosts that have a piano roll. If the first note is too close to the first beat when the transport is activated, the note will not sound, or the "attack" of the note will be modulated incorrectly.

The note always plays correctly when the transport completes one cycle and loops.

This is related to the following bug report:

http://www.kvraudio.com/forum/viewtopic ... 42#3385142

Tim: v1.06 Win: Fl Studio
Still not fixed. Putting a note on first beat in piano roll in FL studio still has a delay then first time it starts. If it cycles 2nd time, it is OK. Just the initial start is still delayed. Other plugins in FL work as expected with note start in same position....I just used a piano roll, and inserted a note at the very beginning, and used a piano or bell patch in Alchemy. Set status to Not Fixed
---------------------------------------------------------------

==================================================
STATUS: Not Fixed 1.06
ASSIGNED TO: John

VERSION: 1.04, Mac 10.5.6, Logic 8.0.2, MacBookPro Intel 2,6, Sound card: tested with integred, Maudio FW410
Reported by eatyone

HOW TO REPRODUCE: Playing ARP synth in loop.

EXPECTED BEHAVIOUR: The loop should start at the start of the song.
OBSERVED BEHAVIOUR: The loop doesn't start well, the first note isn't playing, but when it's in loop mode, the second pass is ok...i try to play with the latency but no results.

Same prob with:
Win XP SP2
FLS 8.0.2
MacBookPro Intel 2,6
tested with Asio4all and MAUDIO FW410...

This may be related to the bug where the first note in a sequence does not trigger correctly if it occurs immediately after transport of the host is started.

Tim: need some more description of the issue. First I recorded a small section ( in live7) using a patch with ARP on. Then looped that section. I also put a drum loop on another track for timing comparisons. It seems to loop fine and in time. However, perhaps I am not reproducing the issue correctly, so need more info. Also tried in FL Studio.8. ( although this could be part of the FL bug for first note attack not being heard) PM sent 9-jan-09

==============================================
STATUS: Not Fixed 1.06
ASSIGNED TO: John

VERSION: 0.93 Mac G5 Logic
REPORTED BY: John Lehmkuhl (from dev forum)

HOW TO REPRODUCE: I was doing a test sequence in Logic Pro and noticed something odd and a problem for me. The very 1st note on is slowly faded in on measure 1 beat 1. I have "Bell Dancer" from the Loops category loaded and the 1st not is missing attack. Please have a look at this. I did another test where measure 1 beat 1 is my additive Dream Guitar and the effects are clamped on the first note. It should not do that if possible

EXPECTED BEHAVIOUR: first note should sound as usual
OBSERVED BEHAVIOUR: first note fades in

Tim: this may be related the the FL studio bug in which it has similar issues.
User avatar
KVRAF
 
4078 posts since 16 Feb, 2005, from Kingston, Jamaica

Postby zvenx; Fri Dec 19, 2008 6:15 am

STATUS: Confirmed
ASSIGNED TO: Col

VERSION: 1.04
HOW TO REPRODUCE: Load the preset Ensemblator in the Keys category (Factory presets)
EXPECTED BEHAVIOUR:
OBSERVED BEHAVIOUR: The preset is tuned one semitone sharp.
User avatar
KVRAF
 
7972 posts since 9 Jan, 2004, from leroyaumeuni

Postby spaceman; Fri Dec 19, 2008 1:50 pm

STATUS: Confirmed (see note 3-Feb)
ASSIGNED TO: John
PRIORITY: High

VERSION: 1.04, Mac OSX 10.5.5, Logic 8.0.2, 2.4 MBP, 2GB RAM, Saffire LE
HOW TO REPRODUCE: Changing presets by clicking on the 'next' arrow
EXPECTED BEHAVIOUR:
OBSERVED BEHAVIOUR: It crashed Logic when clicking on the 'next' arrow in the drop down for selecting a source. I was cycling through string sounds.

Tim: Could not reproduce Logic8.

Col: Cannot reproduce

[ZenPunkHippy] - I have noticed this bug on a number of occasions - I cannot reproduce it reliably yet, although it always occurs when crossing the menu boundary from one folder to the next e.g. Basic / Triangle oscillator -> Pulse / Pul25-Arp

[ZPH 3-Feb] A bug report from a new user confirms this bug is occurring intermittently. An e-mail titled "Logic Crash Logs - Next Arrow Bug" has been sent to support containing 2 crash logs relating to this issue. As noted previously, it is occurring at the boundary of a menu, as it rolls over to the next category.

VERSION: v1.04 AU / Logic 8.02, Macbook Pro, 10.5.6
REPORTED BY: Mr. Tingle

OBSERVED BEHAVIOUR: When I click the 'left' or back preset button (the little left and right arrows on the screen) when the menu has reached its end (ie first or last preset)

This happens on different 'left buttons' ie not just on the main preset selection section but also on the sound source section also. I may happen on all the different places where these 2 little buttons appear.

Anyway the end result is that Logic crashs instantly and quits to the desktop.

Happened about 3 times so far and I've had Alchemy a few days.
Last edited by spaceman on Fri Dec 19, 2008 2:51 pm, edited 4 times in total.
My other host is Bruce Forsyth
User avatar
KVRAF
 
2366 posts since 9 Jan, 2003, from Saint Louis MO
  

Postby foosnark; Sun Dec 21, 2008 12:46 am

STATUS: Confirmed
ASSIGNED TO: Col

The following are reported bugs related to the randomize function

=============================================
VERSION: 1.04, Windows XP, FLStudio 8.0.0

HOW TO REPRODUCE: Using randomize function

EXPECTED BEHAVIOUR:
OBSERVED BEHAVIOUR:
-- "Preserve" is turned off, and tuning/pitchbend are overwritten.
-- All random patches with the "Guitar" category assign LFO 1 to Master Tune Fine with full depth.

Tim: if you move your mod wheel, this fixes it, as mod wheel is assigned to this parameter for vibrato effects.

-- While in the "Arpeggiated" category, it actually just picks a random category

Tim: Confirmed

-- While in the "Loops" category, it often makes arp type sounds.

Tim: It is a mix of arp and selecting samples from the loop folder. Using arp is OK for loop sounds.

-- Many random "arp" sounds have an arp mode of 0 (and not even a perform knob assignment to the mode)... and are thus not arps.

Tim: Confirmed in some randomization's.

[foosnark edited to add version/host/OS]

=============================================
STATUS: Confirmed
ASSIGNED TO: Col

VERSION: 1.04, Win
Reported by ugo

HOW TO REPRODUCE: Pick a guitar preset, then randomize

EXPECTED BEHAVIOUR: No constant LFO modulation for the pitch
OBSERVED BEHAVIOUR: When randomizing a guitar preset, LFO 1 is always getting assigned to the master fine tune. The depth for this modulation is assigned to performance control 7, which is getting set to 100%. As a result, a randomized guitar preset always gets a constantly running pitch bend.

============================================
STATUS: Confirmed
ASSIGNED TO: John

VERSION: 1.04 / All Hosts

HOW TO REPRODUCE: Select Randomise from the MSEG or Sequencer files menus
EXPECTED BEHAVIOUR: The modulator envelope or sequence is randomised
OBSERVED BEHAVIOUR: MSEG - Only the set up parameters for the section are randomised

ADDITIONAL INFO: Users are expecting to see the MSEG randomised, Ben has confirmed this as something that requires implementation.
Last edited by foosnark on Sun Dec 21, 2008 3:08 pm, edited 1 time in total.
KVRer
 
7 posts since 21 Dec, 2008

Postby swamilove; Sun Dec 21, 2008 1:26 pm

STATUS: Confirmed
ASSIGNED TO: John

VERSION: 1.04, Windows
HOW TO REPRODUCE: Test key velocity while arp is in Chord mode.
EXPECTED BEHAVIOUR: Arp should still respond to key velocity if the velocity knob is up.
OBSERVED BEHAVIOUR: Key velocity appears to be ignored in Chord mode.

Tim: Verified. Key velocity appears to be ignored in Chord mode.
KVRist
 
477 posts since 7 Jul, 2004, from Skopje

Postby marvotron; Sun Dec 21, 2008 1:46 pm

STATUS: Confirmed
ASSIGNED TO: John

The following are reported bugs concerning a pop-up dialog when saving a preset.

======================================
VERSION: 1.04, Win XP Pro SP3, Ableton Live 7.0.12

HOW TO REPRODUCE: Save a live set with a patch that has large data

EXPECTED BEHAVIOUR: Clicking OK in the "Please select a location and filename for supporting data files.." should open a dialog.

OBSERVED BEHAVIOUR: The dialog doesnt appear if the alchemy UI isnt open.
Now i know that the main UI has to be open its not such a problem. :)

Tim: Verified.The dialog does not appear if the Alchemy GUI is not open.

======================================
STATUS: Confirmed
ASSIGNED TO: John

VERSION: 1.02 Win
Reported by Torben Hansen (from dev forum)

HOW TO REPRODUCE: Start a new song. Load Alchemy and load the preset Factory>Sound Effects>Alien Planetscape. Save the song. Upon saving Alchemy gives this message: "Please select a location and filename for supporting data files..." If you load the song again Alchemy wont load the preset automatically.

EXPECTED BEHAVIOUR: Song should save without errormessage from Alchemy and the preset should load by itself after loading the song where it's used.

OBSERVED BEHAVIOUR: Alchemy displays message upon saving a song from both Renoise and Cubase 4.

Ben: I can repeat this, and agree it needs fixed. You can work around it by saying 'OK' and selecting a location to save the preset - we strongly recommend the folder for your song. Because you can workaround it easily and this issue only concerns 5% of the presets.
User avatar
KVRAF
 
9613 posts since 18 Jun, 2008, from Melbourne, Australia
 

Postby ZenPunkHippy; Mon Dec 22, 2008 12:08 am

STATUS: Fixed v1.05
ASSIGNED TO: Rob

The following are reported bugs about visible hidden system folders in the Alchemy file-browser

=====================================
VERSION: 1.04, MAC AU / All OSX 10.5.6, Logic 8.0.2
HOW TO REPRODUCE: Open the file browser via Import Audio, navigate to the top of the tree (system disk, root folder)
EXPECTED BEHAVIOUR: view contains only the folders presented by OS X Finder
OBSERVED BEHAVIOUR: various system folders displayed (bin, private, sbin, and some others) that are normally hidden from view, and unnecessary
Will confirm similar behaviour for hidden folders on Windows XP after install

UPDATE: This behaviour is CONFIRMED on Win XP SP2 - various hidden directories are displayed on all volumes in the Alchemy browser e.g. RECYCLER and "System Volume Information"

[ZPH] Seems fixed in OS X 10.5.6 AU, v1.05

=======================================
STATUS: Fixed 1.05
ASSIGNED TO: Rob

VERSION: 1.04, Mac and Win
REPORTED BY: ZenPunkHippy (from dev forum)
REPRODUCE: Open the file browser via Import Audio, navigate to the top of the tree (system disk, root folder)
EXPECTED BEHAVIOUR: view contains only the folders presented by OS X Finder (or Windows Explorer)
OBSERVED BEHAVIOUR: various system folders displayed (bin, private, sbin, and some others) that are normally hidden from view, and unnecessary

Col: 1.05 Mac - doesn't seem entirely fixed here. In import browser, i see a folder called 'Mach' at root which isn't visible in finder. Also in Alchemy App Support folder there is a folder not present in finder....it has a long gobblidegook name beginning with %F4%F4....

Tim: v1.5 Win: seems to be fixed here
[ZPH] No hidden folders visible in OS X 10.5.6 AU, v1.05
Last edited by ZenPunkHippy on Sun Jan 25, 2009 7:42 am, edited 5 times in total.
User avatar
KVRian
 
948 posts since 15 Jan, 2005, from los angeles,ca

Postby cain; Mon Dec 22, 2008 12:48 am

STATUS: Fixed in update (1.05)
ASSIGNED TO: John

The following reported bugs are related to the problem with using midichannel 2 thru 16

===========================================
VERSION: 1.04, Win XP SP3, cubase vst 5.2

HOW TO REPRODUCE: not getting any sound out of midi channel 2 thru 16
EXPECTED BEHAVIOUR:
OBSERVED BEHAVIOUR:get sound if choosen from midi channel 1 but no sound if chosen from midi channel 2 thru 16.

[EDIT ZenPunkHippy] CONFIRMED in the following environments:

Win XP SP2
- Cubase 3 SX
- Sonar 7 Producer Edition

Win XP SP3
- eXT1.41

OS X 10.5.6
- Logic Studio 8
- Numerology 2 RC2

Note: there is no reason that I know of to explain why Alchemy would only accept note input from MIDI channel 1

[EDIT ew] If you're talking about actual physical input fronm the controller having to be on channel 1, that in itself's not that uncommon- for example, most NI plugs only receive on channel 1. They expect the host to do the rechannelizing, and expect the input of the track to be omni or channel 1.

In this case, it seems to be a bug, though. It doesn't work in Kore 2, yet works with Chainer. I'll do some more testing with my other hosts.

Tim: Bug verified in Live7. Switch track to Midi chamme 2, and Alc does not sound.

[ZPH] Fixed in v1.5 (OS X 10.5.6, Logic 8.0.2, AU)

=========================================
STATUS: Fixed in update (1.05)
ASSIGNED TO: John

VERSION: MAC Logic pro 8 OS 10.4.11
Reported by carambo
REPRODUCE: Try to play via MIDI keyboard
EXPECTED BEHAVIOUR: get some sound through my midi keyboard
OBSERVED BEHAVIOUR: get some sound only through the keyboard device in Logic !

This is in addition to a previous bug report where I did't get any sound at all, then it came back and forth ! But actually the sound I had was always through the internal keyboard in Logic, where I draw directly my notes, so it works like this, but I have never succeed to get any sound through my external midi keyboard, while it works for any other plug in of course ! Problem with midi mapping ??

John (Camel Audio): As you are able to use the Logic step input keyboard it sounds like your keyboard may be set to a MIDI channel other than 1. There is a known bug in Alchemy that it only accepts MIDI events in channel 1 and all others are ignored. Hope this is helpful.

Carambo : ok, understood, my keyboard was on 16. Thanks.

==========================================
STATUS: Fixed in update (1.05)
ASSIGNED TO: John

VERSION: Alchemy 1.04 / Windows Vista Home, Win Xp sp3, FL Studio 8
Reported by Yuroun
HOW TO REPRODUCE: Drop Alchemy on a channel and select a preset, import a midi file in a pattern.
EXPECTED BEHAVIOUR: to hear the notes in the piano roll
OBSERVED BEHAVIOUR: no sound, nothing. The problem is in the piano roll, because you can hear the sound by pressing the piano keys.

The user has provided a sample MIDI file for testing. Importing the file in to Logic proves this is not a Type 0 file - it has multiple tracks, and is therefore not currently supported by Alchemy.

The first MIDI track defaults to channel "Any", and no sound is produced from the notes in the piano roll. Changing the MIDI channel to 1 caused notes to play correctly.

The MIDI channel bug has been fixed in a future update. Importing a Type 1 file with multiple MIDI tracks to the ARP section is not currently supported by Alchemy at present.

Col: v1.05 Mac - Seems to be fixed
Tim: v1.5 Win Fixed ( Midi Channel issues)
[ZPH] Fixed in v1.5 (OS X 10.5.6, Logic 8.0.2, AU)
Next

Moderators: ZenPunkHippy, ugo, biomechanoid, Ben [Camel Audio]

Return to Camel Audio