What is KVR Audio? | Submit News | Advertise | Developer Account

Options (Affects News & Product results only):

OS:
Format:
Include:
Quick Search KVR

"Quick Search" KVR Audio's Product Database, News Items, Developer Listings, Forum Topics and videos here. For advanced Product Database searching please use the full product search. For the forum you can use the phpBB forum search.

To utilize the power of Google you can use the integrated Google Site Search.

Products 0

Developers 0

News 0

Forum 0

Videos 0

Search  

WaveShells and Sonar X1 Plugin Manager

VST, AU, etc. plug-in Virtual Effects discussion

Moderator: Moderators (Main)

J4R1O
KVRist
 
381 posts since 1 Jan, 2013

Postby J4R1O; Wed May 22, 2013 1:40 am WaveShells and Sonar X1 Plugin Manager

Hi guys,

Last nite I installed Waves NS1 demo on my computer and once again I had to do this little "trick" to make Sonar's Plugin Manager to notice that there is a new plugin (demo) installed. The trick is that I have to cut WaveShells from my VstPlugin folder (which is located on my Audio Program drive (F) - and launch Sonar, shut Sonar, move WaveShells back to their original location and after that manouver every new plugin is listed on Sonar's Plugin Manager. Weird, isn't it?

But something happened last nite. During my special "trick" I accidentally opened one of my current projects and because those WaveShells were "on exile", Sonar couldn't locate them. No problem. I closed that project and hoped that there was no damage done. After that I moved WaveShells back to their folder and reopened that same project and then I got this:

Locate VST Plug-in

The following VST Plug-in CLSID could not be matched with an entry in the VST plug-in list. Please identify the plugin from the nearest matches listed below.

Original Name: The King's Microphones Stereo
Original CLSID: {lots of numbers and letters}

New CLSID: {lots of numbers and letters}
New Path: f:/audio programs/vstplugins/WaveShell-VST


:-o

After clickin "OK" (couple of times) project opened and The King's Microphones and all those other unlocated Waves plugins were located and working. So after that I opened Plugin Manager and rescanned every plugin. BTW: my Waves folder was lost so I had to create a new one and add all my Waves plugins to the folder. That was little weird.

Ok, I shut Sonar and reopened that same project file. Waves screen popped up to tell me there was 53 Waves plugins (Diamond and Silver) that were not available anymore (demo expired), ok, clicked "SKIP". Back to Plugin Manager and all those 53 expired Waves plugins were gone and I thought that it may have solved the problem. I repeated this couple of times to make sure that everything was working and went to bed.

This morning that same "Locate VST Plug-in" screen popped again + that Waves expired plugins screen. :? This time I cut WaveShell 9.1 from its folder and after that everything seems to work again. My Waves folder was lost (again), so I created another.

Now everything seems to work fine :pray:, but I'm still not sure is that WaveShell 9.1 (x64) .dll file necessary/must-have-there (guess not 'cos everything seems to work normally). That damn file seem to cause some problems: double plugins on the plugin manager list, Waves pop-up screens, new installed Waves demos not found, etc. Should I delete it or what? It's still on my computer, behind the bars.

So what do you guys think? Hope you managed to understand me... poor english, not enough sleep and too much coffee. :)
User avatar
whyterabbyt
Beware the Quoth
 
21398 posts since 3 Sep, 2001, from R'lyeh Oceanic Amusement Park and Funfair

Postby whyterabbyt; Wed May 22, 2013 2:48 am

You could try using the xlutop wrapper/shell to 'unpack' them so they look like separate plugins.

http://www.kvraudio.com/forum/viewtopic.php?t=177538
To laymen, software development is something akin to wizardry. Neither time, nor effort are involved. If software is missing features they want, or has bugs, it is solely because someone has been too lazy to wave their magic wand.
J4R1O
KVRist
 
381 posts since 1 Jan, 2013

Postby J4R1O; Wed May 22, 2013 3:19 am

Just downloaded the Manny Marroquin bundle and I'd like to demonstrate you what's goin' on.

Downloaded/installed via WOTI, 7-day demo license activated via Waves License Center and license transferred to my USB stick. Plugin location: f:/Audio Programs/Waves/Plug-Ins. So everything seems to be ok.

Launced Sonar X1 and Cakewalk Plug-In Manager x64:

Plug-in Categories (9 found)
Registered Plug-Ins (212 found)

...but no MannyM plugins. What a surprise.

Ok. I try to Re-scan failed and existing plugins... Scanning... let's see what happens... Waves License Error pop-up: The following Waves plugins do not have licenses. Please check that you have valid licenses for these plugins, then click 'Rescan licenses'. To continue without these plugins, click 'Skip'.

Skipped, obviously.

Ok, let's have a look at Plugin Manager...

Registered Plug-ins (307 found). WTF?! Now it shows those MannyM plugins + there are TRIPLES of all my waves plugins! to fix this I have to remove Waves Plugin folder from my VST Plugin from Scan Paths. After that there are only doubles (32-bit and 64-bit versions):

MannyM Delay Mono/Stereo
MannyM Delay Mono/Stereo (0) <-- double
MannyM Delay Stereo
MannyM Delay Stereo (0) <-- double


I don't need those 32-bit versions, and there is no WaveShell located on my VstPlugin folder, so why these doubles exist?

I try to do my trick and cut WaveShells from my VST folder and launch Sonar... 184 Plugins found and no Waves folder. I shut Sonar, put back those WaveShells and relaunch Sonar... Scanning... (no answer)... cancel... Cakewalk VST Scan not answering... shutting VST Scan... Waves License Error screen... Sonar open... Waves folder lost... 225 plugins found (including MannyM plugins)... shut Sonar, reopen Sonar... no Waves License Error screen... Waves folder but including only MannyM plugins, so I have to add all my purchased Waves plugins again.

So, what is this shit?! Why is this so complicated?!! :bang:


EDIT: They're all working now, for now. :pray: No doubles, no Waves License Error screens, no unlocated plugins... But there's way too much hassle to get those new plugin demos work right. Something is definitely wrong, but don't know what. :?

Moderator: Moderators (Main)

Return to Effects