What is KVR Audio? | Submit News | Advertise | Developer Account

Options (Affects News & Product results only):

OS:
Format:
Include:
Quick Search KVR

"Quick Search" KVR Audio's Product Database, News Items, Developer Listings, Forum Topics and videos here. For advanced Product Database searching please use the full product search. For the forum you can use the phpBB forum search.

To utilize the power of Google you can use the integrated Google Site Search.

Products 0

Developers 0

News 0

Forum 0

Videos 0

Search  

The crash thread

Discussion about: tracktion.com

Moderators: valley, jules, TSC, ModuLR

skipkent
KVRian
 
1112 posts since 21 Jul, 2004

Postby skipkent; Thu Jan 24, 2013 8:12 pm The crash thread

Thought I'd start a thread for any instances in which T4 is crashing.

For me so far it crashes reliably on Mac when I put the Drum Core Free vst on a track. Plugin available here:

http://www.sonomawireworks.com/drumcore/downloads/
Music is something you DO. Spend time, not money.
http://www.myspace.com/skipkent
http://soundcloud.com/skipkent
TSC
Tracktioneer
 
273 posts since 31 Dec, 2012, from Seattle

Postby TSC; Thu Jan 24, 2013 8:16 pm

Forwarded directly to Jules for bug fixings.

Thanks for the feedback.
Tracktion Software Corporation
frankvg
KVRian
 
584 posts since 4 Jun, 2004

Postby frankvg; Thu Jan 24, 2013 11:47 pm

All Mackie plugins have no gui and seem to crash T.
Btw Jules, would you like us to send crash logs directly to you?
jules
Chief Tracktioneer
 
474 posts since 14 Nov, 2002, from Raw Material HQ, London

Postby jules; Fri Jan 25, 2013 3:25 am

Thanks guys - re: bugs.. The plan is for us to have a bug-tracker on the new website. That's not ready yet, so in the meantime if you've got something really important, please email me. You could also post it here, but there's so much activity that I can't possibly read everything.
User avatar
riley4reason
KVRAF
 
2014 posts since 29 Aug, 2003, from Austin, TX

Postby riley4reason; Fri Jan 25, 2013 4:27 am

I have T4 still in demo mode, it crashes on VST folder scan as soon as it sees Auto Tune 7.
Riley
Asus CM6870 3AB, i7 3770 Ivy, 16GB RAM, 240GB SSD, 7TB Internal, Windows 8 64bit Pro,RME Firface UC, Reaper. Ableton Live 9, Sonar X2, Maschine.
miquelmatas
KVRist
 
123 posts since 25 Feb, 2004, from Andorra

Postby miquelmatas; Fri Jan 25, 2013 5:27 am

I have T4 still in demo mode, it crashes on VST folder scan as soon as it sees UVIWorkstationVST.dll with no usb dongle.
Miquel.
skipkent
KVRian
 
1112 posts since 21 Jul, 2004

Postby skipkent; Fri Jan 25, 2013 5:55 am

TSC wrote:Forwarded directly to Jules for bug fixings.

Thanks for the feedback.


It's just the AU that is crashing, apparently. Mac loads both AU and VST and the VST loads and plays fine. I contacted Jules about this to let him know.
Music is something you DO. Spend time, not money.
http://www.myspace.com/skipkent
http://soundcloud.com/skipkent
User avatar
riley4reason
KVRAF
 
2014 posts since 29 Aug, 2003, from Austin, TX

Postby riley4reason; Sat Jan 26, 2013 6:38 am

Is there any progress on getting the T4 license to activate?
The hissssss is getting old.

Riley
Asus CM6870 3AB, i7 3770 Ivy, 16GB RAM, 240GB SSD, 7TB Internal, Windows 8 64bit Pro,RME Firface UC, Reaper. Ableton Live 9, Sonar X2, Maschine.
valley
KVRAF
 
4631 posts since 28 Nov, 2002, from Chicago

Postby valley; Sat Jan 26, 2013 7:55 am

frankvg wrote:All Mackie plugins have no gui and seem to crash T.


They reportedly work fine on XP. It may just be that those plugs are no longer compatible with the latest OSX version. 10.8 in particular can cause issues with older code as the security model can break things that expect to be reasonably free to do what they want.
Someone shot the food. Remember: don't shoot food!
frankvg
KVRian
 
584 posts since 4 Jun, 2004

Postby frankvg; Sat Jan 26, 2013 2:15 pm

valley wrote: It may just be that those plugs are no longer compatible with the latest OSX version.
That can't be the case because they DO work in T3.
I found they do work in the sense they produce sound. Since there is no gui it is not possible to load presets from the plugin itself so what I did was saving a .fxp in T3 and then loading it in T4.
But on the other hand it is difficult to tell if it really crashes T because over here almost everything seems to crash or hang T.
On average I should say of my old edits, 25% play without problems. The rest doesn't play, immediately hangs or crashes when moving something or produces some distorted sound. So far impossible to figure out what causes this.
valley
KVRAF
 
4631 posts since 28 Nov, 2002, from Chicago

Postby valley; Sat Jan 26, 2013 2:29 pm

frankvg wrote:
valley wrote: It may just be that those plugs are no longer compatible with the latest OSX version.
That can't be the case because they DO work in T3.


<sigh> I'm not with it today. My bad, that should NOT have needed spelling out.

I wasn't able to get them to install as part of the T3 install on 8.2. I should take another look at whether I can resuscitate them.

I found they do work in the sense they produce sound. Since there is no gui it is not possible to load presets from the plugin itself so what I did was saving a .fxp in T3 and then loading it in T4.
But on the other hand it is difficult to tell if it really crashes T because over here almost everything seems to crash or hang T.


The hanging is thread-deadlocking. Jules is already on this. The crashes I'm also seeing, but are proving to be a little harder to isolate.

FWIW, I personally am immensely grateful that TSC have picked up Tracktion and are trying to breathe new life into it. For their part though, I hope they realize how lucky they are to have such an awesome user community, even after all this time!
Someone shot the food. Remember: don't shoot food!
frankvg
KVRian
 
584 posts since 4 Jun, 2004

Postby frankvg; Sat Jan 26, 2013 2:36 pm

valley wrote: FWIW, I personally am immensely grateful that TSC have picked up Tracktion and are trying to breathe new life into it. For their part though, I hope they realize how lucky they are to have such an awesome user community, even after all this time!
Totally agree. And some of that undoubtedly comes down to Jules for his open, communicative attitude and fast updates in the early days. (Apart from being an overall pleasant and funny genius)
User avatar
mandolarian
KVRAF
 
2536 posts since 2 Feb, 2005, from Raincoast of Grayland

Postby mandolarian; Sat Jan 26, 2013 2:40 pm

valley wrote:FWIW, I personally am immensely grateful that TSC have picked up Tracktion and are trying to breathe new life into it.

Me too!!! Still in the 'giddy, somebody pinch me' phase despite all the buck tooth teething pains.
valley wrote:For their part though, I hope they realize how lucky they are to have such an awesome user community, even after all this time!

Indeed. But, TSC will learn the lessons that Mackie never did.

As the old saying goes: "Hell hath no fury like a groundhog scorned!"
perception: the stuff reality is made of.
valley
KVRAF
 
4631 posts since 28 Nov, 2002, from Chicago

Postby valley; Sat Jan 26, 2013 3:46 pm

mandolarian wrote:As the old saying goes: "Hell hath no fury like a groundhog scorned!"


We might be small, and only marginally more intimidating than a penguin, but we are legion, and we can do that creepy ass immobile stare thing which, if not exactly terrifying, can still strike vague weirded-out-ness into the hearts of our foes.

That and we can give you six more weeks of bloody miserable weather. You have been warned!
Someone shot the food. Remember: don't shoot food!
engine
KVRist
 
258 posts since 1 Nov, 2005

Postby engine; Sat Jan 26, 2013 5:10 pm

M-Audio Audiophile win 7 64bit
cant select asio (says the samplerate is not supported)
tried 44k and 48k in the audiophile driver [control panel]

windows audio (and ofc direct sound) line out (m-audio audiophile) works.
Next

Moderators: valley, jules, TSC, ModuLR

Return to Tracktion