Login / Register  0 items | $0.00 New#KVRDeals
Voxengo

Voxengo updates Elephant, GlissEQ, Voxformer, Span and OldSkoolVerb

Voxengo has released updates for Elephant (v2.6), GlissEQ (v2.9), Voxformer (v1.8), Span (v1.9) and OldSkoolVerb (v1.4).

Changes:

  • All: Access violation error on systems with >2GB memory solved.
  • GlissEQ: Spectrum analyzer now shows input signal analysis when in Bypass mode.
  • Voxformer: Extreme level pop fixed that could appear with the enhancer module enabled.
Products Related To This Item
Discussion: Active

Discussion

Please log in to join the discussion

Related news...

Voxengo News
Other Related News

Show more...