Need testers for my x86 to x64 vst adapter

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
z1r
KVRer
5 posts since 10 Sep, 2009

Post Sun Jul 20, 2014 4:40 am

Hi,

Is there any way to get Band in a Box to recognize the bridged plugins? I've tried everything I can think of and BIAB will not recognize them as valid vst plugins. Thank you.

umd
KVRian
1052 posts since 26 Feb, 2006 from Fartland

Re: Need testers for my x86 to x64 vst adapter

Post Sun Jul 20, 2014 10:24 am

Hi!

If it Band in a Box can load VST plugins it should work too... :-)

It looks like it does:

http://www.pgmusic.com/forums/ubbthread ... &site_id=1

But, if it's a 32bit application you'll need to create 32bit bridging files for it ( regardless of the plugin being 32 or 64 bit ), perhaps that could be the problem?
Free midi plugins and other stuff:
http://jstuff.wordpress.com/

z1r
KVRer
5 posts since 10 Sep, 2009

Re: Need testers for my x86 to x64 vst adapter

Post Sun Jul 20, 2014 7:20 pm

Hi UMD,

I tried both 32 & 64 bit bridging files and it made no difference. BIAB does not see the .dlls as valid vst plugins, thanks.

Image

umd
KVRian
1052 posts since 26 Feb, 2006 from Fartland

Re: Need testers for my x86 to x64 vst adapter

Post Sun Jul 20, 2014 8:23 pm

Hi!

Could you try creating the bridging files without the ".32." part in its name and see if the same happens? ( there's an option for that in the bridging tool )
Free midi plugins and other stuff:
http://jstuff.wordpress.com/

z1r
KVRer
5 posts since 10 Sep, 2009

Re: Need testers for my x86 to x64 vst adapter

Post Sun Jul 20, 2014 8:52 pm

Hi UMD,

I already tried that and it made no difference either, thanks.

umd
KVRian
1052 posts since 26 Feb, 2006 from Fartland

Re: Need testers for my x86 to x64 vst adapter

Post Mon Jul 21, 2014 8:38 am

Hi!

That's odd... could you check if it can load the original 32bit TruePianos plugin then?

Also, are you running everything as admin as shown in pics 1-2 here ( same for any other host, double check if needed )?

http://jstuff.wordpress.com/jbridge/jbr ... ing/782-2/
Free midi plugins and other stuff:
http://jstuff.wordpress.com/

z1r
KVRer
5 posts since 10 Sep, 2009

Re: Need testers for my x86 to x64 vst adapter

Post Mon Jul 21, 2014 7:06 pm

Hi UMD,

BIAB will load all of my 32bit plugins fine. It just will not load 32bit or 64bit plugins if they are bridged. I am running everything with Administrative privileges. This is just something I want to play around with and not important enough for you to be overly concerned about. If you can figure out why this doesn't work that's great but don't lose any sleep over it.

umd
KVRian
1052 posts since 26 Feb, 2006 from Fartland

Re: Need testers for my x86 to x64 vst adapter

Post Tue Jul 22, 2014 12:03 am

Hi!

Unfortunately there's no demo of BIAB for me to check this, but we can try another thing... could you PM me with your email address? ;)
Free midi plugins and other stuff:
http://jstuff.wordpress.com/

Siyunking
KVRer
2 posts since 20 Oct, 2014

Re: Need testers for my x86 to x64 vst adapter

Post Fri Oct 24, 2014 1:09 pm

AUTO-ADMIN: Non-MP3, WAV, OGG, SoundCloud, YouTube, Vimeo, Twitter and Facebook links in this post have been protected automatically. Once the member reaches 5 posts the links will function as normal.
Hi !
I have huge problems with jBridgeM (I bought it yesterday)
I am on MacBook Pro 10.9.4, Ableton Live 9.1.5 , 64 bit; I bridged Sylenth1.
First of all, when I open a session using several instances of bridged plug in in one project, it makes Ableton crash just before even seeing the project.
When I can open it, sometimes, some tracks using jBridgeM, have no sound; no sound is coming from the track.
I tried everything, but it crashes or some tracks have no sound.

Please, help me !
siyunking@gmail.com (mailto:siyunking@gmail.com)

umd
KVRian
1052 posts since 26 Feb, 2006 from Fartland

Re: Need testers for my x86 to x64 vst adapter

Post Fri Oct 24, 2014 1:34 pm

Hi!

Which plugins are you bridging so that I can test it here?

ps: check your email ;)
Free midi plugins and other stuff:
http://jstuff.wordpress.com/

Musical Gym
KVRAF
5066 posts since 24 May, 2004 from square1

Re: Need testers for my x86 to x64 vst adapter

Post Sat Nov 01, 2014 3:21 am

I'm thinking of trying the demo again. What are the restrictions/limitations of demo?

Last time I tried it, I had problems with the auto-naming of the files (too many vsts) and I didn't really know enough about what I was doing...

Should I be installing 1.65 demo or 1.7b1 (beta) demo and what are the differences between the two demos?

umd
KVRian
1052 posts since 26 Feb, 2006 from Fartland

Re: Need testers for my x86 to x64 vst adapter

Post Sat Nov 01, 2014 9:49 pm

Hi!

The demo won't load or save any data, and it will work for 20 minutes each time a bridged plugin is loaded.

v1.7 beta has some minor changes ( which are described in the page ), but most plugins should work fine with v1.65 too. :)
Free midi plugins and other stuff:
http://jstuff.wordpress.com/

Musical Gym
KVRAF
5066 posts since 24 May, 2004 from square1

Re: Need testers for my x86 to x64 vst adapter

Post Sat Nov 01, 2014 11:57 pm

thanks umd

BrokenTrance
KVRist
298 posts since 25 Nov, 2010

Re: Need testers for my x86 to x64 vst adapter

Post Fri Jan 16, 2015 10:10 pm

(edit)

magicmusic
KVRian
1004 posts since 11 Nov, 2013

Re: Need testers for my x86 to x64 vst adapter

Post Sun Mar 01, 2015 1:45 am

I test now the 1.71b Demo with sample tank 3.3 and win 10 64 pre release. I have 8 GB RAM and 4 core 2.8 GHZ CPU.this work and i can get lower latency without crackle as on my old win 7 64. and it use lots fewer memory(more as 1 Gigabyte when apps run).

win 10 is free for win 7 win 8 users when it is release, and i think is for all musical realtime apps a big enhance.

http://www.pcworld.com/article/2873214/ ... users.html
The old 1.65 demo do not work. But use on 64 bit DAW and 32 bit plugins convert to 64 bit do not work(test on mulab and cubase 7 le 64 bit. does the 171b version output some log file ?. Or maybe you can add some log output, so can see what problem is, when a VST can not add with jbrige. important to use on win 10 is for all non win 10 programs, that they are install as admin and set to compatibility mode for win 7

at least with win 10 and sample tank 3 jbridge work perfect on my system with 10 ms latency. on win 7 64 sometimes random crackle happen even on 40 ms with soundblaster z live. without jbridge i can use on win 10 2 ms without problems. win 7 work only with 4 ms perfect. so i buy now jbridge
For Bug report Purpose that developer see which system i use; win 10 64 1809 intel i5 8600K (6*3.6 GHZ) 16 GB Ram

Return to “Instruments”