Need testers for my x86 to x64 vst adapter

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
umd
KVRian
1052 posts since 26 Feb, 2006 from Fartland

Post Sun Mar 01, 2015 7:10 am

Hi!

Thanks for the info. I tested it with Windows 10 preview version already and it worked fine here, however, I would prefer to wait for the final release, since something may change meanwhile. ;-)

If you could tell me exacty what is the issue you're having I can try to check it out, I can send you a build with logging capabilities if needed. :-)

As for the achievable working latency, it really depends of a lot of things, the last soundblaster card I had was capable of doing 2ms with its ASIO drivers in an Athlon XP machine, but in my opinion there's no point in going below 4ms, since that's just going to put unnecessary extra load in your CPU and you won't notice any lag difference ( remember that there is also more latency to add to that from other system's components ).
Free midi plugins and other stuff:
http://jstuff.wordpress.com/

magicmusic
KVRian
1004 posts since 11 Nov, 2013

Re: Need testers for my x86 to x64 vst adapter

Post Tue Mar 03, 2015 8:25 am

On win10 the convertet VST to 64 bit is not load. it look as it is not here. i test also in mulab 64 bit(here can select a file direct and look if it is load or not.) I can choose the convertet file of the ck_poly_step_seq_big (its synthedit midi only plugin no 64 bit version is here). work ok on win 7 64 with this settings create automatic

""
"H:\Program Files (x86)\Vstplugins\CK_Pattern_Arp_Plus_BIG.dll"
ID: 1131106416
flags: effFlagsHasEditor
flags: effFlagsIsSynth
flags: effFlagsCanReplacing
flags: effFlagsProgramChunks
""
"""
"H:\Program Files (x86)\Vstplugins\CK_Poly_Step_Seq_BIG.dll"
ID: 1131106387
flags: effFlagsHasEditor
flags: effFlagsIsSynth
flags: effFlagsCanReplacing
flags: effFlagsProgramChunks
"""

But i test also sampletank2 on 64 bit mulab.i also let create new files for win 10. but did not help on win 10 to get 32 bit plugins on 64 bit DAW working. on win 7 64 all start.

10 ms latency is enough for me. but on win 7 64 i notice also some random sound crackle when i use 64 BIT DAW and i use 2 CK_Pattern_Arp_Plus_BIG VST. 1 VST with jbridge work perfect. but when i use more than 1 VST over jbridge then win 7 64 get random crackle even at 10 ms. the ck VST i use are only midi and need not much CPU power. maybe you can suggest me a setting so jbridge can better handle more VST over jbridge running. but anyway win 10 is lots better. i see this, because i can use 3 sample tank 3 VST over jbridge in 32 bit DAW at 10 ms without Problem. on Win 7 also 1 sample tank3 make sometimes random crackle. It happen not often, only every minute or so. increase latency to 20 ms do not help. only with 40 ms it is ok. But 40 ms is for me too large delay, because i like realtime play. ck plugins you can download here and test

http://www.kvraudio.com/forum/viewtopic ... 4&t=420936
http://www.kvraudio.com/forum/viewtopic ... 8#p5897428

But its not a problem with ck plugins. only you can maybe see on win 7 64 4 core system see that more plugin over jbridge even if they not use much CPU increase crackle. I use the plugins in MUX and wire them to sample tank. MUX mulab can test also free.
For Bug report Purpose that developer see which system i use; win 10 64 1809 intel i5 8600K (6*3.6 GHZ) 16 GB Ram

umd
KVRian
1052 posts since 26 Feb, 2006 from Fartland

Re: Need testers for my x86 to x64 vst adapter

Post Tue Mar 03, 2015 11:49 pm

Hi!

Just to confirm, do those plugins work absolutely fine in a 32bit DAW in Windows 10, unbridged?

I don't have access to my Window 10 preview installation at the moment, but I'll give it a try when I get home and see if I can find any problem.
Free midi plugins and other stuff:
http://jstuff.wordpress.com/

magicmusic
KVRian
1004 posts since 11 Nov, 2013

Re: Need testers for my x86 to x64 vst adapter

Post Wed Mar 04, 2015 5:53 am

yes, on win 10 and 32 BIT DAW all work ok. I find no 32 bit VST that not work on win 10. win 10 seem very compatible. I see also no DAW compatibility problem. I test cubase 7 LE (32/64bit), mulab(32 64 bit) magix music maker, samplitude music studio. only the vstbridge have problem. All 64 bit DAW do not add the VST when i have the file with size 3.584 inside. there come no message or crash. Mulab show 0 VST add when i select the file and the VST is not add
For Bug report Purpose that developer see which system i use; win 10 64 1809 intel i5 8600K (6*3.6 GHZ) 16 GB Ram

LeVzi
KVRAF
1905 posts since 8 Jul, 2008 from UK

Re: Need testers for my x86 to x64 vst adapter

Post Sun Sep 13, 2015 2:17 am

Is this still in development ? I have a license for it, but no updates for ages.

Not sure what version is the best and most stable now. ? ? ?
Forward ever, Backward never

rasmusklump
KVRian
833 posts since 13 May, 2004 from Germany

Re: Need testers for my x86 to x64 vst adapter

Post Sun Sep 13, 2015 2:29 am

No updates for ages ?
There where updates this year....

Ben H
KVRAF
2075 posts since 28 Jul, 2003

Re: Need testers for my x86 to x64 vst adapter

Post Sun Sep 13, 2015 3:20 am

LeVzi wrote:Is this still in development ? I have a license for it, but no updates for ages.

Not sure what version is the best and most stable now. ? ? ?
That's because it pretty much works with everything you can throw at it. :roll:
My main tools: Kontakt, Omnisphere, Samplemodeling + Audio Modeling. Akai VIP = godsend. Tari's libraries also rock.

User avatar
aMUSEd
KVRAF
30857 posts since 14 Sep, 2002 from In teh net

Re: Need testers for my x86 to x64 vst adapter

Post Sun Sep 13, 2015 4:01 am

Not on Mac it doesn't, I stopped using it because it doesn't work well with the few plugins I have left that are 32 bit. Bitwig's wrapper is much better.

Ben H
KVRAF
2075 posts since 28 Jul, 2003

Re: Need testers for my x86 to x64 vst adapter

Post Sun Sep 13, 2015 5:00 am

aMUSEd wrote:Not on Mac it doesn't, I stopped using it because it doesn't work well with the few plugins I have left that are 32 bit. Bitwig's wrapper is much better.
Did you bother to report it to him?
My main tools: Kontakt, Omnisphere, Samplemodeling + Audio Modeling. Akai VIP = godsend. Tari's libraries also rock.

umd
KVRian
1052 posts since 26 Feb, 2006 from Fartland

Re: Need testers for my x86 to x64 vst adapter

Post Sun Sep 13, 2015 5:58 am

If I can know which plugins are not working well, and If I can reproduce the problem, I will surely fix anything I can.

I haven't released any new updates meanwhile because there haven't been any major issues reported meanwhile ( and by that I mean issues that I can clearly reproduce in my testing environment ).

But it is a fact that it is much harder to do a generic VST bridge for OS X than it is for Windows. Windows has much better software / API backward compatibility.
Free midi plugins and other stuff:
http://jstuff.wordpress.com/

User avatar
aMUSEd
KVRAF
30857 posts since 14 Sep, 2002 from In teh net

Re: Need testers for my x86 to x64 vst adapter

Post Sun Sep 13, 2015 12:54 pm

None of the ImageLine Mac versions work well with the wrapper, these are almost the only 32 bit plugins that I have now that I care about - but I didn't see the point in reporting it though because they are alphas themselves - but as I said they do seem to work significantly better with Bitwig's wrapper. Apart from that the only 32 bit Mac plugins I have that I use are Hypersonic and Surge but I got fed up with the JBridge wrapper failing so I only use them in hosts that have built in wrappers now. Unlike Windows with its plethora of Synthedit and Synthmaker stuff, I guess the big problem on Mac is the few remaining 32 bit plugins are mostly pretty ancient and no longer being developed, the ImageLine ones are an exception in that they are new, but even so we are unlikely to see 64 bit versions of those for a long time if ever, and their development is at a snails pace.

umd
KVRian
1052 posts since 26 Feb, 2006 from Fartland

Re: Need testers for my x86 to x64 vst adapter

Post Sun Sep 13, 2015 4:23 pm

I just downloaded the ILPluginPack_alpha10.dmg, installed, scanned and bridged all the plugins in there.

I was able to load all the plugins in the DAWs I tested them with ( OS X 10.10, jBridgeM v0.93g8 ).

I noticed that these plugins don't seem to like always-on-top parent windows, if I have the "Bridged plugin's GUI always on top" or the "Plugin editor in host's window client area" options enabled ( which use always-on-top windows ) I will get a blank GUI, so those options will need to be disabled, with a normal window the GUI's appear to work fine. I don't know at the moment if I can find a workaround for this in my implementation.

Other than that I didn't find any problem, should I check anything else?
Free midi plugins and other stuff:
http://jstuff.wordpress.com/

User avatar
aMUSEd
KVRAF
30857 posts since 14 Sep, 2002 from In teh net

Re: Need testers for my x86 to x64 vst adapter

Post Mon Sep 14, 2015 3:12 am

I just found with use over time that the wrapper layer tends to crash, or lock up, with much use, particularly with these plugins (especially Edison and Slicex). This may not show if you are just trying to see if they load.

umd
KVRian
1052 posts since 26 Feb, 2006 from Fartland

Re: Need testers for my x86 to x64 vst adapter

Post Mon Sep 14, 2015 7:35 am

OK, I will have a session with those and see what happens... Meanwhile, if there's any crash log you can send me it would be helpful.
Free midi plugins and other stuff:
http://jstuff.wordpress.com/

drhardlove
KVRer
1 posts since 7 Jan, 2018

Re: Need testers for my x86 to x64 vst adapter

Post Sun Jan 07, 2018 9:42 am

Hi.
I wonder if there is a chance that I can use this program for my TC powercore, Liquid mix, and other plugs that was blacklisted from Cubase version 9 and onwards?
Regards
Doc :help:

Return to “Instruments”