BlueARP VST Arpeggiator development - let's discuss! (OSX MIDI-FX is out)

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
WatchTheGuitar
KVRAF
2372 posts since 30 Apr, 2019

Post Sat Jul 18, 2020 8:34 am

Spitfire31 wrote:
Sat Jul 18, 2020 8:11 am
How many years since xp was supported by Microsoft? And now you demand that a freeware dev support it? Some people…
Quite the debut shitpost :)

Username Peter Pan
KVRer
5 posts since 18 Jul, 2020

Post Sat Jul 18, 2020 6:56 pm

v2.2.10 works ok but 2.2.11 does not. See the changelog for 2.2.11, it says 'no major changes'!
Why doesn't it work anymore?


Changelog
--- BlueARP v2.2.11 / 10-Mar-2020 (patch format ver = 17) ---

1. Refactorings for HW Ctrl interface, no major changes
2. BugFix: crashed when trying to edit preset name (x64 win only)

User avatar
phreaque
KVRian
1050 posts since 17 Jul, 2007 from Baghdad-Iq

Post Sat Jul 18, 2020 8:34 pm

Username Peter Pan wrote:
Sat Jul 18, 2020 6:56 pm
v2.2.10 works ok but 2.2.11 does not. See the changelog for 2.2.11, it says 'no major changes'!
Why doesn't it work anymore?


Changelog
--- BlueARP v2.2.11 / 10-Mar-2020 (patch format ver = 17) ---

1. Refactorings for HW Ctrl interface, no major changes
2. BugFix: crashed when trying to edit preset name (x64 win only)
Here's how programs & applications made:
They are written in programming code, like Java, C++ etc. once the code works well & not causing faults, the process of compiling begins, which it is a program runs on supported operating systems takes the code and translates it to a low level code that the computer can understands.

However, when an OS reaches an end of support (like Win XP) most of these applications won't work, and their makers won't bother supporting these tools to work in that OS.

BlueARP 2.2.11 and upwards builds are compiled in a program with an option that doesn't support Win XP.

Newer OS's & h/w computer components are mutually developed to operate smoothly & much more efficiently. Perhaps if the process to compile an application to work on Win XP, might limit major functionality on other OS. And yes, the majority of users using newer OS's
Saif Sameer - content designer
Reveal-Sound Image-Line SoundCloud

User avatar
graywolf2004
KVRian
575 posts since 15 Apr, 2012 from Moscow, Russia

Post Sun Jul 19, 2020 7:03 am

update: BlueARP v2.3.2
http://graywolf2004.net/wp/?page_id=35

Finally I took time to compile it for Mac as well.
It is basically the same as previous unofficial 2.3.2rc1, but also fixed a bug with bank load, reported by Saif aka phreaque. If you saved a bank with 2.3.2rc1, it won't load into previous 2.3.1. I fixed that. Now also if it fails to load a bank, it will show a message with some info in where it stuck.

Changes from 2.3.1 (from changelog)
1. Refined 'Random' STEP TYPE logic. For 3+ input keys, randomized excludes note repetitions,
so it will be like k1-k3-k2-k3-k1-k2 but never like k1-k1-k1-k3-k2-k2-k3
2. Changed 'arp latch' logic. Now it will re-scan input keys on each new key press.
Old logic is available via 'latch mode' setting
3. Updated English manual to v.2.3.2
4. Added manual in Russian

User avatar
graywolf2004
KVRian
575 posts since 15 Apr, 2012 from Moscow, Russia

Post Sun Jul 19, 2020 7:11 am

K8ch wrote:
Sun Jul 05, 2020 7:55 am
Hi,

I've just downloaded the newest version, and am finding that I'm unable to load a bank of presets.

The -new- BlueArp GUI contains the menu for available presets, so that presets can't be loaded in as they'd been loaded, in the previous version.

How -do- I load in a bank pf presets?
Can I access the ones I'd created, with the previous version of BlueArp?

Keith
I didn't get what exactly is your problem. If you can't load a bank - can you send me one to check? And if you remember - with which version of bluearp is was created?
But first, try the latest 2.3.2. I did some fixes to bank load logic and it might help.

User avatar
graywolf2004
KVRian
575 posts since 15 Apr, 2012 from Moscow, Russia

Post Sun Jul 19, 2020 7:36 am

Username Peter Pan wrote:
Sat Jul 18, 2020 6:56 pm
v2.2.10 works ok but 2.2.11 does not. See the changelog for 2.2.11, it says 'no major changes'!
Why doesn't it work anymore?

Changelog
--- BlueARP v2.2.11 / 10-Mar-2020 (patch format ver = 17) ---

1. Refactorings for HW Ctrl interface, no major changes
2. BugFix: crashed when trying to edit preset name (x64 win only)
I didn't drop XP support deliberately. After some research I found out it is possible to switch XP support manually in VS 2015. So plese try this version and tell if it works. I have no PCs with Windows XP and can't test it myself:
https://drive.google.com/file/d/1ghAqU9 ... sp=sharing
It is 2.3.2 compiled with XP support.

Username Peter Pan
KVRer
5 posts since 18 Jul, 2020

Post Sun Jul 19, 2020 9:44 pm

No it does not work. There is no plug-in in the list.

I have put bluearp in several plug-in paths and set several folders to 'shared folders' and then pressed 'update', but it won't see bluearp, also not after restart.

User avatar
phreaque
KVRian
1050 posts since 17 Jul, 2007 from Baghdad-Iq

Post Sun Jul 19, 2020 9:57 pm

Username Peter Pan wrote:
Sun Jul 19, 2020 9:44 pm
No it does not work. There is no plug-in in the list.

I have put bluearp in several plug-in paths and set several folders to 'shared folders' and then pressed 'update', but it won't see bluearp, also not after restart.
You have other DAW or VST host to check? It might be Cubase fault.
Saif Sameer - content designer
Reveal-Sound Image-Line SoundCloud

Username Peter Pan
KVRer
5 posts since 18 Jul, 2020

Post Mon Jul 20, 2020 11:00 am

In fruity loops it worked, it recognizes bluearp and it seems to work, even bluearp version 2.3.1.

So you could say it is an error of cubase\nuendo but all other plug-ins work very well also all versions of bluearp including v2.2.10 from 21 september 2019. But all later versions of bluearp don't show in the plug-in list.

User avatar
phreaque
KVRian
1050 posts since 17 Jul, 2007 from Baghdad-Iq

Post Mon Jul 20, 2020 9:49 pm

Username Peter Pan wrote:
Mon Jul 20, 2020 11:00 am
So you could say it is an error of cubase\nuendo but all other plug-ins work very well also all versions of bluearp including v2.2.10 from 21 september 2019. But all later versions of bluearp don't show in the plug-in list.
This is Cubase/Nuendo fault obviously. Try to send Steinberg an email.
Saif Sameer - content designer
Reveal-Sound Image-Line SoundCloud

Username Peter Pan
KVRer
5 posts since 18 Jul, 2020

Post Mon Jul 20, 2020 11:04 pm

You could say it is Steinberg who has to resolve this problem. But you could also say it is the compiler version. All plug-ins work very well including all versions of bluearp until v2.2.10, but later versions of bluearp don't show in the list.

I am not a programmer but probably the problem is solved when the older compiler is being used.
The compiler that was used with bluearp v2.2.10 and before.

User avatar
phreaque
KVRian
1050 posts since 17 Jul, 2007 from Baghdad-Iq

Post Mon Jul 20, 2020 11:23 pm

Username Peter Pan wrote:
Mon Jul 20, 2020 11:04 pm
You could say it is Steinberg who has to resolve this problem. But you could also say it is the compiler version. All plug-ins work very well including all versions of bluearp until v2.2.10, but later versions of bluearp don't show in the list.

I am not a programmer but probably the problem is solved when the older compiler is being used.
The compiler that was used with bluearp v2.2.10 and before.
Usually debugging process takes several steps to make sure which factor is causing the problem.
Saif Sameer - content designer
Reveal-Sound Image-Line SoundCloud

Opax
KVRist
293 posts since 26 Sep, 2006 from UK

Post Sat Aug 01, 2020 4:19 am

Hi Oleg,

You need to update the URL of the VST version for Mac as it is still directing to v2.3.1.
Opax

Mineralhillsworkshop
KVRist
30 posts since 13 Jul, 2018

Post Thu Aug 06, 2020 7:59 am

I love this plugin. Thank you Oleg Mikheev!

I would also like to thank Satyatunes for making many amazing vst skins and offering some free blue arp skins. (http://www.satyatunes.com/web/bluearp.php)
But, I was having an issue with the top bar being too bright and wanted less purple.

So I thought I would post my Mod here.
If you would like to use it. Open the Blue Arp skins folder and make a copy of the default.ini file. Then paste the code into it. You can also make your own skins very easily. (Thanks to Valentin Zechiu for teaching me!) You just need to change color codes like "$706A67" to a color code you want. You can use any color program that will give you colors in Delphi codes. I used "Just Color Picker." (https://annystudio.com/software/colorpicker/) (It lets you use an eye dropper and alt+x hot key to get the code of any color you see on your screen.)

Code: Select all

[scheme_BLUETOP_MOD]

// -- drag box
box_LineColor=$706A67
box_FillColor=$3F3A36
box_FillColorActive=$251B1C
box_FontColor=$AAB1B8
box_FontColorActive=$56A1EC
box_LabelFontColor=$D6C09F
box_LabelFontColorInActive=$76776D

// -- drag box bar
bar_FillColor=$2C2220
bar_LabelFontColorHighlight=$56A1EC

// -- button
btn_FillColor=$655549
btn_FillColorActive=$56A1EC
btn_FontColor=$1F1717

// -- LED
led_BackColor=$000000
led_OnColorOuter=$56A1EC
led_OnColorInner=$56A1EC
led_OffColorOuter=$101419
led_OffColorInner=$232C39

// -- stats panel Label
info_panel_LabelFontColor=$BEAFA2

// -- screen (matrix editor)
scr_BackColor=$2C2220
scr_GridBackColor=$C2D0D6
scr_LineColorBright=$A3B9C2
scr_LineColorDark=$88A4AF
scr_LabelColorBright=$56A1EC
scr_LabelColorDark=$5D6266
scr_BrickColorOn=$8F6E3D
scr_BrickColorOff=$5D4C40

// -- block label (yellow lines)
panels_BlockLabelColor=$695B62

// -- globals
panels_BackColor=$221612
panels_OutlineColor=$2C2725
panels_TopPanelColor=$221B1C
panels_SettingsPanelColor=$302827
panels_InfoPanelColor=$3F3A36
You do not have the required permissions to view the files attached to this post.

Return to “Instruments”