Spire Synthesizer

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
KVRian
624 posts since 18 Feb, 2004

Post Mon Nov 22, 2021 2:02 pm

Teksonik wrote:
Mon Nov 22, 2021 11:48 am
Well that was a ton of fun today getting to know Spire. It's an intuitive synth to program and has a very nice character that's going to fit in well with the other synths in my folder. It's got one of the finest GUIs in the land that is so crisp, sharp, and "hi-def". :tu:

Here's five patches. Nothing special just some "getting to know you" patches learning my way around Spire's architecture.
I find it nearly impossible that it took you this many years to get Spire ;) I mean I believe you and all but for someone who's been on this board for so long it just seems impossible. Love Spire.

User avatar
KVRAF
7291 posts since 7 Sep, 2006 from Roseville, CA

Post Mon Nov 22, 2021 2:03 pm

Ploki wrote:
Mon Nov 22, 2021 12:05 pm
oh man, should i re-buy spire, finally get dune, or finally get FabFilter Twin2 i've been wanting for so long
yes

User avatar
KVRAF
16439 posts since 16 Sep, 2001 from Las Vegas,USA

Post Mon Nov 22, 2021 5:41 pm

rezoneight wrote:
Mon Nov 22, 2021 2:02 pm
Teksonik wrote:
Mon Nov 22, 2021 11:48 am
Well that was a ton of fun today getting to know Spire. It's an intuitive synth to program and has a very nice character that's going to fit in well with the other synths in my folder. It's got one of the finest GUIs in the land that is so crisp, sharp, and "hi-def". :tu:
Here's five patches. Nothing special just some "getting to know you" patches learning my way around Spire's architecture.
I find it nearly impossible that it took you this many years to get Spire ;) I mean I believe you and all but for someone who's been on this board for so long it just seems impossible. Love Spire.
Well for one I could never justify the full price due in large part to having so many other synths in my folder.

I tried the demo several times over the years and it just never spoke to me enough but for under $100 it was easy to justify.

I like Spire and it will no doubt gain a place in my starting lineup but to be honest it's not my favorite synth. But "one of my favorites" is certainly possible.... :wink:
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

KVRist
157 posts since 16 May, 2019

Post Wed Nov 24, 2021 1:51 pm

It surely can't just be me but almost every single time (4 in 6) if I am playing midi in Cubase 11 through spire and I press the suspend plugin button, then press it again to make the plugin work again there will be a stuck note.

It only happens when in poly mode, if i switch it to mono mode the stuck notes stop, but if I engage poly mode again the stuck notes start again. Resetting midi (panic) does nothing to resolve it.

What's that all about?
If you don't eat yer meat, you can't have any pudding. HOW CAN YOU HAVE ANY PUDDING IF YOU DON'T EAT YER MEAT!?

User avatar
KVRAF
16439 posts since 16 Sep, 2001 from Las Vegas,USA

Post Wed Nov 24, 2021 2:03 pm

That's weird I got a stuck note today as well. I don't own Cubase and to be honest don't remember which of my DAWs I was using at the time. Panic or "all notes off" didn't work here either. I think I had to shut the project down and open a new one.

I've only owned Spire for a few days but I have spent quite a bit of time with it and the stuck note has only happened once.

I just wrote it off as an unknown glitch and didn't really pay much attention to it but I'll keep an eye out if it happens again and try to gather more information.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

KVRist
157 posts since 16 May, 2019

Post Thu Nov 25, 2021 2:03 am

Teksonik wrote:
Wed Nov 24, 2021 2:03 pm
That's weird I got a stuck note today as well. I don't own Cubase and to be honest don't remember which of my DAWs I was using at the time. Panic or "all notes off" didn't work here either. I think I had to shut the project down and open a new one.

I've only owned Spire for a few days but I have spent quite a bit of time with it and the stuck note has only happened once.

I just wrote it off as an unknown glitch and didn't really pay much attention to it but I'll keep an eye out if it happens again and try to gather more information.
Yeah I think it must be connected to the synth being deactivated and reactivated whilst it is sounding notes. Which I tend to do as a way to mute temporarily something whilst layering.
If you don't eat yer meat, you can't have any pudding. HOW CAN YOU HAVE ANY PUDDING IF YOU DON'T EAT YER MEAT!?

KVRist
410 posts since 5 Feb, 2012

Post Thu Nov 25, 2021 3:34 am

kenny saunders wrote:
Wed Nov 24, 2021 1:51 pm
It surely can't just be me but almost every single time (4 in 6) if I am playing midi in Cubase 11 through spire and I press the suspend plugin button, then press it again to make the plugin work again there will be a stuck note.

It only happens when in poly mode, if i switch it to mono mode the stuck notes stop, but if I engage poly mode again the stuck notes start again. Resetting midi (panic) does nothing to resolve it.

What's that all about?
That would most likely be a bug you should report to Reveal Sound rather than waste our time posting about it on KVR.
Matrix-1000, MicroWave with Access programmer, MicroWave II, MKS-50 with MidiClub programmer, MKS-70, MKS-80 with Kiwi Patch Editor, Nord 2 Rack, Nord 3 Rack, Prophet REV2 module, Pulse 2, Shruthi, Virus TI

User avatar
KVRAF
16439 posts since 16 Sep, 2001 from Las Vegas,USA

Post Thu Nov 25, 2021 3:56 am

kenny saunders wrote:
Thu Nov 25, 2021 2:03 am
Yeah I think it must be connected to the synth being deactivated and reactivated whilst it is sounding notes. Which I tend to do as a way to mute temporarily something whilst layering.
Ok I wasn't muting the synth at the time so should not have caused a stuck note but again let me work with Spire some more and if it happens again here I'll report it. It could have just been a one off glitch. :)
Gadget Fiend wrote:
Thu Nov 25, 2021 3:34 am
That would most likely be a bug you should report to Reveal Sound rather than waste our time posting about it on KVR.
Well to be fair posting about it here (or posting about any issue with any plugin) allows other users to contribute by saying "yes this happens to me" or "no this never happens to me".

That helps to determine if it is indeed a bug or just some system specific issue only happening to one user.

I have no information to give at this point since I don't even remember which DAW I was using and it could just be a one off glitch that will never happen again. I'll keep working with Spire and if I get a stuck note again I'll take note of what actions I was taking at the time, which DAW etc and then I can have something to report to Reveal Sound support. It's only happened once here so far so I'm not willing to classify it as a bug yet. Could very well have been the DAW's fault or maybe I just did something stupid...... :shrug:
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
KVRAF
2370 posts since 12 Jan, 2019

Post Thu Nov 25, 2021 5:36 am

Teksonik wrote:
Thu Nov 25, 2021 3:56 am
Well to be fair posting about it here (or posting about any issue with any plugin) allows other users to contribute by saying "yes this happens to me" or "no this never happens to me".

That helps to determine if it is indeed a bug or just some system specific issue only happening to one user.
Word. People frequently post here about problems with software, and help is frequently provided. It is not a waste of time, and it is woven into the fabric of the forums.
"Have you ever noticed how anyone driving faster than you is a [jerk] and anyone driving slower than you is a moron?" - George Carlin

KVRian
624 posts since 18 Feb, 2004

Post Thu Nov 25, 2021 6:13 am

Not to mention that Reveal Sound reads and posts stuff here.

KVRist
157 posts since 16 May, 2019

Post Thu Nov 25, 2021 1:07 pm

Gadget Fiend wrote:
Thu Nov 25, 2021 3:34 am
kenny saunders wrote:
Wed Nov 24, 2021 1:51 pm
It surely can't just be me but almost every single time (4 in 6) if I am playing midi in Cubase 11 through spire and I press the suspend plugin button, then press it again to make the plugin work again there will be a stuck note.

It only happens when in poly mode, if i switch it to mono mode the stuck notes stop, but if I engage poly mode again the stuck notes start again. Resetting midi (panic) does nothing to resolve it.

What's that all about?
That would most likely be a bug you should report to Reveal Sound rather than waste our time posting about it on KVR.
Okay sir, can you please furnish me with a list of things I am allowed to talk about so as not to waste your ineffably valuable time?

lol u cretin.
If you don't eat yer meat, you can't have any pudding. HOW CAN YOU HAVE ANY PUDDING IF YOU DON'T EAT YER MEAT!?

KVRian
748 posts since 27 Oct, 2011 from Pacific Northwest

Post Tue Nov 30, 2021 11:32 am

Since the previous page had a short discussion on libraries and the ones by Reveal Sounds were recommended, I'd like to point out I just noticed their EDM Bundle is currently on a massive sale. 6 libraries in 1 for $30. Over 650 sounds in total with some WAV one shots and loops. I'm tempted to pick it up myself.

https://reveal-sound.com/store/product/ ... EDM_Bundle

Return to “Instruments”