UVI Falcon - hybrid instrument - version 1.6 released

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
ChamomileShark
KVRian
1239 posts since 12 May, 2004 from Oxford, UK

Post Fri Oct 05, 2018 6:58 am

Don't know. Ask them? Maybe that's how they want to run their business?

UnWorldly
KVRist
31 posts since 13 Jan, 2013

Re: UVI Falcon - hybrid instrument - version 1.6 released

Post Fri Oct 05, 2018 7:22 am

I'm very pleased with the update, these new touche presets are fun. I'm a little bummed that the discount voucher only applies to falcon expansions, I already have all of those. Moar expansions plz, perhaps something that uses lots of pluck and/or drum oscillators, I haven't explored those very much.

User avatar
ChamomileShark
KVRian
1239 posts since 12 May, 2004 from Oxford, UK

Re: UVI Falcon - hybrid instrument - version 1.6 released

Post Fri Oct 05, 2018 8:41 am

From memory last year I got Falcon for 30% off, 2 expansions for free and maybe later I got a 100 euro voucher I could use for libraries.

User avatar
c_voltage
KVRian
1183 posts since 16 May, 2004 from Soviet Union

Re: UVI Falcon - hybrid instrument - version 1.6 released

Post Fri Oct 05, 2018 3:23 pm

There is some great patches among new, but yes, sometimes it really causes even not so much cpu spikes how similar artefacts at press on key (even single key), for example patch "Gravitational 1.6", in any octave. (Good reproduce during sounding tail of previous note.) So, i found that the reason exactly in IRCAM Scrub. But if decrease Scrub's "Window" parameter from 94.9 to minimum then glitch is can say gone.

It is a pity that the ircam devs are not very interested in optimizing their products, and it seems in support in general. Please do no need to say that this is such a complex algorithm and therefore it works only in this way. "I do not believe" (c) Stanislavski. Because it's not just about in Falcon, i have ircam studio pack bundle and there is some aftertaste. For example non-working feature at all (in Trax v3), that still not fixed by years, as well regular crashes of Trax modules (in vst Win at least).
The UVI support looks at this background like avengers (in good sense lol).

DrFolder
KVRist
78 posts since 4 Feb, 2015

Re: UVI Falcon - hybrid instrument - version 1.6 released

Post Fri Oct 05, 2018 3:40 pm

Any one else having crazy scaling issues on a 4k 3840 x 2160 win10 with 1.61? I open the plugin and its zoomed in so much I can only see the "FA" of the Falcon name in the corner. If I resize the window it scales the gui to the right size. This happens every time I open the vsti window in Reaper, Renoise and Reason. Anyone one else having issues?

Charlie Firpo
KVRist
127 posts since 22 Feb, 2005

Re: UVI Falcon - hybrid instrument - version 1.6 released

Post Fri Oct 05, 2018 4:08 pm

No, nothing that serious. I thought i wouldn't even mention it but something changed with the new version (which i'm grateful for, love the new filter). I have my resolution at the recommended settings (win10) but use the windows scale optition (125%). What can i say. I'm getting older and like things to be bigger ;) i have always had Falcon at scale: 100. But the newest version makes the drop down menu selection for Oscillators(the + sign = add osc) disappear half way through the bottom of the screen. I can't for my life remember that it used to be this way. I think in the previous version Falcon felt when the window was about to disappear and moved automaticly upwards instead of downwards, so that you could see all the choices. As it is now, i can't choose pluck, or wavetable. No showstopper by all means, cause i could just use drag and drop from the sides. Or select 90 % scale (which i've done for now) =)
Last edited by Charlie Firpo on Fri Oct 05, 2018 4:52 pm, edited 1 time in total.

Charlie Firpo
KVRist
127 posts since 22 Feb, 2005

Re: UVI Falcon - hybrid instrument - version 1.6 released

Post Fri Oct 05, 2018 4:12 pm

I should mention that the +add osc menu can't fit when you open other things like a filter at keylevel. Thats when it disappears halfway down the screen. (I think it used to automaticly go upwards in previous version)

DrFolder
KVRist
78 posts since 4 Feb, 2015

Re: UVI Falcon - hybrid instrument - version 1.6 released

Post Fri Oct 05, 2018 4:35 pm

DrFolder wrote:
Fri Oct 05, 2018 3:40 pm
Any one else having crazy scaling issues on a 4k 3840 x 2160 win10 with 1.61? I open the plugin and its zoomed in so much I can only see the "FA" of the Falcon name in the corner. If I resize the window it scales the gui to the right size. This happens every time I open the vsti window in Reaper, Renoise and Reason. Anyone one else having issues?
Turning off Open GL in the settings kind of fixed it. It still opens the plugin window the wrong size but it doesn't do the weird ultrazoom scaling.

Charlie Firpo
KVRist
127 posts since 22 Feb, 2005

Re: UVI Falcon - hybrid instrument - version 1.6 released

Post Fri Oct 05, 2018 4:42 pm

And yeah, the ultra Zooming happens here too when checking openGL, as mentioned by DrFolder.

ratsratsrats
KVRer
20 posts since 2 May, 2012 from toledo, ohio

Re: UVI Falcon - hybrid instrument - version 1.6 released

Post Fri Oct 05, 2018 11:06 pm

AcrossTheSky wrote:
Fri Oct 05, 2018 1:30 am
ratsratsrats wrote:
Thu Oct 04, 2018 11:47 pm
Anyone have any luck troubleshooting the issues with a lot of Falcon's polyphonic sounds absolutely destroying the CPU? For example a few presets from the Subculture pack, Twisted and Alien Artifact in particular, I can't even play one note without awful buzzing, I've tried in Cubase, Ableton, in the stand-alone and it persists in all three. I've also tried every buffer rate from 128 to 2048 and no fix. I'm at 48000 if that matters.

Specs: Windows 10 latest, Ableton 10.0.3, latest Falcon/UVI Workstation, latest Cubase 9.5, Audient iD22 with the latest firmware, CPU is a 8700k, speed step and all that other junk is turned off, performance mode enabled on Windows.

Edit: same issue at 44k too. :cry:

just read yours 8700K can run in Max Turbo Frequency of 4.7Ghz
..try to change the setting in BIOS and see what happens..
..also check task manager and watch the CPU performance as you use Falcon loaded in the DAW..
if it hits 100% or around or over 80%-90% then Cpu has not have the power ..

lol...Falcon is not multi-core friendly...ouch...;-(
..I'll wait longer now - needs updating !!!

ehh?? "At Falcon's heart is the UVI Engine XT™, a robust, reliable and CPU-efficient DSP powerhouse that's been constantly refined over the last 10 years".......NO VST3?MULTICORE? ouch.....
I'm stable at 4.5ghz and I still get the problems. Yikes! Really regretting purchasing the rest of the expansions, seems like a good chunk of them are actually unusable even with my setup, which is unfortunate.

Musical Gym
KVRAF
4622 posts since 24 May, 2004 from square1

Re: UVI Falcon - hybrid instrument - version 1.6 released

Post Fri Oct 05, 2018 11:51 pm

Latest version truncates right side menu for me no matter which gui size I select.
You do not have the required permissions to view the files attached to this post.

AcrossTheSky
KVRist
48 posts since 3 Jul, 2016

Re: UVI Falcon - hybrid instrument - version 1.6 released

Post Sat Oct 06, 2018 1:11 am

ratsratsrats wrote:
Fri Oct 05, 2018 11:06 pm
AcrossTheSky wrote:
Fri Oct 05, 2018 1:30 am
ratsratsrats wrote:
Thu Oct 04, 2018 11:47 pm
Anyone have any luck troubleshooting the issues with a lot of Falcon's polyphonic sounds absolutely destroying the CPU? For example a few presets from the Subculture pack, Twisted and Alien Artifact in particular, I can't even play one note without awful buzzing, I've tried in Cubase, Ableton, in the stand-alone and it persists in all three. I've also tried every buffer rate from 128 to 2048 and no fix. I'm at 48000 if that matters.

Specs: Windows 10 latest, Ableton 10.0.3, latest Falcon/UVI Workstation, latest Cubase 9.5, Audient iD22 with the latest firmware, CPU is a 8700k, speed step and all that other junk is turned off, performance mode enabled on Windows.

Edit: same issue at 44k too. :cry:

just read yours 8700K can run in Max Turbo Frequency of 4.7Ghz
..try to change the setting in BIOS and see what happens..
..also check task manager and watch the CPU performance as you use Falcon loaded in the DAW..
if it hits 100% or around or over 80%-90% then Cpu has not have the power ..

lol...Falcon is not multi-core friendly...ouch...;-(
..I'll wait longer now - needs updating !!!

ehh?? "At Falcon's heart is the UVI Engine XT™, a robust, reliable and CPU-efficient DSP powerhouse that's been constantly refined over the last 10 years".......NO VST3?MULTICORE? ouch.....
I'm stable at 4.5ghz and I still get the problems. Yikes! Really regretting purchasing the rest of the expansions, seems like a good chunk of them are actually unusable even with my setup, which is unfortunate.
I'm afraid to say BUT that would explain WHY there is no trial of Falcon - You buy first and discover later that your setup just cannot handle Falcon with satisfying results ..and you cannot simply return your product.

ratsratsrats
KVRer
20 posts since 2 May, 2012 from toledo, ohio

Re: UVI Falcon - hybrid instrument - version 1.6 released

Post Sat Oct 06, 2018 1:30 am

AcrossTheSky wrote:
Sat Oct 06, 2018 1:11 am

I'm afraid to say BUT that would explain WHY there is no trial of Falcon - You buy first and discover later that your setup just cannot handle Falcon with satisfying results ..and you cannot simply return your product.
Worst part is I just spent $78 dollars or so today on expansions and last month I picked up Drum Designer and noticed similar issues with certain sets on that as well. Guess I should stop buying into the hype. Still waiting to see what UVI support has to say.

Oopi
KVRer
25 posts since 1 Jan, 2018

Re: UVI Falcon - hybrid instrument - version 1.6 released

Post Sat Oct 06, 2018 2:25 am

Musical Gym wrote:
Fri Oct 05, 2018 11:51 pm
Latest version truncates right side menu for me no matter which gui size I select.
I have had this same problem after couple of last updates. Right side is cut of. And before that I never had problem even when using opengl renderer but now it moves gui up about five centimetres so you can't see shit. The same problem is also in Uvi workstation when I updated that. So something has gone wrong with both guis after the latest updates. As standalone they work fine when not using opengl renderer, but in Fl studio gui is messed up no matter what.

Oopi
KVRer
25 posts since 1 Jan, 2018

Re: UVI Falcon - hybrid instrument - version 1.6 released

Post Sat Oct 06, 2018 5:33 am

Another problem happened all the favourites which are marked with star disappeared in Falcon factory bank. Probably happened when I marked patch Stab for chords 1.6. After that all other stars disappeared in Falcon factory bank. In other banks I see stars.

Return to “Instruments”