Synapse Audio Minimoog emulation "The Legend" for VST/AU and RE released!

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
KVRAF
15225 posts since 16 Sep, 2001 from Las Vegas,USA

Post Fri Mar 05, 2021 9:50 am

XorXisT wrote:
Fri Mar 05, 2021 9:01 am
Just to be clear, I'm talking about the lock feature, where you right-click the effects ON/OFF button and the "Lock Parameter" appear.
Oh ok I misunderstood what you were writing. :dog:

Yes all Locked Parameters are persistent over multiple new instances. But don't affect older instances.

So for example if I load one instance and lock FX then load another and lock Cutoff then cutoff is not locked in instance #1 but will be locked in instance #3.

The locked parameters not just FX that load in a project are the ones that are locked in the first instance of Legend. If instances 2,3, and, 4 had other params locked they are no longer locked when the project reloads (FL Studio).

I'm not sure if that's a bug or intended behavior. It's been reported so let's see what Richard says then take it from there.
Last edited by Teksonik on Fri Mar 05, 2021 9:52 am, edited 1 time in total.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
KVRAF
10092 posts since 16 Feb, 2005 from Kingston, Jamaica

Post Fri Mar 05, 2021 9:50 am

That happened to me too. ( I could into my account but not the forum), but eventually I got on (a year later :))

You can email them.

https://www.synapse-audio.com/contactus.html

rsp
sound sculptist

User avatar
KVRAF
15225 posts since 16 Sep, 2001 from Las Vegas,USA

Post Fri Mar 05, 2021 9:58 am

After thinking about it further it's possible Locks are supposed to be persistent otherwise what would be the point ?

If you lock for example the FX in one instance then it will be locked in new instances which is what one would want right ?

I don't ever use Lock so I'm not sure what people want or expect it to do.

Let's see what Rich says. If it's not intended behavior then we can do further testing to help find out what's going on...... :tu:
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
KVRAF
10092 posts since 16 Feb, 2005 from Kingston, Jamaica

Post Fri Mar 05, 2021 10:01 am

I would normally use them whilst I am changing patches in that instance....

I wouldn't want it in a new instance at all....
Just that instance...other plugins I use it it is per instance..
Imagine I have an arp I like, I lock the arp and try different presents which may or may not have arp on, and see which one has a better tone that fits the project track.
For sure I wouldn't want it to open every future instance with that arp pattern enabled.

If I want something locked globally, I enable it and save that as my default patch in Cubendo.

Why would lock globally be intentional but not unlock?
rsp
sound sculptist

User avatar
KVRAF
15225 posts since 16 Sep, 2001 from Las Vegas,USA

Post Fri Mar 05, 2021 10:17 am

zvenx wrote:
Fri Mar 05, 2021 10:01 am
For sure I wouldn't want it to open every future instance with that arp pattern enabled.
But the new instance doesn't carry over the old parameter just the Lock function. Try it with Delay. Set it for some long amount then lock the FX. Load a new instance and that long delay is not carried over even when the FX are locked.
zvenx wrote:
Fri Mar 05, 2021 10:01 am
Why would lock globally be intentional but not unlock?
If you load an instance and unlock the FX then the next instance will have the FX unlocked.

I don't see the point in Lock and never use it but like I said let's wait to see what Rich says and take it from there. Maybe it is a bug and that's not the way it's intended to work. :shrug:
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
KVRist
377 posts since 20 Jun, 2005

Post Fri Mar 05, 2021 10:25 am

Thanks everyone :) .

After further testing, I think this is not intended behavior, at least on my end.

Please test this:

1- Create project test1 with legend with effects button ON and save.

2- Create project test2 with legend with effects button ON and save.

Now both projects are with effects button ON, both not locked.

3- Open project test2, open legend and turn effects button OFF and lock it (right-click > lock parameter). Don't save the project.

4- Open project test1 and, at least for me, effects button will be OFF and locked. This is not what I expect because I've saved test1 with effects ON.

User avatar
KVRAF
10092 posts since 16 Feb, 2005 from Kingston, Jamaica

Post Fri Mar 05, 2021 10:28 am

With the delay it is carried over for me.

Certainly the plugins I use lock with, (from other developers), none of them behave this way... Lock is per instance unless you then save it as your default.

rsp
You do not have the required permissions to view the files attached to this post.
sound sculptist

User avatar
KVRAF
15225 posts since 16 Sep, 2001 from Las Vegas,USA

Post Fri Mar 05, 2021 10:39 am

zvenx wrote:
Fri Mar 05, 2021 10:28 am
With the delay it is carried over for me.
No I was talking about locking the FX On/Off Button not the individual FX params but ok I see what you're saying.
zvenx wrote:
Fri Mar 05, 2021 10:28 am
Certainly the plugins I use lock with, (from other developers), none of them behave this way... Lock is per instance unless you then save it as your default.
Ok calm down. It's been reported so once again let's see what Rich says and then take it from there.

We might just be overthinking it anyway. Why not just turn off the locks when you're done using them rather than leaving them on?

Wouldn't that solve the issue the OP is reporting? Turn off the FX lock then it won't be active in any other instances or in older projects ?
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
KVRAF
10092 posts since 16 Feb, 2005 from Kingston, Jamaica

Post Fri Mar 05, 2021 10:53 am

You were trying to rationalize a beahviour that does not make sense. It clearly is a bug.

rsp
sound sculptist

User avatar
KVRist
377 posts since 20 Jun, 2005

Post Fri Mar 05, 2021 11:03 am

Teksonik wrote:
Fri Mar 05, 2021 9:58 am
I don't ever use Lock so I'm not sure what people want or expect it to do.
I didn't use it until last week :lol: .

But the problem is this is not explained on the manual.

I can live with this behavior just fine, but if someone that never used the lock feature just started to use it, their old projects would sound different, and this is where the problem is I think.

But yes, let's see what Richard says :)

User avatar
KVRist
377 posts since 20 Jun, 2005

Post Fri Mar 05, 2021 11:05 am

zvenx wrote:
Fri Mar 05, 2021 10:53 am
It clearly is a bug.

rsp
Yes I think so too.

But maybe Richard can explain exactly how this works

User avatar
KVRAF
10092 posts since 16 Feb, 2005 from Kingston, Jamaica

Post Fri Mar 05, 2021 11:06 am

Fair enough.
rsp
sound sculptist

User avatar
KVRist
377 posts since 20 Jun, 2005

Post Fri Mar 05, 2021 11:11 am

zvenx wrote:
Fri Mar 05, 2021 9:50 am
That happened to me too. ( I could into my account but not the forum), but eventually I got on (a year later :))

You can email them.

https://www.synapse-audio.com/contactus.html

rsp
Thanks, yes will do.

User avatar
KVRAF
15225 posts since 16 Sep, 2001 from Las Vegas,USA

Post Fri Mar 05, 2021 12:49 pm

zvenx wrote:
Fri Mar 05, 2021 10:53 am
You were trying to rationalize a beahviour that does not make sense. It clearly is a bug.
I'm not trying to rationalize anything I'm just trying to figure out what's going on and how Lock works right now. If it's a bug then it's a bug but let's hear from Rich first.

Lock is a feature that does not make sense to me in any plugin no matter how it works or is supposed to work so I don't really care one way or the other. I have no horse in the race. :wink:
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

KVRist
359 posts since 10 Apr, 2010

Post Mon Mar 08, 2021 5:21 pm

Just came back to the Legend after spending a lot of time with hardware analogue synths. It really is on a par with even the higher-end hardware like the Sequential synths, Prophet Rev 2 and OB-6. Just when I was thinking I was done with VA emulations, I wanted to use a synth in a music notation program and dug out The Legend again. Bloody brilliant. It's giving me second thoughts about buying a Polybrute now. If only it had a fuller modulation matrix. But they seemed to have changed even the limited one that is there, or am I misremembering? Didn't there used to be a resonance modulation target and positive/negative options for the modulation targets? Why are they taking stuff out?

Return to “Instruments”