Viper (32 & 64 Bit available)

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
keel
KVRian
703 posts since 27 Oct, 2004 from Inside the kick drum

Post Wed Jun 06, 2018 9:17 am

PiotrPochwat wrote:
1.Sometimes, when I turn on delay in fx section, audio input in viper is crashed, and work only one chanel (right or left) (the same issue is in the reverb) or not play right and left channel and I must reload plugin.
sounds like same issue(?) what I had in FL. Load Viper, play default sound, load factory bank 2 or 3 "on the fly" and Viper says click and sound goes only in left channel. Right channel output goes red and stays there all the time, but no sound. Already reported this here.

PiotrPochwat
KVRist
57 posts since 27 Sep, 2010 from European Union

Re: Viper (32 & 64 Bit available)

Post Wed Jun 06, 2018 9:36 am

keel wrote: sounds like same issue(?) what I had in FL. Load Viper, (...) and Viper says click and sound goes only in left channel. Right channel output goes red and stays there all the time, but no sound. Already reported this here.
Yes.

adamtrance
KVRian
667 posts since 29 Sep, 2004

Re: Viper (32 & 64 Bit available)

Post Wed Jun 06, 2018 10:02 am

Ok, which version of cubase is that and is it the 32 bit or 64 bit cubase?
http://www.adamszabo.com/ - Synths, soundsets and music

PiotrPochwat
KVRist
57 posts since 27 Sep, 2010 from European Union

Re: Viper (32 & 64 Bit available)

Post Wed Jun 06, 2018 10:06 am

Cubase 4 32 bit.

adamtrance
KVRian
667 posts since 29 Sep, 2004

Re: Viper (32 & 64 Bit available)

Post Wed Jun 06, 2018 10:12 am

I updated the demo version, I havent done it yet with the full one yet, can you both try to download the demo and check if this issue happens with that?
http://www.adamszabo.com/ - Synths, soundsets and music

User avatar
Roman Wisniak
KVRist
210 posts since 28 Jul, 2003 from Poland

Re: Viper (32 & 64 Bit available)

Post Wed Jun 06, 2018 10:17 am

I've checked both 32 and 64 bit versions in Studio One Pro 4 and delay problems seem not existant here. Looks like Cubase (or FL) related.
DAW StudioOne 4 Audio Interface Presonus 1818VSL with Universal Control 2.7 CPU Intel Core i9-7920X @4400 OS Win8.1 64Bit / OSX (Hackintosh) HighSierra.

User avatar
BlackWinny
KVRAF
3500 posts since 17 Jun, 2013 from very close to Paris, France

Re: Viper (32 & 64 Bit available)

Post Wed Jun 06, 2018 10:20 am

Roman Wisniak wrote:I've checked both 32 and 64 bit versions in Studio One Pro 4 and delay problems seem not existant here. Looks like Cubase (or FL) related.
... or perhaps another common point which is not yet appearant.
Build your life everyday as if you would live for a thousand years. Marvel at the Life everyday as if you would die tomorrow.

PiotrPochwat
KVRist
57 posts since 27 Sep, 2010 from European Union

Re: Viper (32 & 64 Bit available)

Post Wed Jun 06, 2018 10:21 am

adamtrance wrote:I updated the demo version, I havent done it yet with the full one yet, can you both try to download the demo and check if this issue happens with that?

Adam. Demo from this site?
http://www.adamszabo.com/viper/

or demo from the link/the email?

adamtrance
KVRian
667 posts since 29 Sep, 2004

Re: Viper (32 & 64 Bit available)

Post Wed Jun 06, 2018 10:22 am

The Demo from here: http://www.adamszabo.com/viper/ the link in the email is the full version
http://www.adamszabo.com/ - Synths, soundsets and music

PiotrPochwat
KVRist
57 posts since 27 Sep, 2010 from European Union

Re: Viper (32 & 64 Bit available)

Post Wed Jun 06, 2018 10:28 am

Ok. Tested and problem with delay and cpu also appear.

adamtrance
KVRian
667 posts since 29 Sep, 2004

Re: Viper (32 & 64 Bit available)

Post Wed Jun 06, 2018 10:33 am

Do you think you can make me a video because I am pressing the delay on/off as fast as I can but It doesnt get the error for me. Maybe im doing something wrong
http://www.adamszabo.com/ - Synths, soundsets and music

PiotrPochwat
KVRist
57 posts since 27 Sep, 2010 from European Union

Re: Viper (32 & 64 Bit available)

Post Wed Jun 06, 2018 10:58 am

adamtrance wrote:Do you think you can make me a video because I am pressing the delay on/off as fast as I can but It doesnt get the error for me. Maybe im doing something wrong
I have a idea. Please load my preset and midi file in Your DAW and press play. 15 seconds after viper finished plays the midi file, CPU spontaneously is increases. I have core 2 duo, so in your computer with better processor, cpu jump it must be proportionally less than im my computer.



I send the password for the file in a private message
You do not have the required permissions to view the files attached to this post.
Last edited by PiotrPochwat on Wed Jun 06, 2018 11:41 am, edited 2 times in total.

PiotrPochwat
KVRist
57 posts since 27 Sep, 2010 from European Union

Re: Viper (32 & 64 Bit available)

Post Wed Jun 06, 2018 11:16 am

Adam

*The cpu jump (15 seconds after viper plays the midi file) is little smaller than the CPU usage when the viper plays the melody. But it is.

User avatar
vegaron
KVRist
132 posts since 3 Aug, 2016 from Germany, Munich

Re: Viper (32 & 64 Bit available)

Post Wed Jun 06, 2018 12:37 pm

Hi,

I'm demoing version 1.0.2 (64 bit) on Cubase 8.5.30 (64 bit) (Win7) and have a strange problem...

I can
- open an empty project and browse through the presets
- let Cubase play notes I set manually in parts I add to the Viper-track

but I can not
- add a new Viper-track to my existing project and copy any of the existing parts to the Viper-track (to see how they sound with Viper)
- import one single track from the existing project into an empty project with one Viper-track and move the imported parts to the Viper-track

In both cases Cubase crashes and I do not understand why. There are no information in these parts except notes. No MIDI CCs, no automation, nothing.

This problem did not occur when I demoed the 32-bit version. In fact, my existing project already had one Viper-track and it worked fine. After updating to 64-bit, this project crashes if I don't delete the Viper-track. I hope, I could explain myself...

LL Cool Whip
KVRer
3 posts since 1 Jan, 2018

Re: Viper (32 & 64 Bit available)

Post Wed Jun 06, 2018 3:31 pm

Adam, good to hear you have taken care of the audio glitching on patch changes!
Also sounds like the over-all volume levels are really high in relation to all other VST's on my system. No show stopper, but seems to stand out as something to address in the future.
Chris

Return to “Instruments”