Wusikstation latest version crashes

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
aMUSEd
KVRAF
30084 posts since 14 Sep, 2002 from In teh net

Post Tue Feb 27, 2018 12:36 am

Installer crashes on MacOs Sierra

FX plugin fails auvalidation

User avatar
Michael L
KVRAF
2444 posts since 25 Jan, 2014 from the End of the World as we Knowit

Re: Wusikstation latest version crashes

Post Tue Feb 27, 2018 1:30 am

I installed manually, VST is OK but AU fails.
How do your legacy presets sound with the latest version? ArtVera Mistral are back to being wonky.
I reverted to 8.2.0 and left a support message on his acebook

User avatar
aMUSEd
KVRAF
30084 posts since 14 Sep, 2002 from In teh net

Re: Wusikstation latest version crashes

Post Tue Feb 27, 2018 1:36 am

Oh crap not even checked those yet - will revert - pointless update

User avatar
WilliamK
KVRAF
4195 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusikstation latest version crashes

Post Tue Feb 27, 2018 7:42 am

What a pointless thread I would say myself. :hihi: How about you tell me things directly instead of complaining it here. ;-) I'm working on it already, as some users contacted me directly to tell me what was going on.

On my MAC, OSX Sierra, all works fine, so I really don't know, yet, on why the installer is crashing. As I'm doing things (from what I could tell) correctly. But I'm new to the MAC scene, so I'm still learning things out (even after years of messing around with OSX).

As for the ArtVera Mistral sets, I'm aware of that, I'm fixing things up as fast as I can. Sadly when I updated some problems on V8 and V9, I managed to crap things out for this latest release, so I apologize for that. :oops:

Anyway, you will be hearing about a new update soon. Sorry again for the problems.

Best Regards, WilliamK

User avatar
aMUSEd
KVRAF
30084 posts since 14 Sep, 2002 from In teh net

Re: Wusikstation latest version crashes

Post Tue Feb 27, 2018 9:24 am

WilliamK wrote:What a pointless thread I would say myself.
It got the desired result, only way to get a response, I don't do facebook

User avatar
WilliamK
KVRAF
4195 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusikstation latest version crashes

Post Tue Feb 27, 2018 9:50 am

I still have a support area on my site. The Facebook is another thing.

Anyway, I'm seeking some online help regarding osx as for some reason in some machines it works and in others with the same Sierra setup it won't. And no, you were not the first one to report. I got support requests from my site already.

What is the exact error message the validation tool is giving?

Cheers

User avatar
aMUSEd
KVRAF
30084 posts since 14 Sep, 2002 from In teh net

Re: Wusikstation latest version crashes

Post Tue Feb 27, 2018 2:29 pm

It just crashes the tool

validating Audio Unit Wusik Station V8 by Wusik Dot Com:

AU Validation Tool
Version: 1.6.1a1
Copyright 2003-2013, Apple Inc. All Rights Reserved.
Specify -h (-help) for command options

--------------------------------------------------
VALIDATING AUDIO UNIT: 'aumu' - 'd0gl' - 'Wusk'
--------------------------------------------------
Manufacturer String: Wusik Dot Com
AudioUnit Name: Wusik Station V8
Component Version: 8.2.4 (0x80204)

* * PASS
--------------------------------------------------
TESTING OPEN TIMES:
COLD:


validation result: crashed validation

User avatar
WilliamK
KVRAF
4195 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusikstation latest version crashes

Post Thu Mar 01, 2018 10:24 am

I just uploaded MAC/Windows Wusik Station V8.2.6 BETA 00, please, could you guys test this one out?

MAC_Wusik_Station_V826_BETA_00.zip
WIN_Wusik_Station_V826_BETA_00.zip

(use the Download URL you got from your order)

I also uploaded a new Installer for MAC to be tested, to see if it still crashes.

http://wusik.com/download/Wusik_Install ... 8_2008.zip

- ! IMPORTANT ! Changed the Multi-Out behaviour: now you have a regular file and another one with MultiOut in the name. The regular has one stereo input and one stereo output. And the MultiOut one stereo input and 16 stereo outputs. If you have projects that uses the regular file for multi-outputs just rename the MultiOut file to that other file instead. Also improved the code for the regular one stereo output.
- Fixed a problem with Wavetable files and non-Wavetable files getting confused one from another. Now Wavetable files must have Wavetable or PW on the name to be detected as a Waveform (Transwaves) file. If the filename has PWM and PW it will not be detected, so use PWM and Waveform instead. EG: Pulse PWM Wavetable instead of Pulse PWM PW.
- Fixed a problem with hosts that has more channels than the engine can work with. EG: 64 channels when the engine only supports a max of 32 channels (when in multi-mode).

If you need VST3 support, just copy and rename the .dll files to .vst3

I will handle Wusik 8000 and Wusik 4000 once I have tested those changes.

If anyone want to help me with the installer code, I released it as open-source. ;-)

https://github.com/Beat707/Wusik-Installer

Cheers, WilliamK

User avatar
WilliamK
KVRAF
4195 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusikstation latest version crashes

Post Sun Mar 04, 2018 6:03 am

I uploaded yet another BETA, could you guys test this one out, please? I also uploaded a new installer to test out.

http://wusik.com/download/WIN_Wusik_Ins ... 3_2018.zip

http://wusik.com/download/MAC_Wusik_Ins ... 3_2018.zip

Cheers, WilliamK

User avatar
aMUSEd
KVRAF
30084 posts since 14 Sep, 2002 from In teh net

Re: Wusikstation latest version crashes

Post Sun Mar 04, 2018 6:16 am

Is that the full version? Or do I use my original link for that?

User avatar
WilliamK
KVRAF
4195 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusikstation latest version crashes

Post Sun Mar 04, 2018 6:20 am

You need to use your original link for the full version. That above is the new installer.

Cheers

User avatar
aMUSEd
KVRAF
30084 posts since 14 Sep, 2002 from In teh net

Re: Wusikstation latest version crashes

Post Sun Mar 04, 2018 6:44 am

So it installs the demo?

User avatar
WilliamK
KVRAF
4195 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusikstation latest version crashes

Post Sun Mar 04, 2018 6:49 am

The installer is just the app, for testing.

User avatar
aMUSEd
KVRAF
30084 posts since 14 Sep, 2002 from In teh net

Re: Wusikstation latest version crashes

Post Sun Mar 04, 2018 8:44 am

Still crashes AU validation tool

User avatar
WilliamK
KVRAF
4195 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusikstation latest version crashes

Post Sun Mar 04, 2018 8:50 am

Be sure that you got the latest beta file, as other users who were crashing too no longer crashes now. :shrugs:

Return to “Instruments”