Hypersonic 2 installation

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
1593 posts since 26 Jul, 2004

Post Sun Jul 08, 2018 5:10 am

Hello all.

As a Halion 6 owner I can use Hypersonic2 also.
Steinberg did send me a special license and and iso of the installation files I need.

I tryed to install it, but it fails somehow.

Did anybody ever managed it to install it on win 8 or 10 and get it to work.
I got Jbridght to use it in 64 bit hosts also, but am failing to install it.

Any help possible.

As told, using win 10 home edition, so....

Thanks a lot

1593 posts since 26 Jul, 2004

Re: Hypersonic 2 installation

Post Tue Jul 10, 2018 12:13 am

No on with an idea?


704 posts since 20 Feb, 2003

Re: Hypersonic 2 installation

Post Wed Jul 11, 2018 5:56 am

You don't say the host you're using. Steinberg's own bit bridge stopped working with Hypersonic 2 long before they dropped their 32 bit support for other programs. So you need a 32 bit host, or a compatible host with a working bit bridge solution (for example: jbridge for Cubase)

In terms of installation, I don't know what's gone wrong. Try running the exe file in Windows 7 compatibility mode (search if you don't know how), and check that your host has not added the plugin to any blacklist of plugins it shouldn't load. Failing that, you can manually install hypersonic 2 on Windows if you're comfortable doing the following..

1. Manually copy the content directory folder and the hypersonic dll to a folder in your VST directory.

2. Save the following as a .reg file to enter it into the registry, and modify the paths below to where you placed the Hypersonic DLL and its content directory.

Note that this was only tested on Windows 7, though it should be ok on later versions.

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Steinberg\Hypersonic 2]
"Content Location"="C:\\Your\\Audio\\VST\\PATH\\Hypersonic\\Hypersonic Content\\"
"Install Path"="C:\\Your\\Audio\\VST\\PATH\\Hypersonic\\"
"Vel Sens"="0"
"Touch Sens"="0"
"MIDI Combis"="ON"
"MIDI Numbering"="0-127"
"MIDI Patches"="ON"
"Meter Mode"="0"
"Memory Use"="Default"
"Master Vol"="-6.0 dB"
"Combi Preload Mode"="Off"

Good luck :)

Return to “Instruments”