Wusik EVE V5 Beta Testing

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
goldglob
KVRian
618 posts since 10 Jan, 2007 from London

Post Tue Nov 06, 2018 3:17 pm

Yep, installed the nosounds engine first. I don't think you need basic shared files inside each engine. I think it's just that at the moment the dll doesn't know where everything is...something like that?
BTW, before I installed this latest stuff I re-named my previous installation to get it out of the way and not have any merging problems.
So at present I have 'Shared' folder and 'Wusik EVE V5' folder inside 'Wusik Engine Data' folder. And inside the 'Shared/soundsets' I put AOS soundsets folder and a few others, not the whole 16 gigs yet.

User avatar
fmr
KVRAF
7845 posts since 16 Mar, 2003 from Porto - Portugal

Re: Wusik EVE V5 Beta Testing

Post Wed Nov 07, 2018 3:41 am

I downloaded the big installer file, deleted all the previous folders (the old EVE v5 Data folder and the old Shared folder), and installed the new versions.

I'm glad to say that everything is running fine in both 32-bit and 64-bit versions.

The horrible distortion I reported previously seems to be gone. However, there's an issue. All instuments in a Multi are loaded in Omni. But they all load at full volume, as if they were going to be played alone. Result: If you have like five instruments loaded and didn't change the MIDI channels yet, you risk to blow your speakers. Maybe a way to limit the global volume for these situations, as a safety measure, would be good.

Now regarding the CPU. The 32-bit version improved a little (maybe around 10%) but is still too high. A multi with five instruments takes around 40% CPU in VST Host.

However, the 64-bit versions seem to behave MUCH BETTER now. I loaded the same multi in Reaper, and the Reaper Performance Meter shows only around 4-5% for EVE, which is an AMAZING gain regarding the 32-bit version. If you manage to get this same level of optimization for the other instruments, I will be very happy.

Of course, REAPER is known to be probably the best host around. I'll have to perform tests in other hosts. I will and will report later. Keep the good work, and look forward to the updates to the remaining instruments.

Just another thing: The installer puts ALL the plug-in versions into the same folder. This isn't a good behavior, nor the correct behavior for plug-in installers. Usually, we have the choice for VST2 folders and the VST3 versions go to the pre-defined folders (which are fixed and always the same).

The way it is now, I chose to create a kind of "repository" VstPlugIns folder inside the Wusik.com folder where the all the Data goes, and manually copy the different files to their proper locations. Not elegant, but it's the safer way.
Last edited by fmr on Wed Nov 07, 2018 3:59 am, edited 1 time in total.
Fernando (FMR)

User avatar
WilliamK
KVRAF
4009 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik EVE V5 Beta Testing

Post Wed Nov 07, 2018 3:51 am

Thanks Fernando. Yeah, all of Wusik Products will be optimized with this, very soon. :cool: I'm still coding more optimizations. ;-) I couldn't get the Intel compiler to create a working 32 bits version, so it still uses the MSVC compiler, which is not as optimized. But I'm working on the code which optimizes for both 32 and 64 bits versions.

I will go on every report here soon and fix all problems too. :party:

Cheers, WilliamK

User avatar
WilliamK
KVRAF
4009 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik EVE V5 Beta Testing

Post Wed Nov 07, 2018 6:07 am

goldglob wrote:
Sun Oct 28, 2018 4:31 pm
HQ Piano Sets.
Load a piano..Amp KeyT knob shows 0.0 but sound is actually as if knob was at -1.0....adjust knob a bit..it takes over correct value.
I can't reproduce anymore, I think I fixed this in a previous beta, when stuff wasn't displaying correctly. But let me know if this still happens. Thanks.
goldglob wrote:
Mon Oct 29, 2018 5:19 pm
http://freepats.zenvoid.org/Piano/acous ... piano.html
The Kawai piano is fine but the Salamander (scroll down) makes the noise....I've realized what the noise is...the release samples (the mechanical sound) is about 20x louder than the actual notes....but this piano sounds fine in other SFZ players.
Downloading. ;-)

Cheers, WilliamK

User avatar
WilliamK
KVRAF
4009 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik EVE V5 Beta Testing

Post Wed Nov 07, 2018 7:58 am

Nov 06 2018 - V5.0.0 BETA 56

- Several code optimizations, specially in the 64 bits version.
- New Installers and New Wusik Engine DATA Folder where everything for all Wusik Products gets stored. Inside there is a Shared/SoundSets folder where all sounds gets stored so all Wusik Products can share without duplicated files.
- Fixed the problem with the tree-view filebrowser not been wide enough in some situations.
- Added in the tree-view filebrowser under Options (right click anywhere or click the first item on the top) a new option: Filter Non SFZ Files - when selected it will filter wav, flac, mp3, ogg and aiff files.
- Fixed an error when trying to load internal filters and effects.
- Fixed the installer so it adds Wusik Engine Data to the data folder when you select a folder directly. EG: you select c:\Program Files it will add c:\Program Files\Wusik Engine Data

I'm recompiling the 16 Gig file too with the installer changes.

Cheers, WilliamK

User avatar
WilliamK
KVRAF
4009 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik EVE V5 Beta Testing

Post Wed Nov 07, 2018 10:29 am

Ok, I uploaded just now a new WIN_Wusik_EVE_V5_Engine.zip file that improves the playing of that piano sfz file. For now I'm just ignoring the pedal and release samples, but soon I will add support for that. Also, it looks like my code is not doing the correct conversion of the VOLUME OPCODE, from decibels to gain. I will fix this soon. :cool: Oh boy, still a lot of work to be done. :hihi:

User avatar
WilliamK
KVRAF
4009 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik EVE V5 Beta Testing

Post Wed Nov 07, 2018 10:44 am


Cakreshvara
KVRist
82 posts since 4 Sep, 2006

Re: Wusik EVE V5 Beta Testing

Post Wed Nov 07, 2018 11:45 am

Thanks for these fixes. I was almost able to get out of driving the wife to the mall, but I couldn't make the case that I had to make EVE a priority. She got mad and asked "Who is Eve?". She told me I could explain on the way to the mall...

Looking forward to being able to download the new build once the ordeal here is finished. I think that if there really is a hell in the afterlife, it will be having to walk for eternity through an endless maze of shoe stores and dressing rooms.

John

User avatar
WilliamK
KVRAF
4009 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik EVE V5 Beta Testing

Post Wed Nov 07, 2018 12:04 pm

LOL good one John. :-)

User avatar
WilliamK
KVRAF
4009 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik EVE V5 Beta Testing

Post Wed Nov 07, 2018 3:22 pm

I'm actually doing a new code for SFZ files, to filter SFZ sample files (wav, flac, mp3, ogg, aiff) only when a SFZ file(s) is found in a folder. :cool:

User avatar
WilliamK
KVRAF
4009 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik EVE V5 Beta Testing

Post Wed Nov 07, 2018 3:58 pm

Ok, updated the WIN_Wusik_EVE_V5_Engine.zip file again. Now the SFZ filtering is ON by Default, but it only filter files IF it finds at least one SFZ file in the folder its about to filter. It will hide wav, ogg, flac, mp3 and aiff. You can always turn this option off using the Options as before. In case you want to check those files for some reason.

goldglob
KVRian
618 posts since 10 Jan, 2007 from London

Re: Wusik EVE V5 Beta Testing

Post Wed Nov 07, 2018 4:37 pm

Just home again and testing. William, could you explain how the Amp Key Track works and why minus and plus values?

goldglob
KVRian
618 posts since 10 Jan, 2007 from London

Re: Wusik EVE V5 Beta Testing

Post Wed Nov 07, 2018 6:42 pm

...and thanks for all the concentrated work you're doing...getting late here in London...more thoughts tomorrow.

User avatar
WilliamK
KVRAF
4009 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik EVE V5 Beta Testing

Post Thu Nov 08, 2018 4:48 am

Hey, thanks for all the testing and ideas. :hug:

goldglob
KVRian
618 posts since 10 Jan, 2007 from London

Re: Wusik EVE V5 Beta Testing

Post Thu Nov 08, 2018 7:36 am

To bypass the Filter ADSR I just need to have the FILTER Env knob at zero, yes?

Filters Multi and WS Legacy have bypass option but M24 LP and M24 Multi do not...any reason for that?
Would be good to also have a global bypass of all filters in the right click menu.

FILTER> Options>
Disable reset on NoteOn..is that only relevant to ADSR?
How does Frequency Key Follow work?
ModWheel to Frequency...seems to be working.
After Touch to Frequency....not working?
Key Velocity to Frequency....not working?

Also, the Env knob tooltip box is cutting out some text.

Are the EQ knobs just boost not cut?
Part of what I'm getting at here is being able to hear say a raw imported wav without any filtering or Vol ASDR.

Return to “Instruments”