Vember Audio Surge is now open-source

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
KVRist
405 posts since 28 Oct, 2014

Post Mon Feb 04, 2019 6:47 am

esaruoho wrote:
Wed Jan 30, 2019 8:55 am

Could you confirm what the lowest value of the HP Filter is on Commercial Surge 1.52 version, please?

Because if it is 6.875Hz then the fix is in the newest builds.
Yeah the lowest value is 6.875, but the synth has 55hz as a default, so every time you initialize it, you have to remember to turn down the HP

Oh and regarding the list of changes, yeah i might install for the zoom and new envelope mode :)
64 bit though, the 1.52 also has

User avatar
KVRist
294 posts since 4 Feb, 2010 from kontula, helsinki, finland

Post Mon Feb 04, 2019 7:19 am

_al_ wrote:
Mon Feb 04, 2019 6:47 am
esaruoho wrote:
Wed Jan 30, 2019 8:55 am

Could you confirm what the lowest value of the HP Filter is on Commercial Surge 1.52 version, please?

Because if it is 6.875Hz then the fix is in the newest builds.
Yeah the lowest value is 6.875, but the synth has 55hz as a default, so every time you initialize it, you have to remember to turn down the HP

Oh and regarding the list of changes, yeah i might install for the zoom and new envelope mode :)
64 bit though, the 1.52 also has
New builds are 6.875hz by default.

KVRist
422 posts since 25 Dec, 2018

Post Mon Feb 04, 2019 7:40 pm

planetearth wrote:
Sun Feb 03, 2019 11:04 am
planetearth wrote:
Thu Jan 31, 2019 7:22 pm
I just downloaded the latest version 10 minutes ago, and can confirm that some of the text gets a bit blurry when you zoom. That's not a big deal to me, personally.

I think the bigger problem is that the plug-in window doesn't enlarge when you zoom to 125% (or when choosing "grow by X%" option), and when you drag it out to see the rest of the plug-in, the plug-in GUI is cut off where the window was originally, and you can't re-size it again.

Clipboard01 (1).jpg

If you zoom by 150%, the plug-in window does enlarge and the GUI appears to get bigger, but the GUI is still cut off. As a result, it looks basically like the image I've attached...just bigger, with more empty space in the window where the GUI should be.

Closing the window and re-opening it resets the size to 100%, apparently.

I'm trying to use this in Sonar Platinum (x64) on Windows 7 (x64).

Steve
I mentioned the zoom returning to 100% a few days ago, in this post. Has anyone else who's tried the zoom encountered these other issues, where the plug-in's window doesn't size with the GUI?

Steve
Steve

The collaboration between plugin and host on resize is rather tricky and host dependent. We worked to get most of the ones we could find resizing properly.

If you are seeing this problem in your combination, it would be super useful to open a github issue with host version, operating system, the about screen version you see of surge, the flavor of plugin (vst2,vst3, etc..) so we at least know about it.

Basically not all hosts respond to the vst2 resize message the same way so knowing one that doesn’t may let us find a fix. (And vst3 and AU are different also).

Appreciated

KVRAF
4542 posts since 21 Sep, 2005

Post Tue Feb 05, 2019 10:44 am

I've tested the latest 64 bit VST2 -Feb 4 build in:

Ableton 9 64bit
Ableton Live 10 Lite 64bit
Studio One 3 64bit
Studio One 4 64bit
Samplitude Pro X 3 64bit
Cubase LE 9.5 64bit
Reaper 5.9 64bit

All on winX 64bit.

The GUI zooms and resizes properly. Of course it always resets to 100% normal size after closing and reopening. It does this in all hosts. I'm sure you know about this.

I experienced the same problem as planetearth with the GUI being 'cut off' due to the container or wrapper window not resizing in the host, this time in FLStudio 20.1.1 64bit. The Surge GUI resizes but the FL wrapper window does not. It reverts to normal when shut and reopened.

Also, in Tracktion Waveform, when you zoom the window, you lose the Header title bar of the plugin window making it impossible to move or close the plugin. If you zoom too far you have to close the project down because it's totally blocked. Again reopening (if you can) resets the window. This is Waveform 8 64bit.

Can't seem to find the 32bit version of the Surge plugin to test, so I can't try it in EnergyXT2.6, XT2.7 or XT3.0. If you can point me to where it is I'll give it a go.


I've opened an issue in Github with all the relevant details, including versions and screenshots to show the problems in FLStudio and Waveform.

User avatar
KVRist
294 posts since 4 Feb, 2010 from kontula, helsinki, finland

Post Tue Feb 05, 2019 11:29 am

codec_spurt wrote:
Tue Feb 05, 2019 10:44 am
The GUI zooms and resizes properly. Of course it always resets to 100% normal size after closing and reopening. It does this in all hosts. I'm sure you know about this.
yep, i just read that today that it would be about 5-6 developer hours to properly create the user preferences and make it work so that there would be slots for surge default zoom - and maybe - further down the line, song-specific zoom settings.
yep, there's a ticket for it, and hopefully it'll be implemented soon but maybe not in the next few days.
codec_spurt wrote:
Tue Feb 05, 2019 10:44 am
I've opened an issue in Github with all the relevant details, including versions and screenshots to show the problems in FLStudio and Waveform.
thanks for the ticket, it was very detailed and much appreciated. it's also great to be coming across these daws that have issues with the zoom - that's the only way the zoom will work as-expected on most daws, by getting info on which ones break with it. thanks again!

(it was very encouraging to read such a detailed ticket, and it is very much appreciated).

User avatar
KVRAF
10320 posts since 4 Jan, 2017 from Warsaw, Poland

Post Fri Feb 08, 2019 12:18 am

esaruoho wrote:
Tue Feb 05, 2019 11:29 am
codec_spurt wrote:
Tue Feb 05, 2019 10:44 am
The GUI zooms and resizes properly. Of course it always resets to 100% normal size after closing and reopening. It does this in all hosts. I'm sure you know about this.
yep, i just read that today that it would be about 5-6 developer hours to properly create the user preferences and make it work so that there would be slots for surge default zoom - and maybe - further down the line, song-specific zoom settings.
yep, there's a ticket for it, and hopefully it'll be implemented soon but maybe not in the next few days.
So happy to read this, because that was one of my two "complaints". The other is - maybe I'm wrong - that zooming to 125% blurs the GUI (more than 100%), while to 150% makes it crispy sharp again. Is there some merit to this observation, or I just have to consult an optician? ;)

BTW, really awesome job on "reviving" Surge! :clap: :tu:

I always wanted it, but the EUR99 price tag was preventing me from getting 10+ year old, abandoned synth.
Music tech enthusiast
DAW, VST & hardware hoarder
My "music": https://soundcloud.com/antic604

User avatar
KVRist
294 posts since 4 Feb, 2010 from kontula, helsinki, finland

Post Fri Feb 08, 2019 12:53 am

antic604 wrote:
Fri Feb 08, 2019 12:18 am
So happy to read this, because that was one of my two "complaints". The other is - maybe I'm wrong - that zooming to 125% blurs the GUI (more than 100%), while to 150% makes it crispy sharp again. Is there some merit to this observation, or I just have to consult an optician? ;)
Cool, I've posted on the Surge Synth Slack about this, and hopefully we'll have some answers as to what's going on. (Personally I would expect the 150% assets to be resized down to 125%, instead of 100% assets resized up to 125%, but we'll see what is actually happening.)

Thanks for posting the issue, it really helps! :)

edit: your ticket is now at https://github.com/surge-synthesizer/surge/issues/540

User avatar
KVRian
1071 posts since 6 May, 2010 from Munich, Germany

Post Fri Feb 08, 2019 7:38 am

There have been several claims that Audioterm could not produce well-sounding wavetables. Here is a sound that consists of a wavetable with 5 waveforms. The wavetable was created with serum

https://www.dropbox.com/s/5ljzyjkup9nt9 ... s.fxp?dl=0
Owner of the FB site of Audioterm

User avatar
KVRist
294 posts since 4 Feb, 2010 from kontula, helsinki, finland

Post Sat Feb 09, 2019 12:17 pm

NEW:
32bit windows VST2,VST3 installer available at http://surge-synthesizer.github.io/
wahey!
antic604 wrote:
Fri Feb 08, 2019 12:18 am
zooming to 125% blurs the GUI (more than 100%), while to 150% makes it crispy sharp again. Is there some merit to this observation, or I just have to consult an optician? ;)
Yep, it's definitely a valid issue to report. It's a two-part process: the 125x assets are now in, but there's still some coding required. i'll ping you when it's in.

User avatar
KVRAF
10320 posts since 4 Jan, 2017 from Warsaw, Poland

Post Sat Feb 09, 2019 2:00 pm

esaruoho wrote:
Sat Feb 09, 2019 12:17 pm
NEW:
32bit windows VST2,VST3 installer available at http://surge-synthesizer.github.io/
wahey!
antic604 wrote:
Fri Feb 08, 2019 12:18 am
zooming to 125% blurs the GUI (more than 100%), while to 150% makes it crispy sharp again. Is there some merit to this observation, or I just have to consult an optician? ;)
Yep, it's definitely a valid issue to report. It's a two-part process: the 125x assets are now in, but there's still some coding required. i'll ping you when it's in.
Thanks! :tu:
Music tech enthusiast
DAW, VST & hardware hoarder
My "music": https://soundcloud.com/antic604

User avatar
KVRAF
2001 posts since 16 May, 2004 from Soviet Union

Post Sat Feb 09, 2019 2:15 pm

esaruoho \ folks, i recently try official v152 build from friend, for compare, so, my assumptions were confirmed - by some reason new version load cpu already in initial (idle) stage, just after load plugin (it's a pretty small cpu load, but strange it is). While in v152 absolutely zero cpu usage in the same idle condition. Hmm.
I dont know, maybe i miss something in settings, would be good if you check this too. Or maybe reason is known ?

User avatar
KVRAF
7702 posts since 11 Jun, 2006

Post Sat Feb 09, 2019 10:22 pm

PietW. wrote:
Fri Feb 08, 2019 7:38 am
There have been several claims that Audioterm could not produce well-sounding wavetables. Here is a sound that consists of a wavetable with 5 waveforms. The wavetable was created with serum

https://www.dropbox.com/s/5ljzyjkup9nt9 ... s.fxp?dl=0
i noticed that on your patch, you are not stepping through the partials in the WT.
was that intentional? i wonder how many people use shapable WTs in their patches but
dont realize they are only hearing a single partial unless they step through them with
an LFO or with mod wheel or some other modulator.

ie; left click the LFO1 button for example, the sliders that can be adjusted change color, move the slider the mod amount you want, left click the LFO1 button again.
i do this to the WT shape on almost all my pad patches.
Last edited by layzer on Sun Feb 10, 2019 12:52 am, edited 1 time in total.
HW SYNTHS [KORG T2EX - AKAI AX80 - YAMAHA SY77 - ENSONIQ VFX]
HW MODULES [OBi M1000 - ROLAND MKS-50 - ROLAND JV880 - KURZ 1000PX]
SW [CHARLATAN - OBXD - OXE - ELEKTRO - MICROTERA - M1 - SURGE - RMiV]
DAW [ENERGY XT2/1U RACK WINXP / MAUDIO 1010LT PCI]

User avatar
KVRist
294 posts since 4 Feb, 2010 from kontula, helsinki, finland

Post Sat Feb 09, 2019 10:42 pm

c_voltage wrote:
Sat Feb 09, 2019 2:15 pm
esaruoho \ folks, i recently try official v152 build from friend, for compare, so, my assumptions were confirmed - by some reason new version load cpu already in initial (idle) stage, just after load plugin (it's a pretty small cpu load, but strange it is). While in v152 absolutely zero cpu usage in the same idle condition. Hmm.
I dont know, maybe i miss something in settings, would be good if you check this too. Or maybe reason is known ?
I've posted this at https://github.com/surge-synthesizer/surge/issues/556

should be interesting to find out what's happening. none of the devs have access to v152 however, so this could take a while before looked at and compared.

But it's there - so any voluntary developer who's interested in it and has the possibility of looking at it, can do something about it! :tu:

User avatar
KVRAF
7702 posts since 11 Jun, 2006

Post Sat Feb 09, 2019 11:52 pm

esaruoho wrote:
Sat Feb 09, 2019 10:42 pm
c_voltage wrote:
Sat Feb 09, 2019 2:15 pm
esaruoho \ folks, i recently try official v152 build from friend, for compare, so, my assumptions were confirmed - by some reason new version load cpu already in initial (idle) stage, just after load plugin (it's a pretty small cpu load, but strange it is). While in v152 absolutely zero cpu usage in the same idle condition. Hmm.
I dont know, maybe i miss something in settings, would be good if you check this too. Or maybe reason is known ?
I've posted this at https://github.com/surge-synthesizer/surge/issues/556

should be interesting to find out what's happening. none of the devs have access to v152 however, so this could take a while before looked at and compared.

But it's there - so any voluntary developer who's interested in it and has the possibility of looking at it, can do something about it! :tu:
*sigh* love my v1.5.0 but wish it had a resizable gui like what is being implemented into the open source versions. can't have it all :(

btw, i am working on a wavetable pack based on some cool vocal samples i'll be sharing soon! :party:
HW SYNTHS [KORG T2EX - AKAI AX80 - YAMAHA SY77 - ENSONIQ VFX]
HW MODULES [OBi M1000 - ROLAND MKS-50 - ROLAND JV880 - KURZ 1000PX]
SW [CHARLATAN - OBXD - OXE - ELEKTRO - MICROTERA - M1 - SURGE - RMiV]
DAW [ENERGY XT2/1U RACK WINXP / MAUDIO 1010LT PCI]

User avatar
KVRist
294 posts since 4 Feb, 2010 from kontula, helsinki, finland

Post Sun Feb 10, 2019 12:35 am

layzer wrote:
Sat Feb 09, 2019 11:52 pm
btw, i am working on a wavetable pack based on some cool vocal samples i'll be sharing soon! :party:
That's awesome to hear!

Return to “Instruments”