Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
WilliamK
KVRAF
4702 posts since 12 Jun, 2001 from Wusik Dot Com

Post Sat Apr 20, 2019 10:08 am

Here's the public beta.

https://www.wusik.com/download/WIN_Wusi ... taller.exe

I also created my own Wusik place on Reddit.

https://www.reddit.com/r/Wusik

Cheers, WilliamK

ben2012
KVRist
43 posts since 13 Aug, 2018

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Sun Apr 21, 2019 1:49 am

Hi William,
there is something wrong when briding VST3 plugins. It seems like the plugin.vst3 file is just copied to the target folder without any briding, no matter what options are selected.

Also, I have a sort of special request, maybe you can look into it: It looks like it is possible the have multiple plugins in one dll file. I haven't seen many of these around, but one: "Silent Way" from Expert Sleepers (http://www.expert-sleepers.co.uk/downloads.html). As most DAW don't support this technique (actually, I only found Reaper supporting it when using the VST3 version), maybe X42 can support it when briding? Currently I can only bridge the "first" plugin within the file...

User avatar
WilliamK
KVRAF
4702 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Sun Apr 21, 2019 10:32 am

Ben, check in the plugin's manager if they are selected as Bridged, as I just tested here with Reaper and it seems to be working correctly. Unless you found some other bug that I haven't seen here just yet. :oops:

As for the second thing, I'm using JUCE, so there's no such option there anymore. It used to be like that, one file for VST2 and VST3, but they changed it some time ago. :shrug: Not sure why...

Cheers

ben2012
KVRist
43 posts since 13 Aug, 2018

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Sun Apr 21, 2019 11:09 am

You're right, this one was my fault :dog:

ben2012
KVRist
43 posts since 13 Aug, 2018

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Mon Apr 22, 2019 12:33 am

I did a bit of research, apparently these are called shell-plugins and need some special handling, besides "instrument" and "effect":
https://stackoverflow.com/questions/112 ... lugin-dlls
I can't confirm it, but plugins from "Waves" seem also to use this category.

User avatar
WilliamK
KVRAF
4702 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Wed Apr 24, 2019 3:19 pm

Working on Wusik X42 OSX Version, more work than I first anticipated. :-o But it's working, should have a beta by the weekend, sooner or later. Also will work on the GUI-Less plugin editor, for plugins that have, erm, no GUI... ;-)

Cheers, WilliamK

User avatar
WilliamK
KVRAF
4702 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Thu May 02, 2019 8:40 am

I'm releasing officially V1.0.0, but I will keep working on it as any newer bugs are found.

May 2nd 2019 - V1.0.0

- Initial Windows Release.

OSX version has been pushed to later this year, due to some technical problems. I don't know yet what kind of features it will have in terms of bridging older OSX plugins, as it may not be possible. It will have the MIDI Processors and Over Sampling options for when hosting VST2/VST3/AU plugins into VST2/VST3, but may not feature AU targets. You can contact me for details.

Cheers, WilliamK

User avatar
WilliamK
KVRAF
4702 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Thu May 02, 2019 8:44 am

Wusik X42 V1.0.0 Officially Released

May 2nd 2019 - V1.0.0 - Initial Windows Release.

The OSX version has been pushed to later this year, due to some technical problems. I don't know yet what kind of features it will have in terms of bridging older OSX plugins, as it may not be possible. It will have the MIDI Processors and Over Sampling options for when hosting VST2/VST3/AU plugins into VST2/VST3, but may not feature AU targets. You can contact me for details.

For more details visit the product page.
http://wwww.wusik.com/w/index.php/produ ... /wusik-x42

To purchase, visit the following link.
http://wwww.wusik.com/w/index.php/purch ... p131262298

Here's a 50% Discount Coupon, valid until next Monday (works on other products too).
X42PROMO

Cheers, WilliamK

rardier
KVRist
70 posts since 22 Feb, 2014

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Wed Jun 05, 2019 4:15 am

I ve bought it but it doesn't work (windows 10 , cubase 10 ) the GUI appears only 1 second then disappears, there's only a black box (which has the size of the GUI) with the Top Menu.

User avatar
WilliamK
KVRAF
4702 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Wed Jun 05, 2019 5:18 am

Hello, sorry for the problem, but this is a first, so I will need more info from you in order to resolve the issue. Also, please, always download the demonstration version before making a purchasing of any software. ;-)

Ok, so, the main Wusik X42 manager, you ran it and it allowed to scan for the plugins? So the problem is when you try to load a bridged plugin? Does the plugin run but just that the GUI won't show? Do you see in the taskbar the bridged application name and can you click on it to show the bridged plugin? That's how the bridge works, it opens a new application and in there you will see the original plugin and its GUI. So the black screen could be that Cubase won't allow me to make a copy of the new application GUI. That I can't do anything about. But if you click on the taskbar application name and it shows the bridged app interface, that should help you out.

Let me know if you can provide more information and even screenshots.

Cheers, WilliamK

0degree
KVRist
272 posts since 29 Jan, 2017

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Sat Jun 08, 2019 11:00 am

WilliamK wrote:
Wed Jun 05, 2019 5:18 am
Hello, sorry for the problem, but this is a first, so I will need more info from you in order to resolve the issue. Also, please, always download the demonstration version before making a purchasing of any software. ;-)

Ok, so, the main Wusik X42 manager, you ran it and it allowed to scan for the plugins? So the problem is when you try to load a bridged plugin? Does the plugin run but just that the GUI won't show? Do you see in the taskbar the bridged application name and can you click on it to show the bridged plugin? That's how the bridge works, it opens a new application and in there you will see the original plugin and its GUI. So the black screen could be that Cubase won't allow me to make a copy of the new application GUI. That I can't do anything about. But if you click on the taskbar application name and it shows the bridged app interface, that should help you out.

Let me know if you can provide more information and even screenshots.

Cheers, WilliamK
Hey William - just to let you know - most Waves plugins in version V9 and V10 (VST2) are not read by X42. I point the path to WaveShells and unfortunately they fail

User avatar
WilliamK
KVRAF
4702 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Sun Jun 09, 2019 5:40 am

Got it, maybe some copy protection stuff? :dog:

ben2012
KVRist
43 posts since 13 Aug, 2018

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Sun Jun 09, 2019 10:28 am

ben2012 wrote:
Mon Apr 22, 2019 12:33 am
I did a bit of research, apparently these are called shell-plugins and need some special handling, besides "instrument" and "effect":
https://stackoverflow.com/questions/112 ... lugin-dlls
I can't confirm it, but plugins from "Waves" seem also to use this category.
Hi William, Waves‘ plugins use this.

User avatar
WilliamK
KVRAF
4702 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Mon Jun 10, 2019 12:09 pm

Wusik X42

June 10 2019 - V1.0.2 (BETA04)

- Fixed problems with the interface closing by itself.
- Added a new option to the Options menu: Auto Bridged Window To Top - disabled by default. So the bridged window will only come to focus so you can edit it if you click on it first, if this option is selected it will bring the window to the top when you move the mouse over instead.
- Fixed a problem with Automation not working on some hosts.

Ah, will also update Wusik P2000 with those tomorrow or so. ;-) Just need to recompile it, and also Wusik SQ200.

As for the Waves plugins, not sure about those yet, will see in later on.

Cheers

User avatar
WilliamK
KVRAF
4702 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Mon Jun 10, 2019 1:57 pm

I just downloaded the Waves Central and added a Demo effect. Now I can't find where it installed, an no host can track it down. I did a search and found the DLL file at:

C:\Program Files (x86)\Waves\Plug-Ins V10\API-560.bundle\Contents\Win64\

I added that to each host search path, nothing. I can't believe on how hard is to install this bloody thing. :-( Any hints? Please?

Cheers, WilliamK

Return to “Instruments”