Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
WilliamK
KVRAF
4720 posts since 12 Jun, 2001 from Wusik Dot Com

Post Wed Jun 12, 2019 10:08 am

Nice, Vacuum won't allow me to test it AGAIN. As I have tested it months ago (I don't even remember). I hate those type of protections... protect a trial? Gesh... but that's just me, I guess... :oops: I will try and create another account to test.

Do you mind checking when Hybrid3 crashes like that? I tested here a bit and seems to work with a loop playback. Thanks again! :hug:

Megawattt
KVRist
125 posts since 31 Dec, 2005

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Wed Jun 12, 2019 10:38 am

WilliamK wrote:
Wed Jun 12, 2019 7:16 am
Wusik X42 New BETA

June 12 2019 - V1.0.2 (BETA06)

- Fixed problems with the interface closing by itself.
- Added a new option to the Options menu: Auto Bridged Window To Top - disabled by default. So the bridged window will only come to focus so you can edit it if you click on it first, if this option is selected it will bring the window to the top when you move the mouse over instead.
- Fixed a problem with Automation not working on some hosts.
- Added support to Shell Plugins (EG: Waves).
- Fixed some problems loading certain VST plugins.
Hi William.

Unfortunately i am still having the same problem using the updated version :(
Strictly drum and bass

0degree
KVRist
277 posts since 29 Jan, 2017

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Wed Jun 12, 2019 10:42 am

WilliamK wrote:
Wed Jun 12, 2019 10:08 am
Nice, Vacuum won't allow me to test it AGAIN. As I have tested it months ago (I don't even remember). I hate those type of protections... protect a trial? Gesh... but that's just me, I guess... :oops: I will try and create another account to test.

Do you mind checking when Hybrid3 crashes like that? I tested here a bit and seems to work with a loop playback. Thanks again! :hug:
Ahh yes, the limited trial :dog:
It fails immediately- I create an instance and then it freezes and generates infinite output

User avatar
WilliamK
KVRAF
4720 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Wed Jun 12, 2019 10:45 am

Just uploaded new file, fixed the filenames with / on it. Like Stereo/Mono converts to Stereo-Mono instead. It also removes any extra \ and any bad chars from the name.

User avatar
WilliamK
KVRAF
4720 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Wed Jun 12, 2019 10:46 am

I haven't test the Orion problem just yet.

User avatar
WilliamK
KVRAF
4720 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Wed Jun 12, 2019 10:47 am

I can't find Orion anymore on the Synapse site. :-o

https://www.synapse-audio.com/products.html

Was it discontinued? :dog:

Megawattt
KVRist
125 posts since 31 Dec, 2005

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Wed Jun 12, 2019 11:13 am

WilliamK wrote:
Wed Jun 12, 2019 10:47 am
I can't find Orion anymore on the Synapse site. :-o

https://www.synapse-audio.com/products.html

Was it discontinued? :dog:
Just a moment, i will send you a pm.
Strictly drum and bass

0degree
KVRist
277 posts since 29 Jan, 2017

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Wed Jun 12, 2019 11:32 am

WilliamK wrote:
Wed Jun 12, 2019 10:45 am
Just uploaded new file, fixed the filenames with / on it. Like Stereo/Mono converts to Stereo-Mono instead. It also removes any extra \ and any bad chars from the name.
Hey - now it's way better! Only few clash now, but it's fine as it is. There is one problem tough - you can open the for example API-560 plugin, the window appears but then when you close it it hangs.

User avatar
WilliamK
KVRAF
4720 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Wed Jun 12, 2019 11:44 am

Let me know the clashes you still have, so I can improve the code. :cool: I will test API-560 to see what's going on.

Cheers

User avatar
WilliamK
KVRAF
4720 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Wed Jun 12, 2019 12:03 pm

New file there. I fixed a problem with the GUI closing code. Hope it works now. Here it never froze, so I don't know what's really going on yet. :cry:

0degree
KVRist
277 posts since 29 Jan, 2017

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Wed Jun 12, 2019 12:37 pm

WilliamK wrote:
Wed Jun 12, 2019 12:03 pm
New file there. I fixed a problem with the GUI closing code. Hope it works now. Here it never froze, so I don't know what's really going on yet. :cry:
The newest version crashes immedietaly. I think I know why this those DLLs still conflict - you can have the same plugin in V9 and in V10. For example I have Hybrid Compressor in both versions and that's why generator still prompts for overwrite. The solution would be simple keep a kind of counter and append it to the end of file, for example:
1. H-Comp Stereo-1.dll
2. H-Comp Stereo-2.dll
etc

Megawattt
KVRist
125 posts since 31 Dec, 2005

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Wed Jun 12, 2019 7:41 pm

Good morning William.

I have sent you a pm :)
Strictly drum and bass

User avatar
WilliamK
KVRAF
4720 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Thu Jun 13, 2019 6:08 am

New file uploaded. I fixed something in the plugin's constructor, should not crash anymore. :dog:
I also improved the naming when it finds multiple files, it adds --1 --2 --3 to the filename. :cool:

User avatar
WilliamK
KVRAF
4720 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Thu Jun 13, 2019 6:09 am

And as for Orion, it turns out you must use 64 bits target otherwise it won't work. It doesn't read the 32 bits X42 plugins, only 64 bits ones. So in the main screen of the Wusik X42 Manager select 64 Bits as the target. That will do.

User avatar
WilliamK
KVRAF
4720 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Thu Jun 13, 2019 8:55 am

Also updated and uploaded Wusik P2000 :cool:

Return to “Instruments”