Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
WilliamK
KVRAF
4579 posts since 12 Jun, 2001 from Wusik Dot Com

Post Wed Apr 10, 2019 1:33 pm

Good news. Windows do allow processes to swap windows handles so it is possible for the bridged editor to go along with the original plugin editor. It's already working, I just want to clean the code a bit before I upload anything. Tomorrow for sure. :cool: A bit tired to continue right now... :oops: But it works great. The main plugin window steals the child process window and even if the secondary plugin process crashes it just closes the window and doesn't crash the main plugin. Nice! :cool:

ztrauq
KVRist
110 posts since 13 Dec, 2004 from USA

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Wed Apr 10, 2019 11:03 pm

Any idea on when the mac version will happen? There seem to be some conflicting statements about that (I got an email saying that the plugin is almost done, but so far it's windows only, the page for it on the wusik site says mac + windows). I primarily use a mac/Logic Pro X, and pre-ordered with the idea of having another tool to host VST/3/AU in hosts that otherwise don't support one or the other. So far the plugin looks really interesting and I like the idea of the additional MIDI processing alongside it, but I'd like to make sure that Mac support is still in the development plan.

User avatar
WilliamK
KVRAF
4579 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Thu Apr 11, 2019 4:32 am

Hello, yes, I will have the OSX version done in the next couple of days. Sorry for the delay on that. :oops: I always work on the Windows version first as it's my main OS.

Cheers, WilliamK

User avatar
WilliamK
KVRAF
4579 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Thu Apr 11, 2019 10:19 am

Some BAD news. The code I was using to allow windows to attach to the original host is far from good. And from the docs I read and input from other developers, it is not possible to do the way I'm doing. But I got some other ideas. The problem is that I will need to hold on all this until next week. Some personal stuff to take care of. Hope you all understand. :oops: :hug:

User avatar
WilliamK
KVRAF
4579 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Fri Apr 12, 2019 6:51 am

Apr 12 2019 - V1.0.0 BETA #042

- Improved the interface. There is a limitation here, as you move the mouse over the interface it will bring the original editor window to the top. But at least it now works more like it is embebed into the bridged editor. To check version number click the Wusik logo and About Box. Now it shows V1.0.0 but I will put something better as we get near the final stages of testing by the end of next week.

User avatar
WilliamK
KVRAF
4579 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Fri Apr 12, 2019 10:52 am

Wusik.com was down, but it's back now. :cool:

User avatar
WilliamK
KVRAF
4579 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Sat Apr 13, 2019 11:49 am

Ok, I'm back... what you guys think about the interface solution? To me, it makes total sense and works. So I'm sticking with it until we find a better solution. :hihi:

Also, if anyone knows any idea for other MIDI Processors, please, let me know. This can be added to Wusik X42, P2000 and SQ200 in one go. :-)

Cheers, WilliamK

ben2012
KVRist
41 posts since 13 Aug, 2018

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Sat Apr 13, 2019 12:35 pm

I have a strange scaling issue...
You do not have the required permissions to view the files attached to this post.

User avatar
WilliamK
KVRAF
4579 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Mon Apr 15, 2019 5:06 am

Wow, weird. :-o Does this happen on other vsts too? I will check out here if I figure something out...

garfield78
KVRist
61 posts since 11 Jun, 2013

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Mon Apr 15, 2019 5:12 am

Hi william , my compressor dtc-1 doesn't run with last version beta. :scared:

User avatar
WilliamK
KVRAF
4579 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Mon Apr 15, 2019 5:17 am

Pro-53: I can't reproduce it here, do you mind helping me out with some more details? This is Reaper, right? 64 bits? VST3 format from what I see, correct? Also, which version of Reaper? Anything else that could be different from my machine? I did find the Demonstration version of Pro53. Shows Demo 2002 but no version... Thanks for the help.

DCT-1: indeed, I just tried it here and it freezes. I will check out what's going on. :dog:

We are gettting there, soon it will run 100%. Thanks for all your help. :hug:

Cheers

User avatar
WilliamK
KVRAF
4579 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Mon Apr 15, 2019 5:18 am

DCT-1, are you using the VST2 or VST3 format?

Edit: I just tested again, both formats, and it runs here. So I will need to check why it freezes the first time. :cry:

ben2012
KVRist
41 posts since 13 Aug, 2018

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Mon Apr 15, 2019 5:23 am

WilliamK wrote:
Mon Apr 15, 2019 5:17 am
Pro-53: I can't reproduce it here, do you mind helping me out with some more details? This is Reaper, right? 64 bits? VST3 format from what I see, correct? Also, which version of Reaper? Anything else that could be different from my machine? I did find the Demonstration version of Pro53. Shows Demo 2002 but no version... Thanks for the help.

DCT-1: indeed, I just tried it here and it freezes. I will check out what's going on. :dog:

We are gettting there, soon it will run 100%. Thanks for all your help. :hug:

Cheers
Yes, Reaper x64, latest version (5.974 I think). It happens on every bridged plugin, both VST2 and VST3. I'm using Windows 10 at scaling 125%, maybe it has something to do with that. I can test it with scaling 100% later if it makes a difference.

garfield78
KVRist
61 posts since 11 Jun, 2013

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Mon Apr 15, 2019 6:25 am

William , for me vst2 or vst3 doesn't run , even a second or third time héhé, strange.I am under windows 10 64bits.

ben2012
KVRist
41 posts since 13 Aug, 2018

Re: Wusik X42 BETA (Windows only for now) - Instrument/Effect Bridge and more

Post Mon Apr 15, 2019 11:10 am

Yes, after changing the Windows 10-scaling to 100% the problem is gone and your overlay-trick works as expected!

Return to “Instruments”