Kawai K1 as VSTi - Nils' K1v is here

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
KVRAF
2874 posts since 13 May, 2004

Post Sat Dec 05, 2020 6:38 am

Teksonik wrote:
Sat Dec 05, 2020 6:23 am
moss wrote:
Sat Dec 05, 2020 3:35 am
No, the 5000 series also had a PCM section.
"Polyphony - 32 for the K5000S which has only the additive engine, and 64 for the K5000W which has the additive and PCM/GM engines",

http://www.vintagesynth.com/kawai/k5000.php

This seems to contradict the Vintage Synth article:

https://encyclotronic.com/synthesizers/ ... izer-r288/

This seems like a good price for a K5000S:

https://reverb.com/item/1816114-kawai-k ... eybed-ever
At least the manual of the K5000S says it can (see page 30):
https://www.deepsonic.ch/deep/docs_manu ... nual_2.pdf

User avatar
KVRAF
15508 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sat Dec 05, 2020 6:50 am

Oh ok I just seem to remember the K5000S being additive only but I can barely remember what I had for breakfast these days. :?
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
KVRAF
21710 posts since 7 Jan, 2009 from Croatia

Post Sat Dec 05, 2020 10:11 am

Any K5000 (S, W or R) had both additive and PCM modes for one of 6 parts of a patch. :)

KVRer
1 posts since 11 Jan, 2021

Post Mon Jan 11, 2021 10:53 am

Dear friends

I am new to KVR, and new to this whole softsynth thing, so please forgive me for asking dumb questions...

I think the K1V sound great!
So I thought I could retire my trusty K1 II. I tried to transfer the sounds via MIDI, but now I'm stuck.

I have not found out how to create a new, blank bank of sounds in the K1V, but that is only the lesser problem.

If I select Single IA-1 on my K1 and dump the block, the 32 sounds are transferred to the first page of bank "K1 Factory" in the K1V (which is not what I intended, I would prefer a fresh bank which I can save, but anyway...). Then I select Single iA-1 on my K1 and dump the block. Now, this goes to sounds iA-1 up to iC-3 on the K1V. iC-4 to iD-8 are not transferred.

I am sure I am doing something wrong, but can's figure out what it could be.

Any ideas?

KVRian
730 posts since 14 May, 2014

Post Fri Jan 15, 2021 12:18 pm

I adore this era of synthesis so much, so it's wonderful to see something freshly made!! very well done! :D

KVRist

Topic Starter

274 posts since 22 Oct, 2004 from Neuss, Germany

Post Thu Jan 28, 2021 2:20 pm

joerg721 wrote:
Mon Jan 11, 2021 10:53 am
If I select Single IA-1 on my K1 and dump the block, the 32 sounds are transferred to the first page of bank "K1 Factory" in the K1V (which is not what I intended, I would prefer a fresh bank which I can save, but anyway...). Then I select Single iA-1 on my K1 and dump the block. Now, this goes to sounds iA-1 up to iC-3 on the K1V. iC-4 to iD-8 are not transferred.
I'm going to take a look what could cause this. Meanwhile as a side note, I use Universal Manager most of the time to do patch exchange with my K1. If you are interested, grab it here.

https://www.nilsschneider.de/wp/2020/06 ... -15-years/

Some other updates:

I just released version 1.19 which fixes various issues that people have reported.
  • [Fix] Dropped midi events caused notes to be hanging or not played at all in some hosts
  • [Fix] Neither SysEx send nor receive worked in Mac AU version
  • [Fix] UI did not update if single parameter was changed via MIDI SysEx
  • [Fix] Pitch Bend changes were processed even if turned off in global settings
https://www.nilsschneider.de/wp/2021/01 ... -released/

And some fun stuff :D You can play around with K1v directly in a web browser. 8)

Would be nice to hear if it works, not all browsers support this.

https://www.nilsschneider.de/wp/2021/01 ... mscripten/
https://k1v.nilsschneider.de - Kawai K1 emulated as VSTi/AU
https://heatvst.com - Android Synthesizer with full VST integration
https://gpuimpulsereverb.de - Use your GPU as reverberation DSP

KVRAF
3075 posts since 18 May, 2003 from Sweden

Post Thu Jan 28, 2021 2:36 pm

Nils Schneider wrote:
Thu Jan 28, 2021 2:20 pm

And some fun stuff :D You can play around with K1v directly in a web browser. 8)

Would be nice to hear if it works, not all browsers support this.

https://www.nilsschneider.de/wp/2021/01 ... mscripten/
Works fine with Firefox 84.0.2 and Safari 14.0.1 in OS 10.14.6 Mojave!

Neat idea! :tu:
If it were easy, anybody could do it!

User avatar
KVRAF
1813 posts since 10 Apr, 2002 from Poissy, France

Post Thu Jan 28, 2021 2:45 pm

Nils Schneider wrote:
Thu Jan 28, 2021 2:20 pm
And some fun stuff :D You can play around with K1v directly in a web browser. 8)

Would be nice to hear if it works, not all browsers support this.

https://www.nilsschneider.de/wp/2021/01 ... mscripten/
Works fine in Chrome Version 88 with Win10
Image

User avatar
KVRian
726 posts since 14 Jul, 2018

Post Thu Jan 28, 2021 5:41 pm

Nils Schneider wrote:
Thu Jan 28, 2021 2:20 pm
And some fun stuff :D You can play around with K1v directly in a web browser. 8)
works fine on mac os x mojave, chrome (newest)
and safari

but i have to mouse-click on the keyboard
minidkeyboard (keystep) does not work...? at least not here...
can't find any midi settings...

User avatar
KVRian
726 posts since 14 Jul, 2018

Post Fri Jan 29, 2021 9:06 am

Nils Schneider wrote:
Thu Jan 28, 2021 2:20 pm
I just released version 1.19 which fixes various issues that people have reported.
does not work in logic 10.5.1 / macosx mojave
failed validation

can send validation report in case of interest

seems to work in hostingAU though

KVRist

Topic Starter

274 posts since 22 Oct, 2004 from Neuss, Germany

Post Fri Jan 29, 2021 9:37 am

muki wrote:
Fri Jan 29, 2021 9:06 am
does not work in logic 10.5.1 / macosx mojave
failed validation

can send validation report in case of interest

seems to work in hostingAU though
I had to google what it even means :D Having the report would be very nice indeed => PN
https://k1v.nilsschneider.de - Kawai K1 emulated as VSTi/AU
https://heatvst.com - Android Synthesizer with full VST integration
https://gpuimpulsereverb.de - Use your GPU as reverberation DSP

KVRAF
3075 posts since 18 May, 2003 from Sweden

Post Fri Jan 29, 2021 9:45 am

This is the problem in Logic:
--------------------------------------------------
FORMAT TESTS:

Reported Channel Capabilities (explicit):
[0, 2] [2, 2] [0, 8] [2, 8]

Input/Output Channel Handling:
1-1 1-2 1-4 1-5 1-6 1-7 1-8 2-2 2-4 2-5 2-6 2-7 2-8 4-4 4-5 5-5 6-6 7-7 8-8
X X
Initialize@125: Setting samplerate to 44100
CanScheduleParameters@458: AU: CanScheduleParameters
Cleanup@139: Cleanup
ERROR: -10868 IN CALL Cannot Set Output Num Channels:8 when unit says it can
Initialize@125: Setting samplerate to 44100
CanScheduleParameters@458: AU: CanScheduleParameters

WARNING: Source AU supports multi-channel output but does not provide a channel layout

* * FAIL
--------------------------------------------------
AU VALIDATION FAILED: CORRECT THE ERRORS ABOVE.
--------------------------------------------------
If it were easy, anybody could do it!

KVRist

Topic Starter

274 posts since 22 Oct, 2004 from Neuss, Germany

Post Fri Jan 29, 2021 10:17 am

Ouch, hidden feature exposed here. :D

I figured out that this validation tool is available on every mac. I fixed it and now all tests pass. I'll release an update shortly.
https://k1v.nilsschneider.de - Kawai K1 emulated as VSTi/AU
https://heatvst.com - Android Synthesizer with full VST integration
https://gpuimpulsereverb.de - Use your GPU as reverberation DSP

KVRist

Topic Starter

274 posts since 22 Oct, 2004 from Neuss, Germany

Post Fri Jan 29, 2021 10:50 am

Version 1.20 is now online which fixes the AU validation issue in logic, thanks for reporting!
https://k1v.nilsschneider.de - Kawai K1 emulated as VSTi/AU
https://heatvst.com - Android Synthesizer with full VST integration
https://gpuimpulsereverb.de - Use your GPU as reverberation DSP

User avatar
KVRian
726 posts since 14 Jul, 2018

Post Fri Jan 29, 2021 11:05 am

yesss!
thank nils!

just sent you the, now outdated, validation-text in re v1.19 -> please disregard ;-)

thanks very much!
the new version is working well in logic

Return to “Instruments”