Tal J-8

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
KVRAF
7208 posts since 7 Oct, 2005 from Auckland, NZ

Post Mon Mar 22, 2021 4:24 pm

btfnk wrote:
Mon Mar 22, 2021 3:54 pm
Anyone else have issues with the next preset > button? Using J8 in Ableton 10 and when I press the next button Ableton completely locks up and I have to force quit. I had this happen on earlier versions then 1.3.9 fixed it, now it's back broken again in 1.4
I don't have such problem in Live 11 nor Bitwig Studio 3.3.4 if that helps.

User avatar
KVRAF
2072 posts since 4 Dec, 2011 from Brasília, Brazil

Post Mon Mar 22, 2021 4:34 pm

to be honest, I always had issues next and previous buttons, using the VST3 version. Ableton 10 on Mac OS Catalina (10.15.7)

KVRist
44 posts since 8 Jan, 2009 from Los Angeles

Post Mon Mar 22, 2021 5:00 pm

Ahh that might be it. It's possible I was using a different plugin type. I have VST, VST3 and AU all enabled in Ableton. Thanks for the tip. I'll check on that.

KVRist
249 posts since 12 May, 2004

Post Mon Mar 22, 2021 8:31 pm

1.4.0 released.
On a number of Macs

User avatar
KVRAF

Topic Starter

10127 posts since 16 Feb, 2005 from Kingston, Jamaica

Post Tue Mar 23, 2021 4:35 am

zvenx wrote:
Mon Mar 22, 2021 8:47 am
Ahhh.. That does make sense. let me test that.
Thanks
rsp

edit: yep. that is what it seems to do indeed.
thanks
rsp

After speaking with Patrick I had it wrong.
Firstly I wrongly assumed Panel enabled needs Midi Learn enabled to function.

But Indeed All Panel does is that when Enabled, it makes whatever MidiLearn was created for that patch (it is per patch), apply to whichever the active/visible Panel is currently selected.

So for instance, it seems like the Default patch was set with Midi CC 21 set to Upper Panel Cut off Frequency and CC 22 to Upper Panel Resonance.

If one switches to Lower Panel, these midi cc do not change the lower panel cut off frequency or resonance, unless, one selects the Panel Button then it does.

Hope that makes sense.
rsp
sound sculptist

KVRAF
8574 posts since 16 Aug, 2006

Post Tue Mar 23, 2021 8:08 am

zvenx wrote:
Tue Mar 23, 2021 4:35 am
But Indeed All Panel does is that when Enabled, it makes whatever MidiLearn was created for that patch (it is per patch), apply to whichever the active/visible Panel is currently selected.
Oh ok, that's what I assumed it did. Just took the current learn assignments and applied to whichever panel was active. Sort of like how your Jupiter-8 had two "panels" but only one set of physical controls.

I do wish, as an aside, that all his products had Global MIDI learn. But that's what the lock is for I guess. Still, it trips me up every now and then. I have to save a default preset with the MIDI learn assignment I want, then remember to enable the MIDI lock.

Maybe the feature request I want is a Global "MIDI Lock" preference added to the menu. This way, I can keep the lock on permanently.

User avatar
KVRAF

Topic Starter

10127 posts since 16 Feb, 2005 from Kingston, Jamaica

Post Tue Mar 23, 2021 8:14 am

100% with you on that one too.
(I also would love the same for a SC too)
All optional of course.
rsp
sound sculptist

KVRAF
8574 posts since 16 Aug, 2006

Post Thu Mar 25, 2021 6:20 am

Version 1.4.1
Skips presets when using arrow buttons in some hosts fixed.
Minor bug fixes.
UI refresh.

User avatar
KVRAF
2072 posts since 4 Dec, 2011 from Brasília, Brazil

Post Thu Mar 25, 2021 8:21 am

BTW, it seems that all the TAL plugins that use the arrow button (all of them?) were update to fix the skip presets in some hosts :)

User avatar
KVRAF

Topic Starter

10127 posts since 16 Feb, 2005 from Kingston, Jamaica

Post Thu Mar 25, 2021 8:25 am

Does tal-mod? Didnt see an update for that one yet.
rsp
sound sculptist

User avatar
KVRAF
2072 posts since 4 Dec, 2011 from Brasília, Brazil

Post Thu Mar 25, 2021 8:33 am

zvenx wrote:
Thu Mar 25, 2021 8:25 am
Does tal-mod? Didnt see an update for that one yet.
rsp
not yet - maybe it doesn't have the bug or he is still updating :) But I have seen the fix for Uno LX and Bassline-101

User avatar
KVRAF

Topic Starter

10127 posts since 16 Feb, 2005 from Kingston, Jamaica

Post Thu Mar 25, 2021 8:52 am

Indeed and there was a tal sampler update I downloaded yesterday.
Rsp
sound sculptist

User avatar
KVRist
120 posts since 24 Jan, 2021

Post Thu Mar 25, 2021 9:19 am

The changelog for J-8 also mentions a "UI refresh." I don't see any changes to the main controls, but some of the other buttons are now drawn differently, and the ones that are actually popup menus now have little arrows on the side.

I've attached a quick screenshot for comparison.
j8sidebyside.png
You do not have the required permissions to view the files attached to this post.
I hate signatures too.

KVRian
811 posts since 23 May, 2016

Post Thu Mar 25, 2021 9:58 am

Looks like a different color in the background

User avatar
KVRist
120 posts since 24 Jan, 2021

Post Thu Mar 25, 2021 10:38 am

dermage wrote:
Thu Mar 25, 2021 9:58 am
Looks like a different color in the background
Ah, you're right. I noticed the slight color differences and bolder lines on some of the widgets, but chalked it up to image compression and display DPI differences. Now that I've actually installed 1.4.1, I can see that all the graphics are slightly different. Should be a little more readable on low-DPI displays.
I hate signatures too.

Return to “Instruments”