RAPID Synthesizer | 1.8.5 Released | Chorus X, Vintagizer and more

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
KVRist
38 posts since 10 Oct, 2020

Post Sat Jan 30, 2021 5:04 am

I think it is just the way scripts and remote mappings work in Bitwig - I use the Moss Flexi script and for spare knobs to map to anything in Rapid how you want I would have to map the knob first as a midi CC in the Flexi script. If I plug it in as just a generic midi controller not using a script it will map straight away the way you want in Rapid.

One bug I seem to have in latest version of Rapid is I cant turn off tooltips..

KVRer
5 posts since 7 Mar, 2021

Post Sun Mar 07, 2021 3:27 am

Jkist wrote:
Mon Jan 04, 2021 2:20 pm
I absolutely love Rapid, but I have an issue that I have written support about multiple times, and I have yet to receive an answer of any kind.

Basically the keys will randomly stick at the buffer sizes that I run (128 and 256). If I run a really high buffer size, the problem seems to go away. But no other plugin I own exhibits this sort of behavior, and I don't want to have to run a really laggy feeling buffer size just for Rapid. Anybody else experiencing this issue?
Yes. :( I get this too. Note on/off events get missed. It's worse with sequences of short notes (e.g. 16ths). ASIO buffer size makes a difference to how frequently it happens, but it happens eventually on all sizes, with three different audio interfaces. I haven't had it happen with the Windows MME/Direct X audio option in Ableton Live 10/11, but that's not viable for obvious reasons.

KVRist
82 posts since 6 May, 2017

Post Fri Mar 19, 2021 5:14 am

Bumping for news on 1.9.

KVRAF
7665 posts since 2 Dec, 2004 from North Wales

Post Fri Mar 19, 2021 6:21 am

Just as a reminder :D

1.9.0 Roadmap

Freeform MSEG sequences.
Custom mapping curves for routing entries.
Copy/Paste/Save/Load effect stacks.
Undo/Redo.
Quick Import.
PC, Studio One, BWS, Live, FL Studio, Renoise, Reason, X32 Desk, Hardware Synths, Drum Machines + Eurorack, TD27 V Drums, Guitars & Basses

User avatar
KVRian
1424 posts since 25 Apr, 2009 from France

Post Fri Mar 19, 2021 10:00 am

I’m really waiting for new expansions. ^^
This post is supposed to be non-agressive. Now please give me a broad smile. :ud:

User avatar
KVRist
160 posts since 3 Dec, 2019

Post Fri Mar 19, 2021 10:56 pm

DJErmac wrote:
Fri Mar 19, 2021 10:00 am
I’m really waiting for new expansions. ^^
I've been working on quite a few presets, maybe not your thing, but here's a stream I did today really digging into the arpeggiator and making more presets

https://www.youtube.com/watch?v=cseFIoe_Vio
I do experimental sound design and demos of plugins (no talking) on my youtube: https://www.youtube.com/databroth

I also sell presets/lfos/ and wavetabls on gumroad https://gumroad.com/databroth

User avatar
KVRist
117 posts since 17 Sep, 2019

Post Sat Mar 20, 2021 12:24 am

databroth wrote:
Fri Mar 19, 2021 10:56 pm
DJErmac wrote:
Fri Mar 19, 2021 10:00 am
I’m really waiting for new expansions. ^^
I've been working on quite a few presets, maybe not your thing, but here's a stream I did today really digging into the arpeggiator and making more presets

https://www.youtube.com/watch?v=cseFIoe_Vio
i damn love this kind of experimentation! Well done. :)

KVRian
1370 posts since 18 Feb, 2012

Post Sat Mar 20, 2021 1:47 am

I am really waiting for msegs...for me thats no 1 priority! :)

User avatar
KVRian
1424 posts since 25 Apr, 2009 from France

Post Sat Mar 20, 2021 10:05 am

databroth wrote:
Fri Mar 19, 2021 10:56 pm
DJErmac wrote:
Fri Mar 19, 2021 10:00 am
I’m really waiting for new expansions. ^^
I've been working on quite a few presets, maybe not your thing, but here's a stream I did today really digging into the arpeggiator and making more presets

https://www.youtube.com/watch?v=cseFIoe_Vio
Excellent work !!
This post is supposed to be non-agressive. Now please give me a broad smile. :ud:

User avatar
KVRist
160 posts since 3 Dec, 2019

Post Sat Mar 20, 2021 10:43 am

hey thank you Xbucket and Djermac

I do a lot of these streams, is this something I should be sharing on KVR more often?
I do experimental sound design and demos of plugins (no talking) on my youtube: https://www.youtube.com/databroth

I also sell presets/lfos/ and wavetabls on gumroad https://gumroad.com/databroth

User avatar
KVRian
1424 posts since 25 Apr, 2009 from France

Post Sat Mar 20, 2021 12:00 pm

For sure, and you should compile and sell your presets !
This post is supposed to be non-agressive. Now please give me a broad smile. :ud:

User avatar
KVRist
160 posts since 3 Dec, 2019

Post Sat Mar 20, 2021 2:28 pm

DJErmac wrote:
Sat Mar 20, 2021 12:00 pm
For sure, and you should compile and sell your presets !
I do, I'm working on a rapid pack right now, but I have presets on my gumroad
and loads of wavetables
I do experimental sound design and demos of plugins (no talking) on my youtube: https://www.youtube.com/databroth

I also sell presets/lfos/ and wavetabls on gumroad https://gumroad.com/databroth

KVRist
37 posts since 15 Jan, 2019

Post Sun Mar 21, 2021 7:00 pm

Parawave are you ever going to support license transfers? I ended up not using Rapid much and would like to sell it to someone who actually makes use of it.

KVRist
189 posts since 27 Sep, 2004

Post Fri Apr 16, 2021 1:01 am

Does someone know a way to freeze the reverb inside Rapid instrument / Rapid FX plugin?

KVRer
4 posts since 30 Mar, 2008

Post Tue Apr 27, 2021 12:43 am

Hi,

At the beginning I want to say that I absolutely love Rapid. The sound and the capabilities are really tremendous.
I have however one issue that is really bothering me. From time to time I have some random short clicks/crackle that occur especially when mangling with parameters during playback for example: adjusting the reverb decay (I can procure it intentionally when I push the decay way up) or filter adjustment, changing the intensity of grains or sometimes even at wave morphing or envelope change. It is nothing deal breaking but it is sometimes annoying.

Can anyone tell me if you occur anything similar? I have made all the necessary hardware and windows optimization. The CPU (ryzen 3900X) does not go higher than 2-3% with no spikes, no drops according to latency mon, nothing. These occasional clicks are there however even at 512 buffer. Considering the intensity of math inside Rapid I hope this is a normal behaviour and should not worry about it.

Would be grateful for some feedback from you.

Best Regards,
Sebastian

Return to “Instruments”