E-Phonic Invader 2 v1.0.8 next (WIN / OSX)

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
KVRian

Topic Starter

639 posts since 16 Sep, 2002 from Amsterdam, the Netherlands

Post Tue May 18, 2021 9:02 am

teacue wrote:
Tue May 18, 2021 1:36 am
What a great synth!
The presets are also very well made.
Bought :-)

@ e-phonic
Unfortunately the beta version crashes Cubase as soon as I try to close the gui (latest version of Windows 10 and Cubase Pro 11)
I have already send a report at info@e-phonic.com with my specs
I just installed the Cubase 11 Elements demo (win) and the 'Steinberg VST3 Plugin Test Host' and cannot reproduce the issue you are reporting.
Can anyone using Cubase 11 confirm this crash? It would be nice to tackle this issue for the next release.

KVRAF
8570 posts since 16 Aug, 2006

Post Tue May 18, 2021 10:10 am

e-phonic wrote:
Tue May 18, 2021 9:02 am
teacue wrote:
Tue May 18, 2021 1:36 am
What a great synth!
The presets are also very well made.
Bought :-)

@ e-phonic
Unfortunately the beta version crashes Cubase as soon as I try to close the gui (latest version of Windows 10 and Cubase Pro 11)
I have already send a report at info@e-phonic.com with my specs
I just installed the Cubase 11 Elements demo (win) and the 'Steinberg VST3 Plugin Test Host' and cannot reproduce the issue you are reporting.
Can anyone using Cubase 11 confirm this crash? It would be nice to tackle this issue for the next release.
Just checked Cubase 10.5 Pro on Windows and it was fine here too.

KVRian
608 posts since 22 Jun, 2003 from Germany

Post Tue May 18, 2021 11:30 am

e-phonic wrote:
Tue May 18, 2021 9:02 am
teacue wrote:
Tue May 18, 2021 1:36 am
What a great synth!
The presets are also very well made.
Bought :-)

@ e-phonic
Unfortunately the beta version crashes Cubase as soon as I try to close the gui (latest version of Windows 10 and Cubase Pro 11)
I have already send a report at info@e-phonic.com with my specs
I just installed the Cubase 11 Elements demo (win) and the 'Steinberg VST3 Plugin Test Host' and cannot reproduce the issue you are reporting.
Can anyone using Cubase 11 confirm this crash? It would be nice to tackle this issue for the next release.
After reading your post I tried again.
I get the same result :-(

For anyone willing to try these are the steps I do on my system:
1. Open Cubase 11
2. Create a new project
3. Open an instance of Invader (with F11)
4. Open the gui of Invader (if it's not already open)
5. Close the gui of invader: the gui does not close and Cubase freezes
It can only be closed through the Windows Task Manager

I do not use Cubase 10.5 but Cubase 11
Unfortunately Cubase does not write a crash dump after it freezes in this particular case
So I don't know where I could look.
Also I have no other plugin in use in Cubase when I create a new project
teacuemusic (Musicals)
youtube

KVRian

Topic Starter

639 posts since 16 Sep, 2002 from Amsterdam, the Netherlands

Post Tue May 18, 2021 11:49 am

I would expect Cubase 11 Elements to have the same behaviour as the full Cubase 11 version. It all seems to work fine here, even when using UI scaling modes.
Can anyone else with Cubase 11 try this to confirm this is an issue?

KVRian
608 posts since 22 Jun, 2003 from Germany

Post Tue May 18, 2021 12:07 pm

e-phonic wrote:
Tue May 18, 2021 11:49 am
I would expect Cubase 11 Elements to have the same behaviour as the full Cubase 11 version. It all seems to work fine here, even when using UI scaling modes.
Can anyone else with Cubase 11 try this to confirm this is an issue?
In the meantime I was able to create a crash dump with the Microsoft utility "ProcDump64"
https://docs.microsoft.com/en-us/sysint ... s/procdump

I have tried to send you the crash dump but as the file is 70MB the e-mail has been rejected.
Do you have any interest in this Crash Dump and if yes where can I send it?
teacuemusic (Musicals)
youtube

User avatar
KVRAF
3247 posts since 22 Aug, 2019

Post Tue May 18, 2021 12:57 pm

Closing the GUI in Reaper works fine, no crash or anything.

KVRian

Topic Starter

639 posts since 16 Sep, 2002 from Amsterdam, the Netherlands

Post Thu May 20, 2021 9:19 am

UPDATE v1.0.4
  • OSX VST3 version now available
  • Change: parameter behaviour updated
    • Osc freq and tuning now steps semitones when alt / option is pressed
    • Osc freq, mod and tuning sliders now have linear response.
    • Mod amount sliders gearing is a bit less sensitive for easier control
    • Parameters now show the correct values when used in automation
    • Parameters now have better compatibility for future updates.
    • All patches are converted to new format.
    For songs created with older versions of Invader, small differences in sound may be noticeable. Please use Invader v1.0.3 for full compatibility.
    Old .ivp patches are converted automatically to the new format on load. Please re-save your patches to retain compatibility for future releases.
  • Change: prev / next preset can now be controlled with keyboard up / down or left / right
  • Changed plugin name to Invader 2
  • Informative tooltips for 'Mod Amount' and 'Mod Source' have been removed.
  • Delay mix value tooltip added

https://www.e-phonic.com/invader.html

User avatar
KVRAF
3247 posts since 22 Aug, 2019

Post Thu May 20, 2021 9:59 am

Thanks :)

A question: I just moved my presets folder from the desktop (my old 1.02 demo version folder) to the final folder, so the plugin did not find them, but not show the Select Preset Folder link either. How do I tell the plugin where I moved the folder?

KVRian

Topic Starter

639 posts since 16 Sep, 2002 from Amsterdam, the Netherlands

Post Thu May 20, 2021 10:23 am

In the menu -> Select preset folder :-)

User avatar
KVRAF
3247 posts since 22 Aug, 2019

Post Thu May 20, 2021 10:31 am

Oh, there it was hiding :)

And the synth does only allow one folder level within Presets, right?
I noticed that a Bass sub-folder I created within my own User Patches folder is not shown in the browser...

KVRian

Topic Starter

639 posts since 16 Sep, 2002 from Amsterdam, the Netherlands

Post Thu May 20, 2021 10:45 am

Yes, it scans one level in the main folder atm.

KVRAF
8570 posts since 16 Aug, 2006

Post Thu May 20, 2021 2:43 pm

Anything that can be done to resolve this?

Image

Using Reaper's Learn functionality to MIDI Learn the [stepped] controls on my Roland System-8.

If I assign that same knob to Unison Voices, I don't get any weird scrolling behavior like above. So I'm hoping a similar approach can be taken for the other graphical elements.

KVRian

Topic Starter

639 posts since 16 Sep, 2002 from Amsterdam, the Netherlands

Post Thu May 20, 2021 9:14 pm

Funkybot's Evil Twin wrote:
Thu May 20, 2021 2:43 pm
Anything that can be done to resolve this?
Yes, I can reproduce the issue now. I will look in to it for next release.

ksn
KVRist
184 posts since 12 Mar, 2002

Post Fri May 21, 2021 4:50 am

e-phonic wrote:
Thu May 20, 2021 9:19 am
UPDATE v1.0.4
  • OSX VST3 version now available
:party: Thank you! Let the fun begin

KVRAF
8570 posts since 16 Aug, 2006

Post Fri May 21, 2021 7:20 am

e-phonic wrote:
Thu May 20, 2021 9:14 pm
Funkybot's Evil Twin wrote:
Thu May 20, 2021 2:43 pm
Anything that can be done to resolve this?
Yes, I can reproduce the issue now. I will look in to it for next release.
Great news. Thanks! And thanks for incorporating so many of the suggestions to date. Sometimes little things like Alt to snap to semi-tones and arrow keys to navigate through presets make a big difference. Much appreciated! :tu:

Return to “Instruments”