Plogue OPS7 (bit-accurate DX7 emulation!)

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
pdxindy
KVRAF
20894 posts since 3 Feb, 2005 from in the wilds

Post Mon Sep 27, 2021 6:56 am

davidv@plogue wrote:
Mon Sep 27, 2021 5:56 am
briefcasemanx wrote:
Mon Sep 27, 2021 5:52 am
Personally I think that's completely fine.
The thing I'm hesitating on is to add a volume level to it. I would match the noise precisely against the device by default and you can turn it off or on for the units I have.
If the point is to be accurate, there is no need for a volume level.

If someone wants to play with noise, it is easy enough to layer whatever noise at whatever level one wants.

davidv@plogue
KVRian
809 posts since 3 Aug, 2001 from Montreal

Post Mon Sep 27, 2021 6:58 am

benedettodue wrote:
Mon Sep 27, 2021 6:49 am
In DX7II in addition to performance Mode, have been added 3 new Voice parameters : Range in Pitch Envelope (6 semitone to 8 octave) which is used in numerous new presets (brass, trumpet,..), LFO Mode = Multi (16 LFO, one for voices) and Unison Key mode .
It would be nice to see a version 1.5 of the software with at least the 3 new voice issues :-)
Sure, but there is more to DX7II's than a few firmware/sysex addition. They use the separate EGM/OPSII chips. You know us, we would need to do all that work again to make sure everything is 100% is right. Its not a trivial thing. Much easier to add DX1/DX5 perf as they use the same hardware.
David Viens, Plogue Art et Technologie Inc. Montreal.
https://twitter.com/plgDavid
https://plogue.com

abernathy
KVRist
326 posts since 15 Oct, 2001 from Santa Fe, NM

Post Mon Sep 27, 2021 7:19 am

It's interesting that everyone is talking about all these advanced feature additions and all I want is to be able to save presets...! :wink:

I just tried to save user presets on my 2nd Mac and the very first one I tried to save didn't work. It has the same "- Init -" name issue. I can't believe other users aren't mentioning this bug. Is it unique to macOS Big Sur? I can't really use OPS7 at this point.

Cochrane
KVRist
105 posts since 5 Oct, 2001

Post Mon Sep 27, 2021 7:28 am

davidv@plogue wrote:
Mon Sep 27, 2021 6:58 am
Much easier to add DX1/DX5 perf as they use the same hardware.
It would be awesome having direct DX1/DX5 performances support! In that case, it maybe could be useful having a (global?) switch to increase overall polyphony to 32 voices.

davidv@plogue
KVRian
809 posts since 3 Aug, 2001 from Montreal

Post Mon Sep 27, 2021 7:35 am

abernathy wrote:
Mon Sep 27, 2021 7:19 am
It's interesting that everyone is talking about all these advanced feature additions and all I want is to be able to save presets...! :wink:

I just tried to save user presets on my 2nd Mac and the very first one I tried to save didn't work. It has the same "- Init -" name issue. I can't believe other users aren't mentioning this bug. Is it unique to macOS Big Sur? I can't really use OPS7 at this point.
We _cannot_ reproduce this issue. Its madening.
David Viens, Plogue Art et Technologie Inc. Montreal.
https://twitter.com/plgDavid
https://plogue.com

User avatar
teilo
KVRian
1100 posts since 30 Mar, 2008 from MN, USA

Post Mon Sep 27, 2021 7:37 am

abernathy wrote:
Mon Sep 27, 2021 7:19 am
It's interesting that everyone is talking about all these advanced feature additions and all I want is to be able to save presets...! :wink:

I just tried to save user presets on my 2nd Mac and the very first one I tried to save didn't work. It has the same "- Init -" name issue. I can't believe other users aren't mentioning this bug. Is it unique to macOS Big Sur? I can't really use OPS7 at this point.
I'm on Big Sur. No such issue here. I start with Init. Do some editing. Save, and I get a Save As dialog, type a filename, and it saves. File name is the patch name, and it shows up in the User folder.

abernathy
KVRist
326 posts since 15 Oct, 2001 from Santa Fe, NM

Post Mon Sep 27, 2021 7:51 am

davidv@plogue wrote:
Mon Sep 27, 2021 7:35 am
abernathy wrote:
Mon Sep 27, 2021 7:19 am
It's interesting that everyone is talking about all these advanced feature additions and all I want is to be able to save presets...! :wink:

I just tried to save user presets on my 2nd Mac and the very first one I tried to save didn't work. It has the same "- Init -" name issue. I can't believe other users aren't mentioning this bug. Is it unique to macOS Big Sur? I can't really use OPS7 at this point.
We _cannot_ reproduce this issue. Its madening.
When I move what appears to be a corrupt preset to another computer it has the same problem. Would it help to send you the preset to look at? But honestly if I'm the only one having this issue I wouldn't worry about it.

davidv@plogue
KVRian
809 posts since 3 Aug, 2001 from Montreal

Post Mon Sep 27, 2021 8:12 am

yes please send those, or attach a compressed version of your preset folder here?
/Users/YOU/Library/Application Support/Plogue/Fermata/Presets/com.Plogue.Fermata.chipsynth OPS7
David Viens, Plogue Art et Technologie Inc. Montreal.
https://twitter.com/plgDavid
https://plogue.com

User avatar
waltercruz
KVRAF
2143 posts since 4 Dec, 2011 from Brasília, Brazil

Post Mon Sep 27, 2021 8:16 am

davidv@plogue wrote:
Mon Sep 27, 2021 6:58 am
Much easier to add DX1/DX5 perf as they use the same hardware.
It's a nice idea too :)

abernathy
KVRist
326 posts since 15 Oct, 2001 from Santa Fe, NM

Post Mon Sep 27, 2021 8:40 am

davidv@plogue wrote:
Mon Sep 27, 2021 8:12 am
yes please send those, or attach a compressed version of your preset folder here?
/Users/YOU/Library/Application Support/Plogue/Fermata/Presets/com.Plogue.Fermata.chipsynth OPS7
Here you go. Thanks.
You do not have the required permissions to view the files attached to this post.

btfnk
KVRist
56 posts since 8 Jan, 2009 from Los Angeles

Post Mon Sep 27, 2021 8:44 am

Regarding the noise, I think using a sample for something like this is totally fine, it could even be preferable. I would definitely want a volume adjustment with a full off and a setting to match the noise of the original unit. Totally fine with me if it defaults to off with no noise to satisfy those who think this is silly.

davidv@plogue
KVRian
809 posts since 3 Aug, 2001 from Montreal

Post Mon Sep 27, 2021 10:05 am

abernathy wrote:
Mon Sep 27, 2021 8:40 am
Here you go. Thanks.
OK! Thank you I think we found the issue. The preset box seems to save the info regarding the GUI preset name state. It shouldn't, Its a bug. (only the session recall, or save-as-default should) Will be fixed in next release. Please be patient as there are a lot of things to retest. Even though we had a long beta period, so many more people are using it than we ever had. (Not complaining), but means more issues need addressing.

Thank you all!
David Viens, Plogue Art et Technologie Inc. Montreal.
https://twitter.com/plgDavid
https://plogue.com

abernathy
KVRist
326 posts since 15 Oct, 2001 from Santa Fe, NM

Post Mon Sep 27, 2021 10:47 am

davidv@plogue wrote:
Mon Sep 27, 2021 10:05 am
abernathy wrote:
Mon Sep 27, 2021 8:40 am
Here you go. Thanks.
OK! Thank you I think we found the issue. The preset box seems to save the info regarding the GUI preset name state. It shouldn't, Its a bug. (only the session recall, or save-as-default should) Will be fixed in next release. Please be patient as there are a lot of things to retest. Even though we had a long beta period, so many more people are using it than we ever had. (Not complaining), but means more issues need addressing.

Thank you all!
Glad you found the issue! Looking forward to the update.

ukm
KVRist
93 posts since 28 Sep, 2002 from Germany

Post Mon Sep 27, 2021 11:10 am

This is the first time a software instruments feels and sounds like I had it in mind with a DX 7.
All the others I bought or tried left me alone with frustating attemps of creating the sound and are now liing around on the harddisc.

User avatar
foosnark
KVRAF
6027 posts since 9 Jan, 2003 from Saint Louis MO

Post Mon Sep 27, 2021 11:38 am

digitallysane wrote:
Sun Sep 26, 2021 8:53 am
The DX7 Bible
https://archive.org/details/thecompletedx7
Thanks for sharing that -- DX7 envelopes always have baffled me, including in FM8, but now they at least make a little sense. Still weird and unintuitive in some ways, but not a total mystery :tu:

Maybe someday I will learn the YM2612 SSG envelope stuff. Yamaha was really not afraid of confusing people in the 80s :lol:

Return to “Instruments”