Mac OS X 10.4 compatibility

Official support for: loomer.co.uk
KVRAF
2239 posts since 25 Aug, 2003 from Bournemouth, UK

Post Tue Feb 26, 2013 7:34 am

With Mac OS X 10.9 lurking on the horizon, I'm afraid the time has come to stop compatibility with Mac OS X 10.4.

Apple's development tools make it, at best, difficult to produce plug-ins which run on all flavours of Mac OS X. Recent framework updates have tipped this balance, now making it nigh-on impossible for us to produce plug-ins which run on everything from Mac OS X 10.4 to Mac OS X 10.8 (and theoretically, beyond). It makes no sense to limit features available to the broader group of Mac OS X 10.8+ users, in lieu of the one or two who still use Mac OS X 10.4.

I intend to make this as painless as possible for Mac OS X 10.4 users:
  • A final round of Mac OS X 10.4 compatible updates will be released which will fix those last minor outstanding host specific bugs, as well as ensuring support in all plug-ins for the most requested feature: inline editing of parameters.
  • These releases will always be available to registered users, on request.
  • PPC based architecture will still be supported for Mac OS X 10.5 users. Anyone still on Mac OS X 10.4 can upgrade if they want to keep receiving updates.
  • We'll continue support for users with plug-ins running on Mac OS X 10.4. If you have issues or problems, the support lines are still open.
  • Any further bugs which turn-up in these Mac OS X 10.4 compatible releases will be considered for fixes. I can't make any firm guarantees or promises, but in the unlikely event of some show-stopping bugs I will do what I can to ensure you can still use your plug-ins.
If anyone has any thoughts or concerns about this change, by all means let me know. Thanks!
Architect, the modular MIDI toolkit, beta now available for macOS, Windows, and Linux.

Return to “Loomer”