Architect beta 0.9 64bit standalone crashing after setting vst path

Official support for: loomer.co.uk
User avatar
Beware the Quoth
29290 posts since 4 Sep, 2001 from R'lyeh Oceanic Amusement Park and Funfair

Post Thu Jan 03, 2019 4:45 am

ThomasHelzle wrote:
Wed Jan 02, 2019 8:17 am
Found it, thanks!
The blacklist file seems only to exist very shortly while the Architect is scanning.
Yeah, the blacklist file actually seems to be the 'currently being checked file' ; something that persists if the plugin crashes Architect.

Anyways; reporting on VST scanning on 0.92

Better feedback and options, and sanity for not wiping the list accidently. Feels a bit more responsive on the shorter scans, probably because of the feedback. Still a bit 'is it still on' on long ones though. But then thats hundreds of plugins in my case.

Still not coping that well with jbridge'd plugins. I did manage to get one parsed yesterday though, by (luckily) hitting the 'OK' on the dialog almost instantly, and Ive managed the same today a couple of times. Longer timeout needed?

The plugin sorting options are much better to have, but its still not quite there , IMO. Location sorting is best for me, but the nesting is out, a bit like Tracktion's. eg, for some reason the top level folder is missing and sometimes the second level
So

Code: Select all

<VSTfolder>/effects/creative/delays/multitap
becomes a menu.submenu called delays.multitap
and

Code: Select all

<VSTfolder>/synths/digital
becomes a menu called digital


It looks like its discarding making menu entries for folders with no actual plugins inside even if they do contain other folders?
John Titor died for your sins!

KVRAF
2253 posts since 25 Aug, 2003 from Bournemouth, UK

Post Thu Jan 03, 2019 4:49 am

Thanks for the feedback. Still work to go on this, I appreciate, but I'm hoping the next few revisions will iron out scanning issues.
Architect, the modular MIDI toolkit, beta now available for macOS, Windows, and Linux.

KVRist
197 posts since 11 Jul, 2004 from Melbourne, Australia

Post Wed Jan 09, 2019 5:07 pm

Hi there, I'm trying Architect (0.95) out at the moment and it seems like it could do great things! But I'm having confusing issues with vst scanning - my desktop has blacklisted vst's that Architect sees ok on my surface pro, and vice versa, seems strange? Still lots of crashing during scanning on both machines. Doing it slowly pointing it at folders at a time instead of the entire vst folder seems to work better, but not always. If you need any other info happy to help.

Return to “Loomer”