Architect (0.9.11 VSTi) - Mixer audio outputs to the Host not working beyond first channel

Official support for: loomer.co.uk
KVRist
68 posts since 3 Mar, 2009 from UK

Post Sun Mar 10, 2019 4:46 am

Hey - bought Architect yesterday and I've been having immense amounts of fun with it!

I've run it as a VSTi under Reaper and FL Studio, and I'm having trouble getting Mixer output channels beyond the first to route audio into the hosts

"Input #1" is fine, but Input #2 to #8 don't seem to be working, is this a known issue? I couldn't see any mention of it in the existing threads here.

[EDIT] Standalone Architect doesn't seem to have any problem routing Mixer Output channels to a multi-channel sound card, it's just the plugin I can't get working..

KVRAF
2253 posts since 25 Aug, 2003 from Bournemouth, UK

Post Sun Mar 10, 2019 6:29 am

Thanks!

Yes, that sounds like a bug. Can I just confirm, is Architect running as a multiple output plug-in in your host? That is, is the host application running it with more channels than just a stereo-output?
Architect, the modular MIDI toolkit, beta now available for macOS, Windows, and Linux.

KVRist

Topic Starter

68 posts since 3 Mar, 2009 from UK

Post Sun Mar 10, 2019 8:08 am

Yeah - in Reaper it's running in a 16 channel track, and in FLS all plugin outputs are set to forward to mixer channels subsequent to the assigned one - the same way other multi-channel plugins are set up - but no dice..

KVRAF
2253 posts since 25 Aug, 2003 from Bournemouth, UK

Post Mon Mar 11, 2019 1:05 am

Thanks. I'll take a look into it this morning .
Architect, the modular MIDI toolkit, beta now available for macOS, Windows, and Linux.

KVRAF
2253 posts since 25 Aug, 2003 from Bournemouth, UK

Post Mon Mar 11, 2019 4:28 am

Right, I think I'm on the case. Just to confirm though, could you send me your REAPER project (or a simplified version of one, even if it's just Architect routed as you normally would route a multi-channel plug-in?) Thanks.
Architect, the modular MIDI toolkit, beta now available for macOS, Windows, and Linux.

KVRist

Topic Starter

68 posts since 3 Mar, 2009 from UK

Post Mon Mar 11, 2019 2:24 pm

emailed support@loomer.co.uk with an example project..

KVRAF
2253 posts since 25 Aug, 2003 from Bournemouth, UK

Post Tue Mar 12, 2019 1:01 am

Superb, thanks.
Architect, the modular MIDI toolkit, beta now available for macOS, Windows, and Linux.

KVRAF
2253 posts since 25 Aug, 2003 from Bournemouth, UK

Post Tue Mar 12, 2019 3:07 am

I believe I've fixed this now. Thanks for reporting. Essentially, I was presenting the output channel information incorrectly, and so (some) hosts would interpret this as a single stereo output.

I need to do some further internal testing before I'm happy releasing these changes to the public, but if you'd like a pre-release copy, just let me know and I will send you a download link.
Architect, the modular MIDI toolkit, beta now available for macOS, Windows, and Linux.

KVRAF
2253 posts since 25 Aug, 2003 from Bournemouth, UK

Post Tue Mar 19, 2019 7:51 am

Could you try the 0.9.12 version, available here? I believe this correctly implements multiple outputs for all plug-in formats.
Architect, the modular MIDI toolkit, beta now available for macOS, Windows, and Linux.

KVRist

Topic Starter

68 posts since 3 Mar, 2009 from UK

Post Tue Mar 19, 2019 3:17 pm

Working great! And now 16 stereo outputs instead of 8 - happy bunny :-D

KVRAF
2253 posts since 25 Aug, 2003 from Bournemouth, UK

Post Wed Mar 20, 2019 1:01 am

Great to hear! Thanks for reporting this, and also for taking the time to provide me with a REAPER project showing the problem.
Architect, the modular MIDI toolkit, beta now available for macOS, Windows, and Linux.

Return to “Loomer”