Architect LADSPA questions

Official support for: loomer.co.uk
prinznika
KVRer
15 posts since 27 Sep, 2019

Post Sun Sep 29, 2019 3:30 am

Hi, I thought I would create this thread to have a place to ask and discuss issues on using the ladspa plugin standart within Architect. I have been experimenting with it for some hours and I feel it is really promising!
However I encountered some issues (2 so far, moreto come the more I experiment)

1 just a little bug: I accidentally deleted a track that had loaded a few ladspa's. Strg + Z killed architect

2 A lot of Ladspa plugins only have one output that defaults to be output on the left channel in architect. I couldnt find an easy solution to make the track mono, which resulted in the sound only playing from one speaker. I guess you could solve this problem with a send track and some panning, but an easy solution would be much preferred.
A feature request could be to be able to run the ladspa individually on each channel (left / right)

however as with all my issues: I am probably missing the obvious

colin@loomer
KVRAF
1799 posts since 25 Aug, 2003 from Bournemouth, UK

Re: Architect LADSPA questions

Post Sun Sep 29, 2019 12:18 pm

Let me investigate tomorrow and get back to you. To clarify, is Strg + Z undo? If so, can you recall which Ladspa plugins you had loaded on the track?
Architect, the modular MIDI toolkit, beta now available for macOS, Windows, and Linux.

prinznika
KVRer
15 posts since 27 Sep, 2019

Re: Architect LADSPA questions

Post Sun Sep 29, 2019 6:24 pm

I will try to recreate the errors tomorrow and try to upload some log files. I am not as experienced with this but i see its a common thing people post in forums and i am happy to help if I get some hints on the right terminal commands

colin@loomer
KVRAF
1799 posts since 25 Aug, 2003 from Bournemouth, UK

Re: Architect LADSPA questions

Post Mon Sep 30, 2019 6:19 am

Thank you. Any help narrowing down plug-ins with problem is very much appreciated. On a standard Linux setup, the Architect.log log-file is in ~/.logs/Loomer.
Architect, the modular MIDI toolkit, beta now available for macOS, Windows, and Linux.

prinznika
KVRer
15 posts since 27 Sep, 2019

Re: Architect LADSPA questions

Post Fri Oct 04, 2019 6:35 am

So I upgraded my system a little bit by following the steps suggested here :
https://wiki.archlinux.org/index.php/Pr ... figuration

As I had just reinstalled my Operating System, I hadnt followed these steps and was using ALSA.
With the new update and the system tweaks, the crashing doesnt occur anymore

Return to “Loomer”