Has Logic Pro X 10.5 broken compatibility with Aspect?

Official support for: loomer.co.uk
bjmensz
KVRer
3 posts since 9 Sep, 2020

Post Tue Sep 08, 2020 7:48 pm

I recently updated to Logic Pro X 10.5 and it has rendered Aspect unusable. Any time I try and interact with the virtual instrument it fully crashes to desktop. The only way I can make it work is if I create an entirely fresh project in which Loomer Aspect is the only track. The second I add another track, then go back to tweak the instance of Aspect it crashes. I've also had it crash just futzing around with a single track of Aspect just going back in forth in the patch selector. It's now totally unusable. I'm running OS X 10.14.6, Logic 10.5.1

colin@loomer
KVRAF
2175 posts since 25 Aug, 2003 from Bournemouth, UK

Post Tue Sep 08, 2020 11:31 pm

Short answer, yes, and I'm looking into it. I know what the issue is, so look to have a fix/update out as soon as possible.
Architect, the modular MIDI toolkit, beta now available for macOS, Windows, and Linux.

colin@loomer
KVRAF
2175 posts since 25 Aug, 2003 from Bournemouth, UK

Post Tue Sep 08, 2020 11:32 pm

As an aside, the same issue affects the latest builds of GarageBand also.
Architect, the modular MIDI toolkit, beta now available for macOS, Windows, and Linux.

bjmensz
KVRer
3 posts since 9 Sep, 2020

Post Wed Sep 09, 2020 9:42 pm

That's great to hear, I like Aspect a lot.

colin@loomer
KVRAF
2175 posts since 25 Aug, 2003 from Bournemouth, UK

Post Wed Sep 09, 2020 11:44 pm

Thanks. I'm gonna be getting a beta together soon with this fixed, as well as the new interface. Would you like me to PM you a link when I've got it ready for download?
Architect, the modular MIDI toolkit, beta now available for macOS, Windows, and Linux.

bjmensz
KVRer
3 posts since 9 Sep, 2020

Post Sat Sep 12, 2020 1:28 pm

Oh definitely, that'd be great

Return to “Loomer”