Tracking Apple Silicon Native Hosts, Plugins, Effects

Configure and optimize you computer for Audio.
User avatar
teilo
KVRian

Topic Starter

1100 posts since 30 Mar, 2008 from MN, USA

Post Tue Sep 28, 2021 10:49 am

Eight4aWish wrote:
Tue Sep 28, 2021 10:27 am
Live 11.1: Apple Silicon Support – Now in Public Beta: Unless I am missing something I don't think this version supports Rosetta bridging to non-native plugins. With that possible caveat it seems to be working fine with native plugins.
Read a few posts up.

User avatar
lb24569
KVRist
40 posts since 12 Mar, 2020

Post Tue Sep 28, 2021 11:04 am

For Ableton Live 11.1 Beta

- AU plugins will bridge using Rosetta
- VST/VST3 need to be native to run in Ableton natively. VST scan will not pick up x86 plugins when running in native mode.
Win 10 9900k 32GB RAM | Ableton | FL Studio | S1 | RME Babyface Pro | Yamaha HS8 | MacOS Big Sur | MBP 15" 16GB RAM | Access Virus TI2 | Fabfilter | T-racks | Izotope

User avatar
bmanic
KVRAF
9237 posts since 3 Feb, 2003 from Finland, Espoo

Post Tue Sep 28, 2021 11:10 am

teilo wrote:
Tue Sep 28, 2021 6:36 am
Tronam wrote:
Thu Sep 23, 2021 3:39 pm
The new plugin by Overloud Audio called Gem Mod 1.0.0 is native on release, alongside all of their other plugins since March.
Only the Gem plugin line is native. Their other products are not.
Overloud TH-U is 100% native too. That's the main reason I bought it.
"Wisdom is wisdom, regardless of the idiot who said it." -an idiot

User avatar
teilo
KVRian

Topic Starter

1100 posts since 30 Mar, 2008 from MN, USA

Post Tue Sep 28, 2021 11:15 am

bmanic wrote:
Tue Sep 28, 2021 11:10 am
Overloud TH-U is 100% native too. That's the main reason I bought it.
Right. I did have that one there already, but missed it when scanning down the OP.

sprnva
KVRAF
2117 posts since 16 Jan, 2013

Post Thu Sep 30, 2021 2:41 pm

Picked up the new (free) Nembrini RAT emulation and noticed that it has native M1 support. As does the other freebies I have (Tube Screamer and Klon).

Interestingly, the Lo-Fi Vintage Clipper which was free at launch is now also M1-native, yet this looks like it still requires iLok. So maybe there's M1 support for iLok on the horizon? Or perhaps iLok was dropped and the site hasn't been updated yet. It's late so I won't be investigating tonight.
Image Image Image Image

tbs
KVRer
21 posts since 8 Mar, 2021

Post Sun Oct 03, 2021 12:18 pm

Toontrack‘s EZdrummer 2.2.2 seems to finally support M1s:
https://www.toontrack.com/release-notes/ezdrummer-2/

User avatar
teilo
KVRian

Topic Starter

1100 posts since 30 Mar, 2008 from MN, USA

Post Mon Oct 04, 2021 8:34 am

sprnva wrote:
Thu Sep 30, 2021 2:41 pm
Picked up the new (free) Nembrini RAT emulation and noticed that it has native M1 support. As does the other freebies I have (Tube Screamer and Klon).

Interestingly, the Lo-Fi Vintage Clipper which was free at launch is now also M1-native, yet this looks like it still requires iLok. So maybe there's M1 support for iLok on the horizon? Or perhaps iLok was dropped and the site hasn't been updated yet. It's late so I won't be investigating tonight.
Not sure what to think about this. I also have LoFi Vintage Clipper, with a freebie license in my iLok dongle. And I can confirm the binary is universal. I'd like to see if this thing will actually load native while still activating, but I can't really do that on my M1 Mini at present, as it is dedicated to other uses.

sprnva
KVRAF
2117 posts since 16 Jan, 2013

Post Mon Oct 04, 2021 8:53 am

teilo wrote:
Mon Oct 04, 2021 8:34 am
Not sure what to think about this. I also have LoFi Vintage Clipper, with a freebie license in my iLok dongle. And I can confirm the binary is universal. I'd like to see if this thing will actually load native while still activating, but I can't really do that on my M1 Mini at present, as it is dedicated to other uses.
Much the same here although I don't have a M1 yet in order to check. Still, I'm keeping a close eye on developments as eventually I will have one and will be only running native software when that happens.

Curiously all the Pace Eden binaries in the plugin are UB2. But the current version of the ILM is still Intel-only.
Image Image Image Image

Ploki
KVRAF
5220 posts since 17 Dec, 2009

Post Mon Oct 04, 2021 9:03 am

:o

i don't have any nembrini stuff but i'm super curious about this
Image

User avatar
teilo
KVRian

Topic Starter

1100 posts since 30 Mar, 2008 from MN, USA

Post Mon Oct 04, 2021 9:17 am

Well, would you look at that:

Code: Select all

file __Pace_Eden
__Pace_Eden: Mach-O universal binary with 2 architectures: [x86_64:Mach-O 64-bit bundle x86_64] [arm64:Mach-O 64-bit bundle arm64]
__Pace_Eden (for architecture x86_64):	Mach-O 64-bit bundle x86_64
__Pace_Eden (for architecture arm64):	Mach-O 64-bit bundle arm64
The iLok License Manager and the Pace LaunchAgent and LaunchDemon should not need to be native for this to work. Libraries communicate with the PACE LaunchAgent via a network socket located at /var/tmp/com.paceap.eden.licensed.agent and the LaunchDaemons at /var/tmp/com.paceap.eden.licensed/authorization

This should theoretically allow native binaries to authenticate through Pace directly, since native and Rosetta2 binaries can communicate through network sockets just fine.

I also checked one of the Nembrini amp sims: Bg Exstasy. Also native.

EDIT: I'm going by the specs listed on the Nembrini website, and noting that all their plugins are now native.
Last edited by teilo on Mon Oct 04, 2021 11:45 am, edited 1 time in total.

Ploki
KVRAF
5220 posts since 17 Dec, 2009

Post Mon Oct 04, 2021 10:24 am

So ilok dependent companies are only lazy af?
Image

User avatar
teilo
KVRian

Topic Starter

1100 posts since 30 Mar, 2008 from MN, USA

Post Mon Oct 04, 2021 10:33 am

Ploki wrote:
Mon Oct 04, 2021 10:24 am
So ilok dependent companies are only lazy af?
More likely that the Eden SDK that is arm-native only came out last month.

User avatar
teilo
KVRian

Topic Starter

1100 posts since 30 Mar, 2008 from MN, USA

Post Mon Oct 04, 2021 11:02 am

Ok. I have confirmed this with Nembrini LoFi Vintage Clipper on my M1 Mini. It is running native, and authenticating against my iLok dongle. I verified it using AudioHijack, and confirmed that it is NOT using the AU hosting service under Rosetta2.

Just to cover all bases, I loaded in the legacy version of Valhalla FreqEcho on the same machine, and when hosting that in AudioHijack, the AUHosting service does show up in the process list as Intel.

So it seems that within the last month or so, Pace came out with a version of the Eden client that runs native. I could not find an announcement anywhere about this.

For the record, it has been possible to sign UB2 binaries with Eden since August 2020.

User avatar
bmanic
KVRAF
9237 posts since 3 Feb, 2003 from Finland, Espoo

Post Mon Oct 04, 2021 11:31 am

Very interesting!!! Maybe things are finally happening on the Pace side? Very promising finding. Thanks for checking this!
"Wisdom is wisdom, regardless of the idiot who said it." -an idiot

User avatar
teilo
KVRian

Topic Starter

1100 posts since 30 Mar, 2008 from MN, USA

Post Mon Oct 04, 2021 11:46 am

bmanic wrote:
Mon Oct 04, 2021 11:31 am
Very interesting!!! Maybe things are finally happening on the Pace side? Very promising finding. Thanks for checking this!
Bracing for the flood.

Return to “Computer Setup and System Configuration”